Speedtest der Server - Ergebnis: teilweise verdammt langsam

Inkognito

Active Member
Hallo,

ich habe mir mal die Arbeit gemacht und mit meiner VDSL 50 Leitung Speedtests der Server zur Stoßzeit wenn die Arbeitnehmer nach Hause kommen durchgeführt. Hier ist das Ergebnis mit meiner nicht VPN-drosselnden 50Mbit Down und 10 MBit Up Leitung:

Kein VPN: PING 15 DOWN 51 UP 10
Amsterdam 1: PING 80 DOWN 2-5 UP 8, grottenschlecht, ist nur ein fünftel ausgelastet
Amsterdam 2: PING 79 DOWN 4 UP 9, braucht deutlich länger zum Connecten als Amsterdam 1!

Brisbane: PING 398 DOWN 3-17 UP 1-2, für den Standort okay
Bucharest: PING 100 DOWN 25 UP 10, in Ordnung
Chicago: PING 123 DOWN 9 UP 8, grauenhaft, US Server müssen flotter laufen
Erfurt 1: PING 35 DOWN 35 UP 5, war mit 400Mbit ausgelastet und deswegen langsamer als Erfurt2 (200Mbit), wieso?!
Erfurt 2: PING 49 DOWN 48 UP 10, top!
Frankfurt: PING 29 DOWN 50 UP 10, da der Server neu konfiguriert werden musste ist hier nix drauf los (20Mbit) weswegen der jetzt läuft, gab sonst Probleme, werde das im Auge behalten

Huenenberg: PING 45 DOWN 50 UP 10, top!
London 1: PING 36 DOWN 50 UP 10, top!

Montreal 2: PING 114 DOWN 31 UP 10, ist okay
Moscow 1: PING 235 DOWN 0,04-3 UP 0,5, brauchte mehr als eine Minute zum Connecten!, ist praktisch nicht zu gebrauchen, schlimmer als ISDN, das geht bei anderen Moskau Servern deutlich besser!, liegt NICHT am Standort!
Paris: PING 32 DOWN 50 UP 10, top!
Reykjavik: PING 75 DOWN 10 UP 1,3, in Ordnung
Rotterdam 1: PING 35 DOWN 43 UP 10, gut
Rotterdam 2: PING 35 DOWN 50 UP 10 , gut

Sao Paulo: PING 245 DOWN 3 UP 1, naja
Steinsel 1: PING 47 DOWN 25 UP 10, mies, nur 300Mbit ausgelastet, das ist ein GIGABIT Server!
Steinsel 2: PING 41 DOWN 50 UP 10, top! ist aber auch leicht weniger als Steinsel 1 ausgelastet
Stockholm 1: PING 57 DOWN 5 UP 10, grottig, war nur mit 20 Mbit ausgelastet

Die Wertung inklusive Farbe ist dem Standort angepasst.


Ziel sollte es sein, alle Gigabitserver auf grün zu bekommen und die roten mindestens auf gelb!

@PP: wenn ihr selber testet dann mit OpenVPN unter Windows und Wochentags von 18 bis 20 Uhr, also dann, wenn am meisten lost ist.
 

PP Frank

Staff member
https://www.perfect-privacy.com/ger...t-windows/ipsec-ikev2-certificates-windows-7/

Also wer probleme mit OpenVPN hat, der hat jetzt Plan B. ich habe das gerade auf dem Windows-rechner der bei mir mit OpenVPN stresst getestet und der haut hier 89 MBit über Amsterdam raus. Das wären noch mehr, wenn da nicht PowerLAN bei mir das etwas begrenzen würde. Der andere Rechner(MacOS) direkt am Router macht auch durchaus 110 MBit auf Amsterdam
 

BT2

Member
Bei mir kommt leider folgende Fehlermeldung, obwohl der Cert-Installer angibt, das Zertifikat sei ordnungsgemäß installiert:

osgfvhgc.png
 

PP Frank

Staff member
Du darfst nicht die Server direkt anwählen. Du musst die Gruppe nehmen. Also rotterdam.perfect-privacy.com und nicht rotterdam1.perfect-privacy.com sonst haut das cert nicht hin.
 

mike321

Member
hab alles so gemacht wie im tutorial, nur beim server das hier eingegeben:
rotterdam.perfect-privacy.com

die verbindung steht, allerdings bekomme ich keinen internetzugriff und keine ip adresse :(
 

mike321

Member
anbei vier bilder. auf dem einen bild kann man sehen, es geht kein traffic nach draussen?

verwende comodo internet security und hab testweise die firewall deaktiviert.
 

PP Frank

Staff member
Hattest du den VPN Manager drauf? bzw hast den noch? Hast du dort die Firewall-Optionen gesetzt? Wenn ja, mach die mal raus.
Geh auch sicherheitshalber ins Netzwerk und Freigabecenter und setze die Windows Firewall zurück
 

PP Lars

Staff member
So liebe Leute.. ich hab jetzt mal paar Tage nix geschrieben sondern debuggt.
Also:

- Die neuen Amsterdam1 und 2 haben je nachdem aus welchem Netz man kommt eine hohe latenz. Das liegt an leaseweb, ich stehe in Kontakt mit denen.
Sollten die das nicht repariert bekommen werden wir die Server ersetzen.

- Weniger als 5 Leute haben das Problem das sie egal was sie machen auf genau 5 oder 10 mbit kommen. Das ist ein Bug irgendwo , haben wir jetzt mit mehreren OpenVPN Version Server und Client seitig ausprobiert. und mit mehreren Windows Versionen. Unklar. Da arbeiten wir dran.


Und dann: Alle wollen die beste crypto, openvpn soll überall funktionieren, und am besten soll da auch in der einen stunde peakzeit am tag die 50-100 mbit DSL Leitung durch passen.
Wer möchte kann sich ja mal das: https://community.openvpn.net/openvpn/wiki/Gigabit_Networks_Linux durchlesen. Da steht drin wie man OpenVPN super optimieren kann.
Das Problem ist: Dann funktioniert das einfach bei 20-40% der Mitglieder nicht weil irgend ein Schrott Router nicht klarkommt, oder das DLS Modem rumspinnt oder das verfrickelte windows/linux oder oder oder, wir ham damit schon rumprobiert, geht einfach nicht.
D.h. Im Endeffekt müssen wir stärkste crypto in Kombination mit relativ kleiner packetgröße verwenden. Das sind aber genau die killer die man eigentlich vermeidet wenn man das auf performance optimiert.
Ich hab auf unseren Servern gebenchmarkt. Ein einzelner Xeon 2.4 Ghz Kern schafft für einen OpenVPN Process 120-140mbit.
Um das auszugleichen haben wir zur Zeit 4 OpenVPN Prozesse laufen, ich werde das auf 8 ausbauen.
Aber ihr seht das Problem oder? Erstens: Wer nicht schon selber in seinem Rechner ne fette CPU hat kommt auch nicht auf super hohe Bandbreiten.
Und 2. Das viel größere Problem: Irgendwie kommen in den 2 Stunden am Tag wo eh am meisten auf den Servern los ist auch noch alle auf die idee "oh, jetzt könnte ich doch mal nen speedtest machen um zu schauen wie gut das so unter Last funktioniert." Das kann nicht funktionieren.
Eigentlich sind genau diese Tests, so verlockend sie sind, echt scheisse gegenüber den anderen Mitgliedern. Ihr seht das auf dem Server viel los ist, vermutet er könnte evtl am Limit sein, und um das zu testen macht ihr noch mehr, total sinnlosen Traffic und load. Und das macht ja nicht einer. Sondern mehrere. Dann ist er lahm und ihr kommt im Forum Pöbeln wie scheisse doch pp ist. hrm.

Ich werde jetzt 2 Sachen machen. Erstens kurzfristig: OpenVPN von 4 auf 8 Prozesse umstellen, das bekommt ihr als User nur kurz mit wenn dann Nachts OpenVPN reconnected weil ich den service neu starten muss. Das mach ich wahrscheinlich innerhalb von 14 Tagen, jede Nacht mal 2-3 Server.
Und 2. Längerfristiger: Zur Zeit hat fast keiner unseren Server eine CPU mit nativem AES support. Das werden wir wo es möglich ist Stück für Stück ändern .


Grüße
Lars
 

fx-13

Member
Kleine Anmerkung dazu:
Ich benutze in der Regel die Ping-Funktion eures Managers bevor ich zu einem Server connecte. Amsterdam gibt dabei üblicherweise sehr gute Werte.
(London noch bessere. Das finde ich merkwürdig bis fast schon verdächtig, aber darum geht's hier nicht.)
 

Ghost

Active Member
Ich werde jetzt 2 Sachen machen. Erstens kurzfristig: OpenVPN von 4 auf 8 Prozesse umstellen, das bekommt ihr als User nur kurz mit wenn dann Nachts OpenVPN reconnected weil ich den service neu starten muss. Das mach ich wahrscheinlich innerhalb von 14 Tagen, jede Nacht mal 2-3 Server.
Und 2. Längerfristiger: Zur Zeit hat fast keiner unseren Server eine CPU mit nativem AES support. Das werden wir wo es möglich ist Stück für Stück ändern .

Das finde ich super von euch!!!
Weiter so. Danke:)
 

Inkognito

Active Member
PP Lars;n5752 said:
So liebe Leute.. ich hab jetzt mal paar Tage nix geschrieben sondern debuggt.

Daumen hoch! Finde es klasse, dass du dir das Problem angesehen hast und auch erklärt hast, wieso ihr aus OVPN serverseitig nicht das Performancemaxium herausholen könnt.

Trotzdem noch ein paar Kleinigkeiten:

1. Ein Speedtest dauert evtl. 20 Sekunden und ich bezweifle sehr stark, dass die Mitglieder das so oft machen, dass das zu Problemen führt vorallem wenn man sieht, wie viel Luft nach oben auf den Servern ist (zumindest von der Bandbreite her)
2. Könntet ihr mit den Gigabit Servern bezüglich der Process-OVPN-Umstellung anfangen? Die sind ja auch primär betroffen.

Bin mal gespannt ob die 8 Prozesse etwas bringen.
 

PP Frank

Staff member
2. Das werden wir nach und nach machen und wenn nur die Gigabit Server, auf den anderen ist nichts nötig. Den Frankfurt Server hatten wir eh schon auf der Tauschliste. Alles andere ist auch eine finanzielle Frage. Da muss schon ein schönes Angebot da sein, der zum Tausch motiviert.
 

Inkognito

Active Member
Den Frankfurt Server bitte nicht abschaffen bzw tauschen! Das ist der Server mit dem besten Ping für fast alle in DE egal woher (klasse Routing?) und der ist auch immer flott bis auf die Lastzeiten. Und das Problem liegt ja anscheinend nicht spezifisch am Frankfurt Server, das Problem haben ja alle mit OVPN.

Oder ist der auch mit anderen Protokollen lahm? Wenn schon etwas ändern dann bei den DE Servern dynamische IPs buchen.
 

PP Frank

Staff member
Der Frankfurtserver wird getauscht weil der eine ziemlich alte CPU hat. Wenn werden wir aber beim gleichen RZ was neues holen was im Angebot is

Und wenn du mal auf die Serverliste guckst, dann hat Frankfurt schon ein paar mehr IP's
 

PP Lars

Staff member
So, Amsterdam 1 und Paris sind die ersten die 8 OpenVPNs laufen haben.

Wer spielt mit nachher mal ne runde Amsterdam 1 quälen?

Ich würde sagen um 20 Uhr deutscher Zeit, dann ham wir noch n bischen Vorlauf damit auch jemand sieht was ich hier schreiben.
Alle per OpenVPN auf Amsterdam1, und torrents an. Ich bin auf der Kiste und beobachte top. Dann machen wir da ne viertel Stunde lang Action um mal zu sehen wo das Limit ist :)


Grüße
Lars


By the way,
im Moment hat Amsterdam1 wieder sein Latenz Problem, zumindest aus dem Netz wo ich herkomme. D.h. ich komm mit speedtest.net auf 5mbit, wenn ich aber mal probeweise nen debian torrent anmache ist der sofort auf 50mbit. Also speedtest.net spinnt auch öfter mal rum.
 
Top