Anleitung: On-Demand-VPN mit iPhone und iPad (IKEv2)

Discussion in 'iOS' started by PP Stephan, Aug 9, 2016.

  1. PP Frank

    PP Frank Staff Member

    Eigentlich ist die nicht notwendig.... Eigentlich....
     
  2. D

    Diddle24 New Member

    Vielleicht wär es nicht doch eine Überlegung wert!
     
  3. k

    krox Member

    Mal wieder 'ne Frage... habe in den letzten Wochen öfter mal WiFi in Hotels nutzen müssen und da keinerlei Probleme mit der VPN Verbindung über ikev2 gehabt. Wirklich NULL Probleme. Keine Tunnelabrisse, nichts! Auch im Mobilfunknetz haben sich die Probleme drastisch reduziert, warum auch immer.

    ABER zu Hause bestehen die Probleme immer noch! Daher frage ich mich, ob's evtl. mit dem Router (speedport v723v typ b) zu tun haben könnte? Müssen da Ports freigegeben werden??? UDP 500 und 4500?

    Mir geht das so was von auf den Keks, seit Monaten dieser Mist! Habe schon daran gedacht, nen anderen Router zu bestellen...
     
    Last edited: Dec 22, 2017
  4. D

    Diddle24 New Member

    Welchen Router hast du?
     
  5. k

    krox Member

    Hi, einen speedport v723v typ b.
     
  6. D

    Diddle24 New Member

    Interessant, ich hab ein Speedport 921v. Kammes doch ein Routerproblem sein?
     
  7. PP Frank

    PP Frank Staff Member

    Hast du in dem Speedport irgendwelche Sicherheitseinstellungen?
     
  8. k

    krox Member

    Hi Frank! Nee, mal abgesehen von der MAC Filterung geht da nicht viel mit der Kiste. Aber was soll ich sagen, mich hat's zu sehr gewundert, dass es im LTE Netz sowie in den oben erwähnten Hotel WLANs keinerlei Probleme mehr gab, deshalb hab ich mir heute Morgen 'ne Fritzbox 7590 besorgt und mit der läuft's seit etwa 9:30 Uhr reibungslos und fehlerfrei.

    Werde das mal weiter beobachten und dann hier kurz Rückmeldung geben.
     
  9. D

    Diddle24 New Member

    Ich hab auch keine Sicherheitseinstellungen verändert.

    Gutes neues Jahr noch!!
     
  10. k

    krox Member

    Frohes neues Jahr euch!

    Also, seit ich am Samstag den Speedport in Rente geschickt und die Fritzbox in Betrieb genommen habe, gab es keinerlei Probleme mehr. Ich musste auf keinem der iOS Geräte die Verbindung trennen und neu verbinden, so wie es die letzten 6 Monate gefühlte 100x am Tag nötig war. Die Geräte verhalten sich so, wie sie sich mMn auch sollen. Der Tunnel wird im Standby/deepsleep getrennt und bei Aktivierung des Displays sofort wieder aufgebaut. Scheint dann wohl wirklich am Speedport bzw an einem der letzten Updates für die Kiste gelegen zu haben. Bin wirklich froh, dass ich das in den Griff bekommen habe.

    ABER ich hätte da noch ein Problem, auch wenn es hier nicht rein passt. Möchte nicht extra einen neuen Beitrag aufmachen, also bitte Verschieben, falls es jemand für nötig hält.

    Auf dem PC habe ich PLEX am laufen, nur um im Heimnetz zum TV zu streamen. Mit aktivierten Firewall Einstellungen im VPN Manager kann ich keine Verbindung vom TV zu PLEX herstellen.

    Es scheint an der ausgehenden Regel "Perfect Privacy VPN Networking LAN" zu liegen, denn stelle ich dort unter Eigenschaften>Bereich>Remote IP Adresse von "diese IP Adressen 192.168.0.0/16, 172.16.0.0/12, 10.0.0.0/8" um auf "beliebige IP Adresse" klappts mit der Verbindung. War mir dann aber nicht sicher, ob ich das so lassen sollte und habe wieder auf die vordefinierten Adressen umgestellt und den vordefinierten Computersatz "lokales Subnetz" hinzugefügt.

    Frage jetzt an die PP Jungs, kann ich das so lassen, oder hab ich mir damit ne Sicherheitslücke eingebaut?

    Nachtrag: Kann ich erreichen, dass die Regel nicht nach jedem Start des VPN Managers überschrieben bzw. der Zusatz "lokales Subnetz" gelöscht wird?
     
    Last edited: Jan 1, 2018
  11. D

    Diddle24 New Member

    Ich weiß jetzt auch nicht was ich im Speedport verändern müsste, damit es geht. Da hab ich zu wenig Ahnung davon.
     
  12. k

    krox Member

    Da kann man ja nicht viel einstellen und alles was möglich ist, habe ich probiert. Leider ohne Erfolg.

    Mit der Fritzbox sind immer noch keine Probleme aufgetreten, kann's gar nicht fassen :D
     
  13. m

    manuel plausen New Member

    Beim Verbindungsaufbau habe ich ständig einen ip leak von 1-2 sekunden. Kann ich das ändern? Es leuchtet kurz das wlan symbol auf, nach ein paar sekunden erscheint dann das wlan symbol inkl vpn. Auch apps in denen ich die hintergrundaktualisierung deaktiviert habe erhalten in der zwischenzeit meinw geleakte ip...
     
    ItsFe likes this.
  14. I

    ItsFe Active Member

    Bei mir leakts nur ganz kurz wenn ich WLAN ausmache und auf LTE wechsle :/
    Werde wohl mein iPhone in den Supervised Mode packen müssen um Always On VPN zu aktivieren.
     
  15. k

    krox Member

    ACHTUNG! Weiss nicht, ob es nur mich betrifft, aber wenn ich mich derzeit mit einem iOS Gerät über ikev2 im WLAN mit Zürich oder Erfurt verbinden möchte, kommt keine Verbindung zustande, in der Statusbar wird nicht mehr das WiFi Symbol angezeigt, sondern LTE und man ist ohne VPN im Mobilfunknetz unterwegs. Gerade mehrmalig mit diesen beiden Servern getestet, auch habe ich beide Profile erneut heruntergeladen und installiert.

    Auf den Geräten läuft iOS 12.3.1

    NACHTRAG: Frankfurt verbindet zwar, aber es gehen keinerlei Daten durch.
     
    Last edited: May 26, 2019
  16. k

    krox Member

    Momentan schaut es so aus, dass Erfurt auf einem der iOS Geräte läuft, aber ich mich dann mit keinem weiteren mehr anmelden kann.

    Wurde da eurerseits was geändert?
     
  17. PP Simon

    PP Simon Staff Member

    Hallo @krox, bitte warte mindestens eine Minute zwischen den einzelnen Verbindungen und versuche es dann erneut. Wenn mehrere Geräte im LAN kurz hintereinander die IPsec/IKEv2-Verbindung aufbauen, kann es unter Umständen zu Problemen führen, sodass dein Router die Verbindungen nicht mehr richtig den einzelnen Geräten zuordnen kann.
     
  18. k

    krox Member

    Hi Simon, habe ich schon bemerkt und bin auch so, wie von Dir vorgeschlagen, vorgegangen.

    Zu den Abbrüchen bei Zürich und Erfurt kommt es immer noch, das gravierende ist, dass man danach mit der mobilen Datenverbindung ohne VPN verbunden ist, das Problem mit Frankfurt 1 besteht ebenfalls weiterhin, jedoch nur gelegentlich und ich kann es nicht rekonstruieren.

    Solltet ihr Eurerseits nichts geändert haben, haben sich mit dem iOS 12.3.1 Update wohl einige Bugs diesbezüglich mit eingeschlichen.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice