Tipps & Tricks: Enigma2(ATV&VTI) PP Plugin Anleitung&Download

Discussion in 'Linux' started by PP Frank, Oct 5, 2018.

  1. m

    murxer Member

    @moejoe
    Also habe dieses Problem nicht, meine Boxen laufen schon seit 4 Wochen durch.
    Auch habe ich keinen Neustart vom OpenVPN ausgeführt, läuft Super bei mir.
     
  2. m

    moejoe Member

    Evtl. Isses ein vti problem

    Grüsse
     
  3. s

    silverxx New Member

    Mit der Status Anzeige konnte ich im Original VPN Plugin auf "Show openvpn status" klicken und habe dann direkt sämtliche Infos angezeigt bekommen. Ging recht schnell, aber wenn du einen Skinpart erstellst, wäre es super. Man muss das vorinstallierte openvpn Plugin ja komplett deinstallieren, damit man dieses hier benutzen kann, oder? Zumindest hat das bei mir Probleme gelöst.

    Auch den Fix, dass das Plugin sich jedes mal neu verbindet, wenn man das Einstellungsmenü verlässt und kein Cascade benutzt wäre top.

    Was mir noch aufgefallen ist, dass beim starten der VU+ die Box sich bereits mit dem Internet verbindet, eine IP bekommt und erst nachdem diese paar Sekunden vollständig hochgefahren ist sich mit dem PP Server verbindet und dann eine andere IP bekommt. Dies führt zu Problemen, wenn man bereits beim hochfahren mit IPTV verbunden ist.

    Kann man den Start vom Plugin bzw. die Verbindung zum PP Server irgendwie beschleunigen oder beeinflussen, damit die Box schon eine vollständige Verbindung hat bevor diese überhaupt auf irgendwas anderes zugreift?
    Ansonsten muss ich das über die Portfreigabe und Filter der Fritzbox lösen...
     
  4. m

    murxer Member

    @silverxx

    Den Fix für das erneute Verbinden, habe ich schon abgearbeitet, Update wird dann auch bald kommen.

    Also wegen VU Box Neustarten ja das ist so eine Sache, jedes Image Bootet anders, aber wenn du IPtables aktiviert hast, macht das keine Probleme, weil
    IPtables die Regeln schon vorm Netzwerkstart setzt.
    Somit funktioniert auch IPTV nicht, erst nach dem eine VPN Verbindung besteht.

    Wenn jetzt bei deiner Box IPtables nicht funktioniert dann, müsstest du es über die FritzBox machen.

    Bei VTI ist es so das erst eine VPN Verbindung besteht wenn das Gui geladen ist, weil die Box im Jahr 1970 startet.
    Das ist bei OpenATV wiederum nicht, da geht alles schneller weil die Box beim Starten auch das richtige Datum/Zeit hat.

    Weil man kann nur eine OpenVPN Verbindung mit dem richtigem Datum und Zeit angaben aufbauen.

    Skinpart's sind schon in Arbeit.
    DreamOS mit Zombi Skin habe ich schon erstellt https://www.boxpirates.to/index.php...fullhd-only-dreamos/&postID=940960#post940960

    Für OpenATV Default Skin habe ich auch schon eine Version, die ich aber noch mal überarbeiten möchte, dann erst gebe ich sie frei.
    Was für Infos sollten eigentlich alles abgefragt werden?

    Edit:
    Die Ports die du in der FritzBox freigeben musst, stehen in der pp_iptables im Plugin Ordner.

    LG murxer
     
    Last edited: Nov 27, 2018
  5. s

    silverxx New Member

    Ich habe IPtable deaktiviert und es nun über die Portfreigabe der Fritzbox gemacht.

    Folgende Ports müssen gesperrt werden...
    bei UDP:
    TCP beliebig - beliebig
    UDP 1 - 52
    UDP 54- 147
    UDP 152 - 1147
    UDP 1152 - 65535

    Bei TCP:
    UDP 1 - 52
    UDP 54 - 65535
    TCP 1-141
    TCP 143 - 151
    TCP 153 - 299
    TCP 302 - 1141
    TCP 1141 - 1143
    TCP 1143 - 1151
    TCP 1153 - 65535


    Also Skinpart Info würd mir eigentlich folgende reichen
    Verbunden/Nicht verbunden evtl. mit grün/rot lösen , IP, Land


    Folgender Fehler ist mir im Plugin noch aufgefallen: Wenn ich den VPN über die Fernbedienung stoppe, kommt es zu einem "http....." Fehler.
    Er wird zwar gestoppt, aber es erscheint ein Fehler in der Überischt.
    Kannst du ja mal testen.


    Danke.
     
  6. m

    murxer Member

    Wenn du alle Ports in der pp_iptables.sh frei gibst kommt es auch nicht zu dieser Fehlermeldung.
    Du sperrst ja das Plugin mit deinem Filter auch aus, du musst auch https(443) frei geben.
    Sonst kann ja der Server Status nicht abgefragt werden.

    Wenn bei dir IPtables funktioniert, dann nutz es doch, kommt zum gleichem Ergebnis.
     
  7. m

    moejoe Member

    @murxer:

    ich probiers jetzt einfach nochmal mit cascading.. mal schauen ob der Fehler nochmal auftritt

    grüsse
     
  8. M

    Martina New Member

    Vielen Dank für das tolle Plugin!
    Thematisch noch eine passende Frage dazu: Wenn ich jetzt einfach nur eine IP aus einem anderen Land und dazu noch eine stabile Verbindung brauche auf meiner Enigma2-Box (und Anonymität und Verschlüsselung ausnahmsweise einmal nachrangig sind), ist dieses Plugin doch überschießend. Wäre es da klüger Socks5 zu konfigurieren? Wenn ja, wie mache ich das, mit automatischem Verbinden beim Start der Box + eventuell Backup-Server konfigurieren, falls der 1. mal nicht will.
     
  9. m

    murxer Member

    @moejoe
    ja mach das

    @Martina
    Sorry mit Socks5 kann ich dir nicht weiter helfen.
     
  10. a

    andre74 New Member

    Bin jetzt auch endlich auf dieses tolle Plugin gestossen.
    Nutze es auf meiner VU Zero mit VTI 14.
    Läuft bis jetzt tadellos.
    Was ich mir auch wünschen würde wäre eine Information in der Infoleiste... VPN an/aus, IP (Land), Ping

    Wäre super wenn das möglich wäre.
     
    Last edited: Dec 3, 2018
  11. p

    pepe79 New Member

    Hallo murxer, bin auch zufällig auf das Plugin gestoßen und möchte mich herzlich bei Dir bedanken ☺️
    Einfach genial für Laien wie mich , ich habe mich wirklich mega gefreut .1000 Dank

    Nur zur Info

    Mein System Vu Solo 4k und Solo Se 2v
    Auf der stärken 4k mit Amsterdam Server 4 einen Ping von 18.756 und Downloadspeed von knapp 40 Mbit laut Netspeed Test

    Mit der kleinen Solo Se 2v Ping von 48.72 und Download von 11 Mbit
    Open ATV 6.2

    Viele Grüße
     
  12. m

    murxer Member

    @andre74
    Eine Infoleiste in der InfoBar ist, schon möglich.
    Ich habe jetzt schon ein paar Skinparts erstellt, nur für jeden Skin müsste man das dann auch erstellen.
    Die Info ist aber ohne Ping, das dauert zu lange, dann kann es auch sein das immer der Spinner kurz kommt wenn du die InfoBar öffnest.
    Darum ohne Ping.

    Skinparts die ich jetzt schon erstellt habe:
    OpenATV Metrix Skin(Default-Skin)
    VTI-OpenATV iFlat Skin getestet auf VTI 14
    DreamOS MetrixStyle und ZombiFHD

    VTI-OpenATV gibt es bis jetzt nur diese Einstellung:
    [​IMG]

    OpenATV gibt es 2 Möglichkeiten:
    [​IMG]

    Wenn ich alle erstellt habe, dann werde ich sie zum Download bereit stellen.
    LG murxer
     
    Last edited: Dec 4, 2018
    andre74, virtualagent and sheracircus like this.
  13. a

    andre74 New Member

    Mir ist noch etwas aufgefallen.
    Ich muss die Option "reneg-sec" manuell auf 86400 stellen um nicht stündlich Aussetzer zu haben.
    Wäre es möglich eine Config-Option dazu zu erstellen?
    So dass ich nicht immer über Telnet alles ändern muss?
     
  14. m

    murxer Member

    @andre74
    werde "reneg-sec" im ConfigScreen hinzufügen.
    Werde es dann heute gleich mal umsetzen.

    LG murxer
     
  15. m

    murxer Member

  16. m

    moejoe Member

    @andre74
    Hast du wie ich nach ein paar Tagen irgendwelche temp dns errors wenn du cascade benutzt ?

    Grüsse
     
  17. a

    andre74 New Member

    @moejoe
    Cascade nutze ich bis dato nicht.
     
  18. a

    andre74 New Member

    @murxer
    Top... Alles läuft perfekt.
    Vielen Dank dass du die Wünsche so konsequent umsetzt.
     
    murxer likes this.
  19. s

    sheracircus New Member

    @murxer

    Ich nutze die aktuellste Version deines Plugins, neuestes VTI-Image mit IflatHD Skin und deinen Skinparts.

    Mir ist folgendes aufgefallen:

    Nutze ich als Server einer der Nuremberg-Server, hängt sich fast die komplette Box dann auf, wenn man aus dem Menü rausgeht, da er in der Infobar Nuremberg irgendwie nicht anzeigen kann. Bei Frankfurt2 steht ja z.B. auch Innenstadt in Klammern dahinter. Bei Nuremberg, egal ob 1 oder 2, ist dann in der Infobar nur der grüne Punkt und VPN steht dahinter und wie bereits gesagt lässt sich die Box fast nicht mehr bedienen, da er Nuremberg irgendwie nicht aufschlüsseln kann. Habe jetzt nicht jeden einzelnen Server ausprobiert, aber bei Nuremberg wird die Box fast unbedienbar und es dauert alles ewig und der Spinner läuft und läuft und läuft.

    MFG
     
  20. m

    murxer Member

    @sheracircus

    Habe versucht es nachzustellen, bei mir funktioniert es aber ohne Probleme.
    Wähle noch mal den Nuremberg Server, dann schau Bitte in /tmp/ipdata nach was da genau drin steht.
    zum vergleich hier meine ipdata wenn ich Nuremberg 1 oder 2 wähle.

    {"as":"AS201011 AS33891 Netzbetrieb GmbH","city":"Nuremberg","country":"Germany","countryCode":"DE","isp":"CORE-BACKBONE","lat":49.452,"lon":11.0767,"org":"Perfect Privacy Payments LTD.","query":"81.95.5.44","region":"BY","regionName":"Bavaria","status":"success","timezone":"Europe/Berlin","zip":"90403"}


    LG murxer