Anleitung: Perfect Privacy VPN auf Vilfo-Routern einrichten

beng

Freshly Joined Member
Habt ihr denn bezüglich Killswitch-Funktionalität mal bei Vilfo direkt nachgefragt ob dort eine Integration geplant ist? Im übrigen sind die erwähnte gewollte, absichtliche Trennung einer VPN-Verbindung und eine ungeplante Unterbrechung der Verbindung zwei unterschiedliche Fälle. Daher bietet der VPN-Manager unter Windows da auch mehrere Möglichkeiten den Leak-Schutz einzustellen.

Der Vilfo Router bietet in den Einstellungen die Funktion Killswitch an. Ich habe die Möglichkeit diese Ein/Aus zustellen. Leider greift diese Funktion nicht bzw. bei einer ungeplanten Unterbrechung gehen die angebundenen Clients über das im Vilfo Router hinterlegte reale Gateway ins Netz. Eine ensprechnde Anfrage habe ich heute gestellt Vilfo.
 

Chegga87

Junior Member
Der Vilfo Router bietet in den Einstellungen die Funktion Killswitch an. Ich habe die Möglichkeit diese Ein/Aus zustellen. Leider greift diese Funktion nicht bzw. bei einer ungeplanten Unterbrechung gehen die angebundenen Clients über das im Vilfo Router hinterlegte reale Gateway ins Netz. Eine ensprechnde Anfrage habe ich heute gestellt Vilfo.


Hab direkt am selben Tag als ich hier die frage stellte auch bei Vilfo nachgefragt, bisher keine Antwort.
Find ich etwas schade angesichts dessen was man für das Teil blechen muss.

Ich habs übrigens auch schon mit Gruppen versucht, sodass ich die VPN Verbindung garnicht trennen muss sondern das jeweilige Gerät von der einen zur PP Verbundenen Gruppe in die andere zur PP Verbundenen Gruppe switche, selbst dort wird kurzzeitig die reale IP gesendet.
Frag mich echt wieso die mit einen Killswitch werben der anscheinend NICHT funktioniert.

Ich verstehe unter Killswitch, wenn ich ihn aktiv habe das unter keinen umständen meine reale IP adresse sichtbar wird ... anders macht für mich der Name keinen sinn.
 

Gerd

Active Member
Da Vilfo auf OpenWRT Firmware basiert, kann ich vielleicht bei der Konfiguration eines Kill-Switchs helfen.

Kann ein Vilfo Router Besitzer per WinSCP oder SCP mit dem Vilfo Router verbinden und den Inhalt der Dateien

/etc/config/firewall
/etc/config/network

hier posten?
 

Aybee

Freshly Joined Member
Ich hole das Thema noch einmal hoch. Gibt es dazu inzwischen eine Lösnung oder Nachricht von Vilfo?

Ich hab genau das gleiche Problem, der Killswitch funktioniert auch bei mir nicht wenn ich die VPN Verbindung trenne, ohne Killswitch ist das ding einfach nix wert für mich.

Hier die Antwort von Vilfo:

Hello!
It's working as intended. The killswitch activates if you unexpectedly disconnect from the VPN. That is, if you're connected to a VPN server and the connection drops without your intervention, the killswitch activates to block your internet connection. It does not activate if you disconnect manually
We've received some feedback about people wanting to be able to disconnect manually and have the killswitch kick in so that's something we're considering adding.
Do note that there is a Block button in the Devices menu that blocks internet for said devices, so if you need to switch to a new location, you can block internet for them, disconnect, and then connect to a new region. It's also possible to move devices over to a new group with a different VPN connection
 
Last edited:

misa60

Freshly Joined Member
Hat jemand bereits erfahrung ob man der Aussage von Vilfo trauen kann mit dem Killswitsch ? Oder ob er überhaut geht?
 

Chegga87

Junior Member
Na schön das überhaupt mal wer eine Antwort bekommt von Vilfo.
Es ist ja gut und schön das der Kill-Switch aktiv ist wenn die Verbindung unerwartet getrennt wird.
Mir gehts aber darum absolut nichts durchzulassen wenn ich es nicht will, so wie es sich auch gehört, heißt der Killswitsch soll auch aktiv bleiben wenn ich selber die VPN Verbindung trenne um zb den Server zu wechseln, wieso Vilfo das nicht kapiert und das nicht von anfang an so eingebaut hat ist mir ein Rätsel. Das kriegt selbst jeder Asus Router so hin und da ist die VPN funktion nur ein extra.
Aber schön das sie jetzt immerhin erwägen die funktion einzubauen und sich erst was weiß ich wieviele User beschweren müssen.

Ich benutze den Router derzeit als cascade, also VPN läuft auf den Router und zusätzlich benutze ich noch den VPN Mangaer der wenigstens nichts durchlässt. Der Router alleine ist mir derzeit zu unsicher, solange sie die (All)blockfunktion noch nicht eingebaut haben.
 

Aybee

Freshly Joined Member
Vifo ist leider was Entwicklung angeht sehr sehr langsam, die hängen seit Wochen in der Roadmap am letzten Task. Antwort bekomme ich zu 90% immer eigentlich mal am selben Tag aber auch oft Tage später. Der Support ist leider nur bis 17 Uhr zu erreichen, zählt übrigens auch für deren Schwester VPN Firma, sind so sachen die ich nicht begreife.

Mit dem Killswitch habe ich denen auch 2-3 mal erklärt was diese funktion für einen Sinn hat, der Killswitch soll immer dann greifen wenn eine Verbindung getrennt,abgebrochen wurde egal ob ich das selbe war, es Probleme beim Anbieter gibt oder ob der Liebe Gott es war Killswitch => Trennen sofort!

Der Router hat leider noch einen Bug (bei mir jedenfalls) wenn ich Geräte in eine VPN Gruppe schieben und die VPN gruppe noch nicht Verbunden ist, trennen sich alle Verbindungen von allen Geräten egal in welcher Gruppe Sie sind, ich hab dann auf keinem Gerät mehr Internet. Ich weiß nicht ob es daran liegt das Vilfo immer den DNS nimmt von der Gruppe die als letztes sich Verbindet und die Geräte dann beim DNS wechsel Probleme bekomme oder ob es ein Bug in der Software ist.

Die Funktion des DNS manuel setzten im Vilfo ist übrigens nur dafür da wenn man mit keinem VPN Verbunden ist.

Probiert es mal aus
 
Last edited:

Chegga87

Junior Member
@Aybee: Mit dem Killswitch habe ich denen auch 2-3 mal erklärt was diese funktion für einen Sinn hat, der Killswitch soll immer dann greifen wenn eine Verbindung getrennt,abgebrochen wurde egal ob ich das selbe war, es Probleme beim Anbieter gibt oder ob der Liebe Gott es war Killswitch => Trennen sofort!

Und genauso sehe ich das nämlich auch, nur das bietet maximale Sicherheit. Alles andere wäre, ja könnte Sicherheit bieten oder auch nicht. So eine Konfiguration ist mit OpenWRT auch problemlos möglich, keine ahnung wieso die das nicht so gemacht haben oder zumindest dann 2 Verschiedene Optionen das man es so haben kann wie es im moment ist oder eine 100% disconnection und blocking egal wie getrennt wird.
 

Chegga87

Junior Member
Wollte mal einen Zwischenbericht abgeben, da ich den Vilfo Router jetzt schon länger verwende.
Mir ist aufgefallen das der Kill Switch tatsächlich überhaupt nicht existent ist, der Router verbindet gnadenlos mit dem Internet ob die VPN Verbindung abricht, man ihn selbst unterbricht oder sich der VPN dienst gerade neu Verbindet.
IP Leaks sind garantiert!

Bisher kam auch kein update der dies unterbindet, meiner Meinung nach ein echtes unding dafür das man mit einem Kill Switch auch noch aktiv wirbt und hervorhebt. Die Kill Switch Funktion im Menü ist praktisch nur Deko.
Mein Fazit, entäuschung pur, das macht auch die Geschwindigkeit nicht wet.
 

Chegga87

Junior Member
Gut dass ich das hier gelesen habe. Somit hat sich das Thema Vilfo Router auch erledigt.

Der Killswitch funktioniert zuverlässig, man hat ihn quasie nur falsch verstanden, daran ist Vilfo aber selbst schuld anhand mangelnder Beschreibung.
Solange eine VPN Gruppe aktiv ist die man erstellt hat ist der Killswitch aktiv, die VPN Gruppe bleibt auch dann aktiv (somit auch der Killswitch) wenn der VPN Tunnel die Verbindung verliert. Das hatte sich mir damals nicht erschlossen ich dachte wenn der VPN Tunnel die Verbidnung verliert ist auch die Gruppe inaktiv, dem ist aber nicht so. Das prinzip hab ich erst nach einer ganzen weile Verstanden wo merhmals die Verbindung weg war, aber die Gruppe aktiv blieb.

Wie gesagt, an die Verwirrung ist Vilfo selbst schuld, da dazu nichts geschrieben steht.
Der Killswitch funktioniert.
 

beng

Freshly Joined Member
Letzten Freitag schaue ich auf meine Vilfo Router und stelle fest dass ein Update verfügbar ist. Ich sollte betonen, dass ich eingestellt habe, dass ich nur stable Updates beziehen möchte. Naiv wie ich bin, habe ich nun eine BETA v1.1.0 Version auf dem Router installiert.

Der schnellste VPN Router der Welt war mal dh. ich bekomme bei unterschiedlichen VPN-Anbietern (auch PP) nur noch ca. 25% bis 40% der ursprünglichen Geschwindigkeit vor dem Update.

Bei 95% der Standorte (auch PP) mit denen sich der Router verbindet, baut sich eine Verbindung auf aber es lassen sich keine Webseite etc. aufrufen.
Ich habe den Kollegen von Vilfo auf den verfügbaren Kanälen alle notwendigen Informationen zukommen lassen. Bis heute hat sich an der Problematik nichts geändert. Sehr befremdlich finde ich die Reaktionsgeschwindigkeit des Supports, jeder der schon einmal mit denen zu tun hatte weiß wovon ich spreche.

So ist der Router für mich nicht nutzbar und ich kann diesen Router nicht empfehlen!
 

Chegga87

Junior Member
Letzten Freitag schaue ich auf meine Vilfo Router und stelle fest dass ein Update verfügbar ist. Ich sollte betonen, dass ich eingestellt habe, dass ich nur stable Updates beziehen möchte. Naiv wie ich bin, habe ich nun eine BETA v1.1.0 Version auf dem Router installiert.

Der schnellste VPN Router der Welt war mal dh. ich bekomme bei unterschiedlichen VPN-Anbietern (auch PP) nur noch ca. 25% bis 40% der ursprünglichen Geschwindigkeit vor dem Update.

Bei 95% der Standorte (auch PP) mit denen sich der Router verbindet, baut sich eine Verbindung auf aber es lassen sich keine Webseite etc. aufrufen.
Ich habe den Kollegen von Vilfo auf den verfügbaren Kanälen alle notwendigen Informationen zukommen lassen. Bis heute hat sich an der Problematik nichts geändert. Sehr befremdlich finde ich die Reaktionsgeschwindigkeit des Supports, jeder der schon einmal mit denen zu tun hatte weiß wovon ich spreche.

So ist der Router für mich nicht nutzbar und ich kann diesen Router nicht empfehlen!

Wieso Beta? Die Version 1.2 ist mitlerweile stable draussen.
Schon mal Werksreset versucht?
 

beng

Freshly Joined Member
Wieso Beta? Die Version 1.2 ist mitlerweile stable draussen.
Schon mal Werksreset versucht?

Reset habe ich noch nicht gemacht ... schaue ich heute Abend mal.

Info zur aktuellen Version

v1.1.0​

Veröffentlicht May 09, 2021


This is a major update, going from LEDE as the underlying operating system to OpenWrt. We've done over 1250 commits of changes to adjust Vilfo.

An open beta has been taking place for the last two months. If you want to participate, change the update channel of your unit to Beta on the General tab. If no major issues are reported, v1.1.0 will be released on May 10th, 2021.

Besides adjusting Vilfo to the underlying changes, the following features/improvements have been made:

  • The killswitch is now enabled the second a connection attempt is made, instead of after a VPN connection has been established
  • The internet connection for all devices is blocked on boot before any potential VPN connections have been established
  • Ability to switch a VPN connection for a group without first having to disconnect
  • Ability to discover devices with static IP addresses in the network
  • Ability to connect groups without any devices to VPN servers
  • Allow editing of parental control rules
  • New layout for the parental control page
  • Resolved bug that caused issues submitting diagnostics if Vilfo had been powered on for a long time.
  • Ability to perform backups again
  • Improved load times when over 100 devices are in a network
  • Various bug fixes related to statistics intervals
  • API token no longer gets invalidated on new logins
  • Added custom messages for some VPN providers explaining which credentials should be used
  • Improved setup flow
  • Drastically reduced file writes to SSD
  • Bypass can now handle IDN domains
  • Allow various date formatting options
  • Added possibility to connect a group without any devices to a VPN server
  • Improved formatting when viewed on mobile devices
  • Additional input checks regarding IP and ports when bypassing
  • A total rewrite of Firefox & Chrome extensions (will not work until v1.1.0 is released publicly)
  • Several bug fixes & improved error handling
 

Chegga87

Junior Member

Reset habe ich noch nicht gemacht ... schaue ich heute Abend mal.

Info zur aktuellen Version

v1.1.0​

Veröffentlicht May 09, 2021


This is a major update, going from LEDE as the underlying operating system to OpenWrt. We've done over 1250 commits of changes to adjust Vilfo.

An open beta has been taking place for the last two months. If you want to participate, change the update channel of your unit to Beta on the General tab. If no major issues are reported, v1.1.0 will be released on May 10th, 2021.

Besides adjusting Vilfo to the underlying changes, the following features/improvements have been made:

  • The killswitch is now enabled the second a connection attempt is made, instead of after a VPN connection has been established
  • The internet connection for all devices is blocked on boot before any potential VPN connections have been established
  • Ability to switch a VPN connection for a group without first having to disconnect
  • Ability to discover devices with static IP addresses in the network
  • Ability to connect groups without any devices to VPN servers
  • Allow editing of parental control rules
  • New layout for the parental control page
  • Resolved bug that caused issues submitting diagnostics if Vilfo had been powered on for a long time.
  • Ability to perform backups again
  • Improved load times when over 100 devices are in a network
  • Various bug fixes related to statistics intervals
  • API token no longer gets invalidated on new logins
  • Added custom messages for some VPN providers explaining which credentials should be used
  • Improved setup flow
  • Drastically reduced file writes to SSD
  • Bypass can now handle IDN domains
  • Allow various date formatting options
  • Added possibility to connect a group without any devices to a VPN server
  • Improved formatting when viewed on mobile devices
  • Additional input checks regarding IP and ports when bypassing
  • A total rewrite of Firefox & Chrome extensions (will not work until v1.1.0 is released publicly)
  • Several bug fixes & improved error handling
Gerade im Router nachgeguckt, stimmt ist ja die 1.1
War schon bei 1.2. Sorry :D
 

beng

Freshly Joined Member
Wieso Beta? Die Version 1.2 ist mitlerweile stable draussen.
Schon mal Werksreset versucht?
Ich habe den Vilfo Router zurückgesetzt und die Performance ist immer noch ca. 25% bis 40% der ursprünglichen Geschwindigkeit vor dem Update. Dabei ist mir zudem auch noch aufgefallen, wie absurd die Funktion des Backups an dem Router ist, wenn ich keine Möglichkeit habe das Backup bei bedarf wieder zurück zuspielen.
 

Chegga87

Junior Member
Ich habe den Vilfo Router zurückgesetzt und die Performance ist immer noch ca. 25% bis 40% der ursprünglichen Geschwindigkeit vor dem Update. Dabei ist mir zudem auch noch aufgefallen, wie absurd die Funktion des Backups an dem Router ist, wenn ich keine Möglichkeit habe das Backup bei bedarf wieder zurück zuspielen.

Da bleibt dann wohl echt nur noch der Support.
Hab auch die 1.1 drauf, aber geschwindigkeiteinbußen habe ich nicht und ich Teste die Geschwindigkeiten auch regelmäßig.
 

Hero1304

Freshly Joined Member
Hallo,

ich würde gerne mal wissen wie die Erfahrungen mit der Geschwindigkeit generell sind, nachdem es scheinbar seit dem Update 1.1 Probleme gibt.

Ich habe bisher einen ASUS RT-AX88U (Asuswrt-Merlin) mit PP genutzt und beim Speedtest zwischen 150-180 Mbps bei direkter Verbindung per LAN-Kabel erreichen können.

Ich habe nun den VILFO bekommen und nutze aufgrund der besseren WLAN-Leistung und zusätzlichen Features (z.B. Gästenetzwerk) den ASUS als Access-Point weiter, was auch gem. der Anleitung von VILFO auf der Homepage super funktioniert. WLAN beim VILFO ist auch deaktiviert.
Ich habe alle Geräte in einer Gruppe, d.h. es ist aktuell nur 1 VPN Verbindung aktiv.

Laptop direkt am VILFO per LAN-Kabel und per Bypass erreiche ich auch die 400Mbps die mein Glasfaseranschluss hergibt.
Mit den verschiedenen PP-DE Servern schafft der VILFO aber leider auch nur 160-180 Mbps.

Sollte da nicht deutlich mehr drin sein oder geben die PP-Server nicht mehr Speed her?
 
Last edited:

Chegga87

Junior Member
Hallo,

ich würde gerne mal wissen wie die Erfahrungen mit der Geschwindigkeit generell sind, nachdem es scheinbar seit dem Update 1.1 Probleme gibt.

Ich habe bisher einen ASUS RT-AX88U (Asuswrt-Merlin) mit PP genutzt und beim Speedtest zwischen 150-180 Mbps bei direkter Verbindung per LAN-Kabel erreichen können.

Ich habe nun den VILFO bekommen und nutze aufgrund der besseren WLAN-Leistung und zusätzlichen Features (z.B. Gästenetzwerk) den ASUS als Access-Point weiter, was auch gem. der Anleitung von VILFO auf der Homepage super funktioniert. WLAN beim VILFO ist auch deaktiviert.
Ich habe alle Geräte in einer Gruppe, d.h. es ist aktuell nur 1 VPN Verbindung aktiv.

Laptop direkt am VILFO per LAN-Kabel und per Bypass erreiche ich auch die 400Mbps die mein Glasfaseranschluss hergibt.
Mit den verschiedenen PP-DE Servern schafft der VILFO aber leider auch nur 160-180 Mbps.

Sollte da nicht deutlich mehr drin sein oder geben die PP-Server nicht mehr Speed her?

Hab meinen erst bei Kleinanzeigen Verkauft. Zufall? ^^
Nein aber ernsthaft, die volle Geschwindigkeit die der Vilfo Router angibt gelten nur unter Laborbedingungen, zudem haben VPN Server auch ein ressourcenmanagement, selbst wenn der Vilfo Router 5 Gbit/s VPN übertragen könnte, würde der Server das überhaupt nicht zulassen! Andere user wollen schließlich auch noch Bandbreite ab haben!
Mit einer Bandbreite von 200- 250 Mbit/s würdest du schon extremst gut fahren.
 
Top