Tipps & Tricks: Enigma2(ATV&VTI) PP Plugin Anleitung&Download

murxer

Active Member
@moejoe
Ja du kannst das Plugin auch installieren, eventuell im anderen Plugin den Autostart deaktivieren.
Außer es ist das Plugin vom Image selbst, dann passt das alles.
 

baum2020

New Member
Hallo murxer,
danke für Deine schnelle Antwort. Habe gerade Deine Nachricht gelesen.
Vor der Installation habe ich opak update ausgeführt und dann versucht die
Installation durch zu führen, leider ohne Erfolg. Ich erhalten immer die gleiche
Fehlermeldung. Habe die Box auch komplett neu aufgesetzt auch das hat nicht funktioniert.

Ich habe auf allen Boden OpenATV Version 6.2
Werde jetzt Deine zweiten Vorschlag ausprobieren
 

murxer

Active Member
Hast du schon versucht die Pakete einzeln zu laden?
opkg install kernel-module-xt-multiport
opkg install kernel-module-xt-conntrack
opkg install iptables
 

moejoe

Member
@baum2020
schau doch mal hier rein da wird das auch diskutiert:

https://www.vuplus-support.org/wbb4...-hilfe-iptables-installieren-gibt-mir-fehler/

scheint ein 4k ( arm) problem zu sein.

Aber ich brächte nicht unbedingt das plugin mit iptables, einfach ohne würde reichen.

aber so wie ich dass sehe, gibt es die pakete für die Ultimo4k nicht und du müsstest im Forum ma jemanden fragen, oder die pakete von der uno4k benutzen, mach aber vorher eine Sicherung

grüsse
 
Last edited:

PP Frank

Staff member
Interessant. Damit hatte ich jetzt nicht gerechnet. Ich habe schon angenommen das die Repos für alle Geräte so halbwegs identisch sind....

Vielleicht auch eine andere Version?

Du kannst ja mal folgendes im Terminal versuchen:

opkg list opkg list *xt-conntr*
und

opkg list opkg list *multiport*
Ich vermute mal da kommt dann gar keine Ausgabe.... Vielleicht heisst es aber dort nur leicht anders....

Hat hier jemand VTi auf einem 4k Gerät? Ich habe nur einen Duo2, von daher kann ich das nicht prüfen
 

murxer

Active Member
@PP-Frank
Solo4k und auch bei der Zero4k funktioniert es mit VTI, das hat mir ein Freund bestätigt.
Es gibt nur das Pakete für die Ultimo4k nicht.

Werde kernel-module-xt-multiport, kernel-module-xt-conntrack und iptables als Abhängigkeiten bei der Installation rausnehmen.
Dann kann man das Plugin auch Installieren und auch schon mal nutzen, werde dann das Plugin Menü noch anpassen.
So das beim Aktivieren von IPtables erst überprüft wird ob es diese Pakete gibt und dann erst installiert werden.
 

PP Frank

Staff member
Hallo murxer,
opkg install iptables konnte ich installieren
Die anderen beiden nicht?
opkg install kernel-module-xt-multiport
opkg install kernel-module-xt-conntrack
siehe Anlage

Versuch mal folgendes: Ich packe dir die beiden fehlenden Module in den Anhang hier als ZIP. Die lädst du runter.
Dann packst du die in /tmp so wie beim PP-Modul und versuchst die via SSH manuell zu installieren und danach dann das PP Plugin.

ABER: Ganz zu Beginn vielleicht mal noch folgendes machen:

opkg update
opkg install iptables
Für mich stellt sich nämlich die Frage ob das einen Grund hat warum die Pakete nicht in den Repos sind bei der Version für deinen Receiver, oder ob die einfach nur fehlen.
Letzteres wäre cool, weil dann können wir alles so lassen und man muss nur die beiden Pakete per Hand nachladen.
 

Attachments

murxer

Active Member
Wenn du das Menü beendest, dann fragt er ja ob die Configs xxxxx geladen werden sollen.
Das musst du beim ersten mal mit ja Beantworten, dann erst sind auch die Configs vorhanden.
 

murxer

Active Member
Ich meinte das Menü vom Plugin, wo du deine Zugangsdaten eingeben musst.
Beim schließen des Menü kommt ja die Frage ob Configs geladen werden sollen.
 

moejoe

Member
Ah etz funktionerts ... super

Habe zwar ein VTI Image aber cascading Funktion ist an, weiss aber nicht ob die korrekt läuft, wie sehe ich das ?

grüsse
 

murxer

Active Member
Habe jetzt auch auf der 2 Box VTI installiert und auch bei mir funktioniert Cascading.
Wenn es beim starten Probleme geben würde, dann bekommst du eine Meldung.
Wenn Hop2 auch als Server oben Angezeigt wird passt es.

Die neue Version beinhaltet:
-VTI icon's Fix
-installations Fix
-resolv-update-conf Fix
-updown.sh Fix

Muss noch was überprüfen, dann könnt ihr diese auch testen.
 

elitehunting123

New Member
finde das plugin ansich super.
Aber ich bekomme mit Openatv 6.2 nur noch Fehlermeldungen mit Lila Bildschirm und dann Neustart.
Auch neu Images installieren bringt nix.
Jemand Erfahrung damit?

Kann auch Log zur Verfügung stellen, sollte es was helfen.
 

murxer

Active Member
@moejoe
Eigentlich nicht, jeder kann das Plugin anpassen wie er will, die plugin.py ist ja mit dabei.

@elitehunting123
Also ich nutze eigentlich nur OpenAtv, gib bitte mal mehr Infos welche Box, Image-Version und welche Plugin Version du nutzt.
Den Crash Log kannst du mir gerne zu kommen lassen, dann kann ich auch mehr dazu sagen.
 

moejoe

Member
@PP Frank:

Tu mal den Hinweis von VTI raus, das dass Cascading nicht geht, das stimmt nämlich bei der neuen Version nicht mehr

@murxer:

Könnte man wenn man mit Exit aus dem menue wieder geht evtl. nicht dauernd gefragt werden ob eine neue config geladen werden soll oder das cascading regestartet wird.


Danke

grüsse
 
Last edited:

moejoe

Member
@murxer

Bist du sicher das die Cascade startet ?
Weil ich habe so gut wie keinen Leistungsanstieg was CPU betrifft.

Sieht man das irgendwie in den Routing Tabellen ?

btw. beim testen mit dem cascading hat er mir meine default route fürs interne netz zerschossen nach einem Neustart ; )

Nach erneuten Neustart und deinstallation geht wieder alles.. aber glaub da passt nochwas nicht.



grüsse
 
Last edited:
Top