Windows 10 Firewall Control - Einstellungen für OpenVPN

Alex

Active Member
Mich würde interessieren wie ich die Windows Firewall einstellen muss, damit Programme nur auf das Internet zugreifen dürfen, wenn OpenVPN läuft.

Quasi sowas wie der VPNManager in die FW einträgt, nur eben nicht für den VPNManager sondern für OpenVPN selbst.

Die Regel muss ich aber einfach deaktivieren können, denn ich will nicht immer mit PP und OpenVPN im Internet unterwegs sein.

Wenn möglich würde mich interessieren wie man das mit Windows 10 Firewall Controll einrichten kann.

Den Thread OpenVPN mit Win-Firewall absichern habe ich gefunden, der nutzt mir aber wenig, da wie gesagt ich die Regel einfach deaktivieren können muss ohne diese zu löschen.

Ich habe zwar für Firefox 2 Profile (eins für VPN, eins ohne)...
Ein anderer Browser kommt für/ohne VPN wie im verlinkten Thread nicht in Frage.
 

speedylein

Active Member
@Frank
Beim installieren von Windows hast Du keine Möglichkeit
PRIVAT auszuwählen.Nur Domäne,Öffentlich,Heim..
Öffentlich kann,und habe ich,in den Firewall-Einstellungen
Deaktiviert.Und nur dort kann man,und habe ich,Privat aktiviert.
Das Öffentlich wird allerdings im Netzwerkcenter trotzdem
alls aktiv gezeigt,ist aber Deaktiviert...
 

Dr_Iwan_Kakalakow

Active Member
@Speedy,
wenn Du, siehe Dein Bild mit den beiden Netzwerken, auf die dort zusehende obere Bank klickst, kannst Du von ÖFFENTLICH auf HEIMNETZ gehen/wechseln.
Meint Frank das oder ist das wieder etwas anderes?
 

speedylein

Active Member
@Speedy,
wenn Du, siehe Dein Bild mit den beiden Netzwerken, auf die dort zusehende obere Bank klickst, kannst Du von ÖFFENTLICH auf HEIMNETZ gehen/wechseln.
Meint Frank das oder ist das wieder etwas anderes?

Theoretisch kann ich wechseln,aber Praktisch nicht.Das Sys verlangt
dann von mir,IPV6 zu aktivieren.Tjä,dann komme ich noch nicht mal
auf meine FritzBox :mad:
 

Alex

Active Member
@Dr_Iwan_Kakalakow
Da klickst du auf den Text "Öffentliches Netzwerk" unter Netzwerk 3 und dann kannst du das auf Privat (Heimnetzwerk) umstellen.
Jepp, ist genau das was du schreibst, allerdings wenn ich auf das Bild klicke (statt auf den Text), dann kann ich nur den Namen (Text) ändern!

Das gelbe Warnzeichen ist aber nur vorhanden, wenn der PP-Manager zugeschaltet wird.
Stimmt, war aber mal "ganz früher" nicht so (weißt du ja laut deiner Aussage selbst).

Ich bin da nicht mal sicher ob das ein Bug im Manager ist. Das kann durchaus ein Bug in Windows sein, der da irgendwas nicht schnallt
Auch möglich, aber damit sollen wir leben?!:oops:
 
Last edited:

Dr_Iwan_Kakalakow

Active Member
Also das gelbe Ausrufezeichen im Netzwerkicon kann man auch im Netzwerk- und Freigabecenter sehen, nämlich in der oberen Reihe.
Durch klicken kann man das gelbe Warnzeichen jetzt im Freigabe- und Netzwerkcenter killen. Ich surfe schon den ganzen Tag ohne dieses gelbe Zeichen.
 
Last edited:

Dr_Iwan_Kakalakow

Active Member
Wenns keine wirklichen Auswirkungen hat? Windows zeigt einem meist so viel Mist an, da stört doch nen Dreieck auch nicht wirklich :D
Stimmt in diesem Fall. Aber es hat lange gedauert bis ich dahinter gekommen bin. Ich habe das gelbe Zeichen ja monatelang gehabt. Jetzt ist es weg - durch mich :)
Und ja, die Anonymität war sowieso nie gefährdet. Das plöde Zeichen hat mich lediglich gestört.
 

Alex

Active Member
Also das gelbe Ausrufezeichen im Netzwerkicon kann man auch im Netzwerk- und Freigabecenter sehen, nämlich in der oberen Reihe.
Durch klicken kann man das gelbe Warnzeichen jetzt im Freigabe- und Netzwerkcenter killen. Ich surfe schon den ganzen Tag ohne dieses gelbe Zeichen.
Hmm, finde es dort nicht.o_O
Hast'e mal 'nen Screenshot wo genau das war?
Vll. kannst du auf dem Screenshot einkreisen wo das bei dir war, im Netzwerk- und Freigabecenter.
 

speedylein

Active Member
Also,nen gelbes Ausrufzeichen im Netzwerk- und Freigabecenter habe
ich auch noch nie gesehen.Normal existiert das nur im Verbindungssymbol
unten in der Taskleiste,wenn's denn da ist.
Im Netzwerk- und Freigabecenter habe ich ein rotes Kreuz bei VPN
Verbindung zwischen "Mehrere Netzwerke und Internet"
Aber das ist normal.Auf das Kreuz ist auch kein Klick möglich.
Wird VPN getrennt,ist das sofort wech...

@
Dr_Iwan_Kakalakow

Wieso hast Du 3 Netzwerke...
 

Dr_Iwan_Kakalakow

Active Member
[..]
@ Dr_Iwan_Kakalakow
Wieso hast Du 3 Netzwerke..
[..]
Das hat sich so eingerichtet. Stand auf einmal da. Es gibt wohl noch einen Reserve-PC. Ob der sich auch da eingenistet hat? Ich kann es Dir nicht sagen.
Wenn ich morgen Zeit habe, versuche ich mal das gelbe Ausrufezeichen herbei zu klicken. Ob es funktioniert weiss ich nicht. Ich weiss ja auch nicht mehr, welche genauen
Klicks bzw. Veränderungen dazu geführt haben, dass das gelbe Ausrufezeichen jetzt nicht mehr erscheint. Jedenfalls habe ich das gelbe Zeichen oben in der MItte gesehen und drauf geklickt. Danach verschwand das Zeichen und jetzt steht dort "Mehrere Netzwerke"
 

Alex

Active Member
Also,nen gelbes Ausrufzeichen im Netzwerk- und Freigabecenter habe
ich auch noch nie gesehen.Normal existiert das nur im Verbindungssymbol
unten in der Taskleiste,wenn's denn da ist.
Im Netzwerk- und Freigabecenter habe ich ein rotes Kreuz bei VPN
Verbindung zwischen "Mehrere Netzwerke und Internet"
Aber das ist normal.Auf das Kreuz ist auch kein Klick möglich.
Wird VPN getrennt,ist das sofort wech...
So auch bei mir ,was normal ist!
Anders hatte ich es bisher auch noch nie.o_O

Ja, VirtualBox ist was ganz anderes... nutze ich auch, doch auch von dort kenne ich das nicht.
 

Dr_Iwan_Kakalakow

Active Member
Zum roten Kreuz im Freigabe- und Nertzwerkcenter:
Also wenn ich mit der Maus auf das rote Kreuz zeige, dann erscheint folgende Meldung "Klicken Sie hier, um Probleme zu behandeln". Ich habe versuchsweise drauf geklickt - es geht also. Adapter sowie das gesamte Netzwerkgedöns ist ein Fachbereich für sich. Ich bin jedenfalls froh, dass alles normal weiter läuft. Ich hasse PC-Probleme.
 

Alex

Active Member
Sicher bin ich mir jetzt nicht, ob es an einer der neuen PPVPNManager-Versionen liegt (wohl eher nicht?!o_O) oder ob es an der Windows 10 Firewall Control lag, aber ich habe einiges mehr freigegegeben, u.a. rundll32.exe, irgendwas mit System, wo ich noch nicht genau weiß was das ist:oops:, da ich keine Datei/Pfad sehe (siehe Screenshot) und wmiprvse.exe.:eek:
Eines davon könnte verantwortlich gewesen sein, für das gelbe Ausrufezeichen.:confused:

Bin mit PPVPNManager und PP-Server verbunden, glbes Ausrufezeichen (seit Tagen) weg.;)
 

Attachments

  • system.jpg
    system.jpg
    120 KB · Views: 15
Top