Linux Mint ---IPv6 deaktivieren---

Discussion in 'Linux' started by Ghost, Feb 9, 2014.

  1. Ghost

    Ghost Junior Member

    Linux Mint IPv6 deaktivieren
    Wer kein IPv6 benötigt sollte es abschalten.​



    Prüfen ob IPv6 eingeschaltet ist:
    $ cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    Ergebnis = 0 IPv6 eingeschaltet
    Ergebnis = 1 IPv6 ausgeschaltet
    Ausschalten von IPv6 (nur mit Root Rechten möglich)

    Bearbeiten der Datei sudo nano /etc/sysctl.conf
    Diese Zeilen am Ende des Dokumentes hinzufügen:
    #disable ipv6
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1

    Speichern der Änderungen an der Datei sysctl.conf.

    Reboot des Systems

    Prüfen ob IPv6 eingeschaltet ist:
    $ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

    Jetzt muss als Ergebnis eine 1 (IPv6 ausgeschaltet) angezeigt werden.
     
    Loreas likes this.
  2. Ghost

    Ghost Junior Member

    Funktioniert auch unter Linux Mint 17.1
     
  3. s

    someuser Junior Member

    Vielleicht schreibst du noch was zur Intention warum man IPv6 abschalten sollte?
     
  4. Ghost

    Ghost Junior Member

    PP unterstützt keine VPN IPv6 Verbindungen.
    Wenn IPv6 aktiv ist besteht die Gefahr, dass deine reale IP übertragen wird.
     
  5. s

    someuser Junior Member

    Oh, gut zu wissen, danke.

    Wie ist das jetzt, wenn man einen Kabel ISP hat, wie schaltet man IPV6 da ab? Oder wird automatisch IPV4 genutzt, wenn das Interface kein V6 "kann"?
     
  6. Ghost

    Ghost Junior Member

    Vielleicht stellt dich dein Kabel Anbieter auf reines IPv4 um.;)
    Falls nicht, tja, dann hast du Pech gehabt.
     
  7. JackCarver

    JackCarver Junior Member

    Ich vermute mal dein Anbieter nutzt Dual Stack lite, das bedeutet, dass dein Router zwar keine öffentliche IPv4 Adresse bekommt, du aber trotzdem IPv4 nutzen kannst. Dazu werden deine IPv4 Pakete in IPv6 Pakete verpackt und an nen NAT deines Providers geliefert, das über IPv4 verfügt. Dort werden die IPv4 Pakete wieder entpackt und es geht zum IPv4 Zielserver. Der Rückweg läuft genauso. Für dich ist das also kein Nachteil, denn du kannst trotzdem lokal IPv6 abschalten und dein System läuft hinter deinem Router rein über IPv4.

    Sie werden dich mit Sicherheit nicht wieder auf IPv4 zurückstellen, IPv6 macht Sinn, allein wegen der Verknappung der IPv4 Adressen. Es gibt eben 2 große Techniken, einmal Dual Stack und dann Dual Stack lite. Bei ersterem kriegt dein Router sowohl ne IPv4 als auch ne IPv6 Adresse, bei letzterem halt nur IPv6, aber trotzdem der Möglichkeit weiterhin IPv4 Server, wie die von PP zu erreichen.
     
  8. s

    someuser Junior Member

    Hab mal geguckt, hab Dual Stack Light, richtig.

    trotz:

    cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    1


    zeigt ifconfig auf eth0 trotzdem noch:


    inet6 addr: xxxx:xxxx:xxxx:xxx:xxxx:xxxx:xxxx:xxxx/64 Scope:Global
    inet6 addr: xxxx:xxxx:xxxx:xxx:xxxx:xxxx:xxxx:xxxx/64 Scope:Global
    inet6 addr: xxxx:xxxx:xxxx:xxx:xxxx:xxxx:xxxx:xxxx/64 Scope:Global
    inet6 addr: xxxx::xxxx:xxxx:xxxx:xxxx/64 Scope:Link
    inet6 addr: xxxx:xxxx:xxxx:xxx:xxxx:xxxx:xxxx:xxxx/64 Scope:Global
    inet6 addr: xxxx::xxxx:xxxx:xxxx:xxxx/128 Scope:Global


    Sieht also nicht wirklich deaktiviert aus?
     
  9. JackCarver

    JackCarver Junior Member

    Bearbeite mal die /etc/sysctl.conf, so wie Ghost das beschrieben hat und mach n reboot, dann guck nochmal.
     
  10. JackCarver

    JackCarver Junior Member

    Als Test kannst du dann auch mal nen IPv6 Server anpingen, mit


    ping6 ipv6test.google.com

    Oder du surfst mal diese Seite an, da gibt's auch Infos zu:

    http://ipv6test.google.com
     
  11. s

    someuser Junior Member

    Hab ich ja, also die sysctl.conf so bearbeitet. Die Google Testseite sagt:


    You don’t have IPv6, but you shouldn’t have problems on websites that add IPv6 support


    Soweit, so gut. Vielleicht weiß ja noch jemand, wieso eht0 trotzem IPV6 Adressen zu haben scheint. Ist nur Interesse, aus scheint V6 ja zu sein.

    ping6 ipv6test.google.com
    unknown host


    sieht auch gut aus :)
     
  12. JackCarver

    JackCarver Junior Member

    Guck mal auf dein Router, evtl verteilt er per DHCP V6 Adressen. Macht aber auch nix, da das V6 System ja deaktiviert ist unter Linux.
     
  13. s

    someuser Junior Member

    Ja stimmt, daran liegt es. Kann man leider nicht deaktivieren, nur den V4 DHCP Server. Naja, es funktioniert ja (nicht) wie es soll, von daher danke für den Tipp. Habe auf meinen nicht-linux Systemen auch mal IPV6 deaktiviert.
     
  14. AyaShi

    AyaShi Junior Member

    Danke, funktioniert auch unter Ubuntu 14.04 wunderbar.
     
  15. Dr. Kochhahn

    Dr. Kochhahn Junior Member

    Ich habe das anders deaktiviert. Prüfen ob IPv6 aktiviert ist: "ip addr show | grep inet6" Jetzt darf keine IPv6 Adresse mehr im Terminal erscheinen. Wenn doch: Root Rechte holen und mit Editor in die Datei: "/etc/default/grub" gehen und dort die Zeile: "GRUB_CMDLINE_LINUX="ipv6.disable=1" einfügen. Das Speichern und anschließend mit Rootrechten "update-grub" ausführen und das System neu starten. Wenn man dann "ip addr show | grep inet6" ausführt, dürfte keine IPv6Adresse mehr erscheinen.
     
  16. A

    Antares New Member

    So, dann will ich auch mal meinen Senf dazugeben.

    Ich habe es auch erst auf diese Weise geregelt. Soweit funktionierte es auch aber wenn ich dann eingab: ip addr show | grep inet6 eingab bekam ich immer noch eine IPv6Adresse angezeigt.

    Darum habe ich das lieber im Grub abgeschaltet:

    1.) $ sudo nano /etc/default/grub

    2.) Die Zeile : GRUB_CMDLINE_LINUX="ipv6.disable=1" einfügen.

    3.) $ update-grub

    4.) Neustarten

    5.) ip addr show | grep inet6

    Jetzt darf keine IPv6 Adresse mehr im Terminal angezeigt werden.


    Auf Arch und auf Arch basierenden OS wie Manjaro würde das auch funktionieren aber ich konnte dann die UFW Firewall nicht mehr verwenden. Um IPv6 abzuschalten und trotzdem die UFW Firewall verwenden zu können ging ich wie folgt vor:

    1.) Mit dem Editor eine Datei erstellen:

    $ sudo nano /etc/sysctl.conf


    Dort eintragen:

    #ipv6 disabled
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1


    6. Um das danach einzulesen ist ein Terminal zu öffnen und dort einzutragen:

    $ sudo sysctl -p


    Dieser Befehl: $ sudo sysctl -p ist nach jedem Neustart auszuführen. Denn immer wenn die Netzwerkverbindung weg ist, muss es neu eingelesen werden. Sonst istIPv6 wieder eingeschaltet. Funktioniert aber zuverlässig. Bei Eingabe des Befehls: ip addr show | grep inet6 erscheint keine IPv6 Adresse mehr.
     
    Loreas and Dr_Iwan_Kakalakow like this.
  17. H

    Honk New Member

    IPv6 unter Ubuntu / Mint deaktivieren


    Um zu prüfen, ob das Internet Protocol Version 6 (IPv6) aktiviert ist, führt man den folgenden Befehl aus:
    Code:
    cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    Liefert der Befehl als Rückgabewert eine 1, ist IPv6 deaktiviert. Wird eine 0 zurückgegeben, ist IPv6 aktiviert. In der Standardinstallation wird hier eine 0 zurückgegeben, da das Protokoll standardmäßig aktiviert ist.

    Deaktivieren von IPv6
    Zur Deaktivierung muss die Datei /etc/sysctl.conf mit einem Editor geöffnet werden.
    Code:
    sudo xed /etc/sysctl.conf
    In der Datei müssen die nachfolgenden Einträge gesetzt werden. Wenn die Einträge nicht vorhanden sind, werden diese einfach am Ende der Datei angefügt. Sind die Einträge bereits vorhanden, passt man die Wertzuweisung von einer 0 auf eine 1 an.

    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1


    Anschließend wird die Datei gespeichert und geschlossen.

    Damit die Einstellungen angewendet werden, muss anschließend die sysctl Konfiguration neu eingelesen werden:
    Code:
    sudo sysctl -p
    Ein Neustart des Rechners mit Hilfe z.B. des Befehls „reboot“ hat den selben Effekt.

    Anschließend sollte der bereits genannte Befehl
    Code:
    cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    eine 1 zurückgegeben. Die zurückggegebene 1 bestätigt die erfolgreiche Deaktivierung des Protokolls.


    Nachtrag für OpenVPN:
    in den OVPN-Dateien den Eintrag
    tun-ipv6
    deaktivieren, also ein # voranstellen
    # tun-ipv6




    So kann man bei den verschiedenen Distributionen IPV6 ausschalten:

    Debian / Sidux / Ubuntu / Linux-Mint:

    Als root die Datei /etc/modprobe.d/aliases öffnen
    und die Zeile

    alias net-pf-10 ipv6
    in
    alias net-pf-10 off
    ändern.

    Um das manuelle Laden des ipv6-Moduls zu verhindern kann noch die Zeile alias ipv6 off angehängt werden.





    Bei Grub2 folgende Zeile in die Datei /etc/default/grub einfügen:

    #IPV6 aus
    GRUB_CMDLINE_LINUX="ipv6.disable=1"

    Bei Grub(1) in der Datei /boot/grub/menu.lst folgendes an die Kernelzeile anhängen:

    ipv6.disable=1

    Und jeweils anschließend noch ein update-grub laufen lassen.




    In Mozilla-Browsern about:config in die Adresszeile eingeben und

    network.dns.disableIPv6 auf true stellen.





    Die Datei "/proc/sys/net/ipv6/conf/all/disable_ipv6" ist nicht mehr existent:

    $ cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    cat: /proc/sys/net/ipv6/conf/all/disable_ipv6: No such file or directory

    Da komplette Verzeichnis /ipv6/ fehlt nun:

    [​IMG]




    Testen im Terminal:

    ip addr show | grep inet6
    keine Ausgabe = kein IPv6

    watch -n 1 lsof -i
    zeigt die aktuellen Verbindungen an. Hier werden nun keine IPv6-Adressen mehr angezeigt.


    (Meiner Easybox wurde eine neue Firmware eingespielt und schon ging das ganze IP6-Theater los ...)
     
  18. ItsFe

    ItsFe Member

    Hattest du einen Leak obwohl du zu nem PP Server verbunden bist (die meisten haben ja IPv6)
     
  19. H

    Honk New Member

    Der kürzeste Weg (unter Linux Mint):

    Bei Grub2 folgende Zeile in die Datei /etc/default/grub einfügen:
    # IPV6 aus
    GRUB_CMDLINE_LINUX="ipv6.disable=1"


    Jetzt noch ein update-grub und dann neustarten, nach Neustart ist das Ipv6-Verzeichnis verschunden.

    [​IMG]

    und natürlich in den OVPN-Dateien den Eintrag
    tun-ipv6
    deaktivieren, also ein # voranstellen
    # tun-ipv6
     
    Last edited: Oct 25, 2018
  20. H

    Honk New Member

    Hatte nach dem Firmware-Update mit
    Code:
    sudo watch -n 1 lsof -i
    diese langen v6-Adressen in der Anzeige.

    Da ich kein IPv6 benötige und ich nicht weiß, wie damit umzugehen ist, muss das erstmal weg.
    Oder kann mir jemand erklären, wozu ich das benötige.