IPv6 für alle

theoth

Junior Member
Also bei mir klappt Chromium und FF auch mit www.heise.de in der Adresszeile. Bei FF allerdings nicht vergessen in about:config dns.disable.ipv6 auf false zu setzen - sonst macht der nur v4 lookups. Wer alles (v6+v4) durch den Tunnel routet, muß eigentlich nix tun.
Aber nicht vergessen sowohl die v4 (iptables), als auch die v6(ip6tables)-Firewall entsprechend zu konfigurieren, daß nix am Tunnel vorbei geht, oder für den Fall, daß der Tunnel zusammenbricht
 

JackCarver

Junior Member
Ich hab mir den OpenVPN Traffic mal unter Wireshark angesehen, wenn ich in die Adresszeile des Browsers:

ipv6.google.com
eingebe. Unter Chrome passiert dabei folgendes:
- Query als Type A:

Queries
ipv6.google.com: type A, class IN
Name: ipv6.google.com
[Name Length: 15]
[Label Count: 3]
Type: A (Host Address) (1)
Class: IN (0x0001)
Er bekommt keine Antwort, dann
-Query als Type AAAA:

Queries
ipv6.google.com: type AAAA, class IN
Name: ipv6.google.com
[Name Length: 15]
[Label Count: 3]
Type: AAAA (IPv6 Address) (28)
Class: IN (0x0001)
Er bekommt Antwort:

Answers
ipv6.google.com: type CNAME, class IN, cname ipv6.l.google.com
Name: ipv6.google.com
Type: CNAME (Canonical NAME for an alias) (5)
Class: IN (0x0001)
Time to live: 21599
Data length: 9
CNAME: ipv6.l.google.com

ipv6.l.google.com: type AAAA, class IN, addr 2a00:1450:4001:806::200e
Name: ipv6.l.google.com
Type: AAAA (IPv6 Address) (28)
Class: IN (0x0001)
Time to live: 299
Data length: 16
AAAA Address: 2a00:1450:4001:806::200e
Unter Safari passiert dann das:
-Query als Type A:

Queries
www.ipv6.google.com: type A, class IN
Name: www.ipv6.google.com
[Name Length: 19]
[Label Count: 4]
Type: A (Host Address) (1)
Class: IN (0x0001)
- Er bekommt folgende Antwort von 8.8.8.8:

2 0.048559 8.8.8.8 10.29.12.244 DNS 119 Standard query response 0xa72a No such name A www.ipv6.google.com SOA ns3.google.com
Das war's dann...Da kann natürlich nix klappen...

Unter Firefox:
- Query als Type A:

Queries
ipv6.l.google.com: type A, class IN
Name: ipv6.l.google.com
[Name Length: 17]
[Label Count: 4]
Type: A (Host Address) (1)
Class: IN (0x0001)
Darauf kommt dann auch nix als Antwort zurück. Wieso das alles sich so verhält ist zumindest komisch, aber irgendwie funktioniert derzeit unter nem nativen IPv4 OSX mit PP IPv6 unter OpenVPN nur Chrome sauber.
 

WarmRed

Junior Member
kann man danach in den Netzwerkeinstellungen den Haken bei IPV6 wieder ruhigen Gewissens wieder rein tun? Bis anhin wurde hier davon abgeraten.
 

PP Frank

Staff member
Ja. Siehe Serverliste im Mitgliedsbereich. Nicht bei allen RZ gibt es IPv6. Die grossen Locations haben wir fast alle mit IPv6. Einige werden wir noch nachrüsten
 

DJBeatMaster

Junior Member
Habe seit 2 Wochen Win 10 installiert und nutze auch den aktuellsten PP VPN Client (1.8.3.0) aber beim DNS-LeakTest auf Eurer Page erscheinen bei mir die originalen DNS Server von meinem Provider und nur 1 DNS Server aus dem PP VPN Manager. In den Netzwerkeinstellungen werden die in der PP VPN angezeigten DNS Server auch korrekt eingetragen aber irgendwie scheint wohl dennoch etwas nicht zu funktionieren.
Auf meinem vorherigen OS (Win 7) funktionierte alles noch 1a. Habe aber dort auch IPv6 abgeschaltet. Jetzt in Win10 ist IPv6 aktiviert, ebenso in der FritzBox.
 

PP Frank

Staff member
Prüfe in deinem normalen LAN-Adaptern mal die DNS-Einträge bei IPv4 und IPv6. Was sagt der IPv6 Check auf der Website von uns?
 

DJBeatMaster

Junior Member
Hat keiner eine Idee was bei mir schiefläuft ? Ist es bei den anderen Benutzern OK oder gibt es auch hier Probleme ?
Wenn ich sowohl in der normalen Netzwerkverbindung von meiner Netzwerkkarte und in dem TAP Windows Adapter (der von PP erstellt wird) bei IPv6 manuell 2 IPv6 DNS Server von PP eintrage funktioniert es. Also gibt keinen DNS Leak mehr.

Funktioniert hier der PP Client nicht richtig ?
 
Top