Install Error on Kubuntu 20.04

gh4wind

New Member
Kubuntu 20.04 LTS is now available for install (see Distrowatch.com)
Installed Kubuntu ok.

Attempted to install PP-VPN and got the following error message:
"Error: Cannot satisfy dependencies"

Same PP-VPN works ok on Kubuntu 19.*
Fix needed... Please advise.
 

Golemhacker

New Member
Did you do a clean install of 20.04 or did you upgrade from a version before?
I am still on 19.10 and will wait until next week for upgrade, so can't tell anything yet

But it would be nice to see, if PerfectPrivacy could test their Software with new LTS realeases every 2 years.
Just testing if everything is running fine or if there are new dependences or bugs.
@PP Christian Could you consider this as a topic for the next team meeting? thx
 
Last edited:

gh4wind

New Member
Kubuntu 20.04 LTS was new install to a blank disk using full disk encryption.

Also did a new install of Lubuntu 20.04 Desktop amd64 to a blank disk on another PC,
without using full disk encryption.
Got a similar error message:
"Dependency resolution failed."

Added Nord VPN to the Lubuntu PC as a test and it appears to work, but i would rather
use Perfect Privacy VPN (if it worked).

Fix needed.... Please advise.
 

gh4wind

New Member
package python-requests is not installed... so PP-VPN will not install.

Looks like python for Linux is no longer supported.

If anyone knows where this package can be found, please advise.
 

Xulux

New Member
Ubuntu 20.04 removed the very old phyton 2 and replaced it with 3.8.
Phyton 2 is deprecated and no longer supported.

If the pp-client depends on phyton 2...it can not work anymore.

Edit: you can Install phyton 2 If you enable the Ubuntu universe repository....
 

gh4wind

New Member
Yes pp-vpn will not install on the 20.04 ubuntu family of Linux OS with a new install as it requires python2.7 with "python-request".
If one has a working 19.* ubuntu family OS it maybe possible to do an upgrade to 20.04, but if the upgrade removes python2.7 stuff,
the result maybe more grief.

PP-VPN needs to be upgraded to work with python 3.* or rewritten to not use python.
Nord VPN can be manually installed on 20.04 ubuntu family OS as a temporary fix, but it lacks the nice features of PP-VPN.

Please fix PP-VPN NOW !!!
 

fbn6

New Member

The following packages have unmet dependencies.
perfect-privacy-vpn : Depends: python-requests (>= 0.8.8~) but it is not installable
E: Unable to correct problems, you have held broken packages.


This is a show stopper for me at the moment.
 

gh4wind

New Member
Installed pp-vpn_test104.deb on Kubuntu 20.04 PC.
attempted to update PP-VPN Prefernces, but no response from PP server.
attempted to connect to several PP-VPN Server Cities, but no connection.
Noted that the icons that normally appear in the square boxes were absent.
 

gh4wind

New Member
Correction to prior post re pp-vpn_test104.deb
Actually the first attempt to update Preference worked and downloaded from PP server.
Then it would not connect to anything.
I suspect the info that came from the PP server was for the current PP-vpn setup and
not for the pp-vpn_test104.deb ???
 

Dreamingwolf

New Member
It is possible to install on the Ubuntu 20.04 family (and derivatives), but you have to manually install python2, pip for python2, then sudo pip install requests. A real PITA but it can be done.
I know because it's installed on all my 20.04 installations.
 

Golemhacker

New Member
@PP Christian @PP Frank
Gibt es einen Termin, wann hier ein neue finale Version kommt?
Lest ihr hier mit und meldet das dem Entwickler, dass die Beta Version noch nicht funktioniert?

Ich will dringend auf 20.04 updaten kann es aus dem Grund jedoch noch nicht.
Das ist extrem ärgerlich. Hier muss dringend ein Fix kommen

PS: Bei der Gelegenheit wäre es übrigens nett, wenn Single Server mal für Linux freigeschalten werden.
Die Dateien werden ja mit heruntergeladen, es fehlt nur die Option im Manager das zu aktivieren.
Danke
 

Golemhacker

New Member
Schön wieder mal so ein tolles Feedback zu bekommen...
Und ich dachte schon die Moderatoren hätten jetzt ernsthaft vor etwas zu ändern.
Wie man sich täuschen kann


@ english speaking users
Sorry guys, don't expect anything too soon.
If you are Linux user like me, maybe consider suicide and hope that you get better support in your next life ...
 

Golemhacker

New Member
Danke, für die Zukunft das bitte ohne mehrmaliges nachfragen beantworten.
Man sieht wann ihr das letzte mal online wart und ich stelle mir nur die Frage,
wieso sich niemand die Mühe macht so einen Einzeiler zu antworten, obwohl ihr offensichtlich die Frage gelesen habt.

Auch in anderen Threads wurde der Support jetzt schon mehrfach kritisert. Warum ändert sich da nichts?
Daher auf Fragen und Anliegen bitte sofort eingehen.
Wenn es für Linux ein Update gibt, welches das Problem beheben soll, dann würde ich bitten das irgendwie zu kommunizieren.
Einfach unverständlich und ärgerlich


@english speaking users:
There should be an update for the official Linux version.
So try this one if it works on 20.04: https://www.perfect-privacy.com/downloads/perfect-privacy-vpn.deb
 

PP Christian

Staff member
wieso sich niemand die Mühe macht so einen Einzeiler zu antworten, obwohl ihr offensichtlich die Frage gelesen habt.
Das ist leider manchmal nicht so einfach, da wir uns gerade in technischen Fragen abstimmen müssen. Ich kann ja nicht irgendwas behaupten, was am Ende nicht oder nicht zu dem Zeitpunkt erfüllt werden kann. Dann gib es ja auch wieder Ärger ;)

Wir sehen auch nicht immer alles sofort. Wenn in einem gewissen Zeitraum neue Threads entstehen, Unterhaltungen fortschreiten oder das Augenmerk gerade auf etwas anderes gerichtet ist (z.B. offene Tickets), kann auch mal etwas übersehen werden.
 
Top