dreambox mit openvpn plugin und pp

Discussion in 'Anleitungen' started by PRISM, Sep 6, 2013.

  1. wolve

    wolve New Member

    Hast du einfach die Mac .ovpn datei in /etc/openvpn gespielt, Rechte auf 755 gesetzt und den Pfad in der Datei zur passwort.txt angepasst?

    Und hast du die .ovpn in .conf umbenannt?

    Die Zertifikate, die früher mal extra datein waren, scheinen ja nun schon in der .ovpn inkludiert zu sein, verstehe ich das richtig?
     
  2. PRISM

    PRISM Junior Member

    1) Ja
    2) Nein. Heißen noch .ovpn

    Ich kann am Wochenende nachschauen, wie genau ich das nun eingestellt habe. Komm aber erst am Sonntag auf meine DM darauf.
     
  3. wolve

    wolve New Member

    also auch mit der mac config klappt es nicht...

    und mit der .opvn-endung lässt sich das openvpn plugin garnicht starten, sondern nur, wenn ich die datei in .conf umbenenne... und dann klappt es eben nicht

    keine ahnung was hier los ist, ich komme nicht weiter...
     
  4. PRISM

    PRISM Junior Member

    Gib es eine Fehlermeldung?
    Code:
    openvpn --config /etc/openvpn/Amsterdam.ovpn 
    

    Code:
    root@dm800se:/etc/openvpn# ls
    Amsterdam.conf
    Amsterdam.ovpn
    Amsterdam_cl.crt
    Amsterdam_cl.key
    Amsterdam_ta.key
    ca.crl 
    ca.crt
    ccd
    easy-rsa
    password.txt
    zB Amsterdam.ovpn:
    Code:
    proto udp
    tun-mtu 1500
    fragment 1300
    mssfix
    cipher AES-256-CBC
    remote amsterdam.perfect-privacy.com 149
    ...
    ...
    
    auth SHA512
    auth-user-pass /etc/openvpn/password.txt
    client
    comp-lzo
    dev tun
    #float
    hand-window 120
    inactive 604800
    mute-replay-warnings
    nobind
    ns-cert-type server
    persist-key
    persist-remote-ip
    persist-tun
    ping 5
    ping-restart 120
    redirect-gateway def1
    remote-random
    reneg-sec 3600
    resolv-retry 60
    route-delay 2
    route-method exe
    script-security 2
    tls-cipher .....
    tls-timeout 5
    verb 4
    
    ca /etc/openvpn/ca.crt
    cert /etc/openvpn/Amsterdam_cl.crt
    key /etc/openvpn/Amsterdam_cl.key
    tls-auth /etc/openvpn/Amsterdam_ta.key 1
    crl-verify /etc/openvpn/ca.crl
    
     
  5. wolve

    wolve New Member

    root@vusolo4k:~# openvpn --config /etc/openvpn/Zurich.ovpn
    Sun Feb 26 22:38:53 2017 Unrecognized option or missing parameter(s) in /etc/opnvpn/Zurich.ovpn:7: ncp-disable (2.3.6)
    Options error: --down script fails with '/etc/openvpn/update-resolv-conf': No sch file or directory
    Options error: Please correct this error.
    Use --help for more information.


    Ich habe keine Ahnung, wie du an diese files:

    Amsterdam_cl.crt
    Amsterdam_cl.key
    Amsterdam_ta.key
    ca.crl
    ca.crt
    ccd
    easy-rsa

    gekommen bist... ich habe NUR die .ovpn, wenn ich den zip-ordner öffne
     
  6. wolve

    wolve New Member

    also openvpn startet und zeigt mir auch keine fehler an.

    wenn ich mir nun aber den status anzeigen lasse, dann steht dort:
    .
    .
    Bytes received via tun0: (0.0 B)

    ich versteh es einfach nicht... kann es irgendeine andere einstellung an meinem netzwerk sein? sobald ich openvpn wieder beende, ist dide box sofort wieder online und ich kann daten empfangen über meine normale lan-verbindung
     
  7. PP Stephan

    PP Stephan Staff Member

    Der folgende Befehl zum starten:

    openvpn --cd /etc/openvpn/ --config <config.ovpn>

    wobei du <config.ovpn> mit dem entsprechenden Server austauscht, also zB Frankfurt.ovpn
     
  8. wolve

    wolve New Member

    klappt auch nicht.. gleiches problem wie oben

    wenn ich rein die .ovpn aus der Konfigurationsseite herunterlade, schreibt er mir schon nen fehler mit der update-resolv-conf hin, dass diese datei nicht gefunden werden kann

    wenn ich die zwei zeilen rauskommentiere, dann startet openvpn zwar, doch die verbindung zum internet klappt nicht... sobald ich es stoppe, habe ich sofort wieder internet

    ergo... gleiches problem wie vorher
     
  9. PRISM

    PRISM Junior Member

    anscheinend habe ich noch alte aber funktionierende Konfigs. Ich kann dir diese bei Bedarf zukommen lassen. Auf meiner dm800 se funktioniert die Verbindung mit Amsterdam ohne Probleme. ggf. frag mal in einem VU+ Forum nach.
     
  10. PP Frank

    PP Frank Staff Member

    Ich habe das gestern getestet auf einem VU+. ich habe das Plugin von VTI genutzt. Plugin installieren. Config(iOS TCP habe ich genommen) downloaden. Dann via SSH oder Putty das vorgefertigte Config-File auf der Dreambox/VU+ unter /etc/openvpn durch das Confige-File von uns ersetzen. Dann im Config File die Zeile auth-user anpassen, damit das PW vorhanden ist.
    Dann muss man nur noch den Autostart im Plugin im VTI-menu auf dem VU aktivieren.
    Sollte auf anderen Firmwares aber recht gleich funktionieren
     
    wolve likes this.
  11. wolve

    wolve New Member

    Danke @PP Frank, mit der TCP-config für IOS hat es nun geklappt...

    für leute mit ähnlichen problemen:
    habe für das vti-image die bevorzugte *.ovpn (IOS, TCP single) in "openvpnvti.conf" umbenannt (wird ja so von dem image eigentlich vorgegeben) und in /etc/openvpn/ gespielt
    "password.txt" erstellt, login-daten von PP eingetragen (1. Zeile User, 2. Zeile Passwort) und in /etc/openvpn/ gespielt
    rechte von beiden mit dem FTP-Programm hoch auf 755
    in der openvpnvti.conf-datei die auth-user-pass Zeile mit vollständigem pfad zur .txt anpassen (hier: auth-user-pass /etc/openvpn/password.txt) und file per ftp aktualisieren
    vpn autostart einrichten
    dann mal box neu starten

    so hat es jetzt funktioniert

    danke für die hilfe
     
  12. vpn33

    vpn33 New Member

    Hallo,
    Ich versuche gerade das gleiche zu installieren auf meiner VU+ SOLO 4K jedoch bekomme ich es nicht hin und hoffe ihr könnt mir helfen. Also ich habe zwei Probleme wie komme ich an die ganzen Certifikate? Ich habe nur die Ovpn Datei der Server. Und welche muss ich da nehmen die für Linux nehme ich an? Diese habe ich dann in config umbenannt und auch eine Datei für Passwort und benutzername ergänzt sowie den Pfad in der Config hinzugefügt. Jedoch fehlen mir eben die Certifikate.
     
  13. PP Frank

    PP Frank Staff Member

    @vpn33

    Sie 2 Beiträge über dir: #70

    Das funktioniert genauso. Du musst da gar nichts mit Certs machen, da die alle in der iOS-Config mit drin sind. Direkt in der .ovpn-Datei
     
  14. moejoe

    moejoe New Member

    Anscheinend geht es nicht mit AES256/GCM
    ´
    Obwohl laut openssl es unterstützt wird auf der vu+:

    Code:
    root@vuuno4k:/etc/openvpn# /usr/bin/openssl enc -help 2>&1 | grep gcm
    -aes-128-ecb               -aes-128-gcm               -aes-128-ofb
    -aes-192-ctr               -aes-192-ecb               -aes-192-gcm
    -aes-256-ctr               -aes-256-ecb               -aes-256-gcm

    Und die autostart funktion in dem plugin für openvpn geht ( zumindest) bei mir auch nicht

    btw. wie kann ich sicher sein, dass auch der traffic über den vpn läuft ?

    ist cascadierung auch möglich ?

    grüße moejoe
     
    Last edited: Jul 6, 2017
  15. moejoe

    moejoe New Member

    @PRISM:

    Dein Plugin geht bei mir leider nicht


    Hab aber ne andere Möglichkeit gefunden die Ip zu lokalisieren per command line und somit zu checken ob sich der vpn richtig connected :


    Als erstes curl installieren:

    Code:
    opkg install curl 
    Dann folgenden Befehl ausführen:

    Code:
     curl -s ipinfo.io/ chaoip
    grüsse moejoe
     
    Last edited: Jul 7, 2017
  16. moejoe

    moejoe New Member

    Morgen miteinander,

    Zzt. krieg ich folgende Fehlermeldung habe aber eigentlich auf meiner Seite nichts verändert:

    Code:
    Thu Jan  1 09:09:59 1970 us=506387 TLS Error: TLS object -> incoming plaintext read error
    Thu Jan  1 09:09:59 1970 us=506505 TLS Error: TLS handshake failed
    Thu Jan  1 09:09:59 1970 us=506651 Fatal TLS error (check_tls_errors_co), restarting
    Thu Jan  1 09:09:59 1970 us=506743 TCP/UDP: Closing socket
    Thu Jan  1 09:09:59 1970 us=506853 SIGUSR1[soft,tls-error] received, process restarting
    Thu Jan  1 09:09:59 1970 us=506907 Restart pause, 5 second(s)
    
    Woran kann das liegen ?

    Mt dem Windows Client geht es ohne Probleme


    Update:

    Jetzt scheint es wieder zu gehen. K.A obs bei mir oder euch dran lag hab aber nix weiter geändert.

    Danke

    grüße moejoe
     
    Last edited: Jul 26, 2017
  17. evolver_xxl

    evolver_xxl New Member

    Hallöchen alle zusammen

    Bin auch ein neuer und bevor ich wieder nen neuen Thread aufmach dacht ich schreibste lieber hier.

    Hab soweit alles hinbekommen. Meine Rechner mit Linux gehn soweit, meine Handys funktioniern auch und ich habs sogar mit Hilfe der Unterhaltung hier hinbekommen den VPN für meine Boxen zum laufen zu kriegen.


    Was ich allerdings nicht hinbekommen hab war das Plugin zu nutzen mit dem ich mir über die Gui bei meinen Dreamboxen anzeigen lassen kann ob ich auch verbunden bin oder nicht also die IP schön anzeigen lassen. Sowas hätt ich echt gern, aber es scheint wohl nicht mit den aktuellen Boxen zu gehn, kann das sein?? Hab ne 900er und ne 7080 mit jeweils den aktuellen Img's.
    Kann ich über die Box direkt auch Befehle erteilen ohne das ich meine Kiste hier anschmeißen muss um zu checken ob die Verbindung steht?
    Hab zwar schon en bissl gestöbert aber noch keine Alternative zu dem Angebot gefunden was euer Kollege hier ma gemacht hatte.


    Und ist es schlimm dass ich anstatt den udp config mit tcp arbeiten muss? Hab mich schön an die Anleitung gehalten aber meine Dreamboxen wollten mit den UDP nicht arbeiten aber mit TCP schon. Is das arg schlimm?? Denn bis jetz sitz ich seit heud Mittag und so langsam .... :D Köpfchen brummt . :D

    Könntet ihr mir eventuell behilflich sein?

    Liebe Grüsse

    Evo