Beantwortet: DNS LEAK Schutz funktioniert nicht!

OhHiImJLN

Junior Member
Guten Abend!

Ich habe meinen PC vor 2 Tagen neu aufgesetzt und PP neu installiert.

Leider bekomme ich nun bei jeder Verbindung



Kein Anti-Virus installiert... firewall ebenfalls mal komplett ausgeschaltet.

Bitte um hilfe :x

Grüße,

JLN
 

tholinbo

Junior Member
Ja ich hatte die ausgeschalten, allerdings glaube ich ich habe die IPv4 und IPv6 nur in den Lan adapter eingetragen.Ich habe alles nochmal widerholt und beide adapter präpariert,bis jetzt keine Meldung mehr .Ich habe auch ein paar serverwechsel gemacht und ebenfalls keine Meldung mehr .Natürlich wenn ich mal das Netzwerk via Manager zurücksetze geht das Spiel wieder von vorne los.

Ich habe auch mal nachgesehen ob die eingegeben IPv4 und IPv6 Werte noch in den Adaptern stehen bei aufgebauter Verbindung ....ist nicht der Fall.

Was bei mir gar nicht funktioniert ist IPSEC ...der Manager crasht jedesmal. Womöglich muss ich noch einiges am Rechner vorab passend machen daß das sicher läuft , aber einfach direkt via manager geht absolut gar nix ....Nun ja, das ist allerdings eine andere Baustelle.
 

tholinbo

Junior Member
Erhalte ebenfalls beim booten und herstellen der Verbinbdung bereits genannten Fehler "Log PID_ERR replay-window backtrack occurred...." und zwar nachdem die Connection hergerstellt wurde 3 mal in Folge .
 

abudabi

Junior Member
Hallo Leute,

aufgrund meines ausgeprägten Halbwissens ;) weiß ich garnicht so genau ob ich in diesem Thread richtig bin. Ich muß aber halt bei jedem Start von PP die DNS-Leakschutz-Meldung "ignorieren".

Eigentlich funktioniert jedoch alles wie es soll:
- Ohne den VPN Manager "normale" Internetverbindung.
- Mit VPN Manager, aber ohne Verbindung geht nichts.
- Verbinde ich mich nun mit einem PP-Server funktioniert wieder alles, inklusive F und D Anzeige, es werden auch keine Warn-Icons angezeigt.
- CHECK IP von der PP-Webseite bestätigt mir dann auch die Verwendung von PP-DNS-Servern (ebenso bei DNS Leaktest).

Mein OS ist Win7 64bit. Kaspersky in der Testphase abgeschaltet. Alle anderen Netzwerkarten (1 physische fürs LAN, 2 virtuelle für VM) deaktiviert.

Bei der jetzt noch aktiven "Internet-Netzwerkkarte" ist normalerweise mein lokaler Router als DNS-Server eingetragen. Testweise auch mal DNS-Server vom Provider ebenso wie Google-DNS probiert, gleiches Ergebnis.
Der Netzwerk-Reset über Einstellungen / Sonstiges hat auch nichts gebracht, ebenso wie die Umstufung des Adapters in Arbeitsplatznetzwerk (normalerweise habe ich das als öffentlich eingestuft).

Nun habe ich mal in der PP-Log rumgestöbert - da kommen zwei Zeilen die aussehen als würde sich PP daran stören daß bei mir IPv6 deaktiviert ist:
(Zeitstempel) Debug Current setting: ... V6: DNS Manual, no current v6 DNS servers.
(Zeitstempel) Debug Should be setting: ... V6: DNS Manual, current DNS servers: (2 IPv6 Adressen)


Ist das vl des Rätsels Lösung? Der VPN-Manager macht sich Selbstvorwürfe weil er mein (nicht vorhandenes) IPv6 nicht schützen kann? Wäre ja schön, dann könnte ich fürderhin guten Gewissens "Dauerhaft ignorieren" anklicken, oder?

Gruß, abudabi
 

PP Frank

Staff member
guten Gewissens "Dauerhaft ignorieren"

Schlechte Ideee. Der DNS-Leak an sich ist jetzt nichts so extrem kritisches, aber eben doch unschön. DNS löst halt nur Domainname zu IP auf, schreibt das in den Cache des Computers(weswegen man den auch beim Start der TrackStop funktion neu starten oder DNS Cache leeren muss) und das also auch nur einmal in der laufenden Session.
Aber das tut ja nicht Not das diese Infos vorbei gehen.

Kaspersky ist dabei schon mal grundsätzlich eine schlechte Idee. Die 2016er Version ganz übel, ab 2017 macht es schon weniger Stress...
Es ist einfach drauf zu achten das IPv6 an ist und die Windows-Firewall aktiv ist. Bei dir scheint beides nicht der Fall zu sein.
Kaspersky zu deaktivieren bringt übrigens genau NUll. Das musst du schon komplett mit dem KAVREMOVER runter schmeissen. Siehe den Faden "Windows Security Suiten" unter Anleitungen hier im Forum
 

abudabi

Junior Member
Zunächst mal danke für die schnelle Antwort am WE!

Die Windows-Firewall war und ist aktiv. Wenn ich bei der betreffenden Netzwerkkarte IPv6 ankreuze und in Standardkonfiguration belasse kommt diese DNS-Leak-Warnung nicht mehr.

Das suggeriert doch nun daß ich eine Sicherheitslücke schließe indem ich alles unverändert lasse und lediglich ein zusätzliches Protokoll aktiviere. Ist das tatsächlich so der Fall?

Kaspersky updaten auf 2017 sollte kein Thema sein, das werde ich mir für demnächst mal auf die Fahne schreiben...
 

PP Frank

Staff member
Siehe den anderen Faden. Mit KIS 2016 geht der Firewallschutz AUF KEINEN FALL. Egal was du machst
Am Besten Kaspersky kicken. Ist eh was ganz furchtbares was überall rum fummelt wo es nichts zu suchen hat. Schmeiss es runter und installiere einen einfachen AntivirenScanner. Die Kostenlosen reichen vollkommen aus
 

abudabi

Junior Member
Ok, zur Kenntnis genommen. Was ist denn nun aber mit der Frage nach der DNS-Leak-Meldung:
Wenn ich bei der betreffenden Netzwerkkarte IPv6 ankreuze und in Standardkonfiguration belasse kommt diese DNS-Leak-Warnung nicht mehr.

Das suggeriert doch nun daß ich eine Sicherheitslücke schließe indem ich alles unverändert lasse und lediglich ein zusätzliches Protokoll aktiviere. Ist das tatsächlich so der Fall?
 

Nytro87

Junior Member
Zu dem DNS Leakschutz kann ich nur sagen, es darf in IPV4 und IPV6 im Ethernet Adapter einfach nichts eingetragen sein. Also alles auf automatisch beziehen lassen. Sobald ich oben den PC im Router eine feste IP zuweise bekomme ich die DNS Leakmeldung auch.

Wichtig nachdem du das gemacht hast unter C:\Program Files (x86)\Perfect Privacy VPN Manager die "DNSSettings.store" Datei löschen. Dann erst den VPN Clienten starten der erstellt die Datei dann neu! Die DNS Leak Fehlermeldung ist dann verschwunden! Ich gehe davon aus das unter Windows 10 dem Clienten nach wie vor die Rechte fehlen diese Datei selbstständig zu verändern oder zu löschen. Jedenfalls kriegt der Client das nicht gebacken bei mir ^^
 

abudabi

Junior Member
Danke für die Info. Das ist wohl die oben erwähnte Leerung des DNS Caches.
Aber wie gesagt geht's bei mir ja schon ohne Warnmeldung wenn ich IPv4 lasse wie's ist (also mit fester Adreßzuweisung sowie Router als DNS-Server) und einfach nur IPv6 aktiviere.
Schade nur daß mir die obige Frage nicht beantwortet wird...
 

tholinbo

Junior Member
Hallo miteinander

Leider bekomme ich die DNS fehlermeldung andauernd seit ich in den Einstellungen bei Firewall und DNS den Haken in beiden Fällen auf "Bei Programmstart aktivieren" gesetzt habe .Wenn ich bei Firewall den Haken bei "Bei Tunnelstart aktivieren" setze habe ich eigentlich keine Probleme mit einer DNS Leakschutz Fehlermeldung.Jedoch kann ich nicht ohne aktiver VPN Verbindung ins Netz weil ja alle Verbindungen bei dieser Firewall Einstellung blockiert sind ...

Es ist zum Haareraufen...Ich bitte um Unterstützung
 

PP Frank

Staff member
Entweder ein IPv6 Problem:

Prüfe alle deine LAN-Adapter-Einstellungen ob der Haken vor IPv6 gesetzt ist. Du findest das über das Netzwerk-Center von Windows. In der lionken Spalte gibt es dort einen Eintrag wo du in die Übersicht der Lan Adapter kommst. Dann einen Rechtsklick auf den jeweiligen LAn-Adapter und dann "Einstellungen".

Danach öffne folgendes Microsoft Support Dokument im Internetexplorer/Edge(KEINEM ANDEREN BROWSER): https://support.microsoft.com/en-us/kb/929852

Dort wählst du weiter unten "Re Enable IPv6". Nach Durchführung startet dein Rechner neu.

Oder sowas wie Security Software oder komische Tools wie CCleaner.
Versuch aber erstmal IPv6 zu aktiviern
 

tholinbo

Junior Member
Mit den jeweils für Firewall und DNS Leakschutz gesetzen Haken auf "Bei Tunnelstart aktivieren" in den Einstellungen habe ich das Problem daß, sobald ich die Verbindung löse für egal welchen genutzen Server und den Manager beende und einen Rechnerneustart mache ich kein Netz habe bzw nicht ins Netz kann ohne VPN...erst wenn ich den Manager starte und eine Verbindung aufbaue dann läuft das wieder.Setze ich die Haken jeweils auf "Bei Programmstart aktivieren" bekomme ich jedesmal die DNS Leakschutzfehlermeldung....und zwar immer , das nervt schon ziemlich

Bei beiden Adaptern sind die Haken für Ipv6 und 4 gesetzt. Allerdings weiß ich nicht ob dort dynamische IP's vergeben werden und wie man das gegebenenfalls einstellen muß oder ob das nicht wurscht wäre

I.e. Dummy braucht wie gesagt Hilfe

Ah danke für die so schnelle antwort ...Ich checke das und ja ich hab den CCleaner auf dem Rechner und als antivir das kostenlose avast ...

Also IPv6 ist in beiden Adaptern aktiviert ...ccleaner wurde gekilllt...DNS fehler erscheint nicht mehr ...dafür aber anderes Problem bekommen.

Problem ist : wenn Haken "bei Programmstart aktivieren" für firewall und DNS ...gesetzt ist werde ich nicht verbunden bzw der manager versucht die Verbindung herzustellen bleibt aber bei Verbinde zu XYZ hängen und git nicht die Meldung Verbunden mit warte auch Bestätigung etc...

Das Problem welches ich habe bei Neustart wennn ich die Haken auf bei Tunnelstart aktivieren lasse daß ich ohne VPN connection kein Netz habe habe ich noch nicht getestet.

Also nach Neustart habe ich jetzt wieder Netz auch ohne bestehende VPN verbindung :) Ich denke CCleaner war der Übeltäter ...Verbindungsaufbau mit gesetzten haken bei Programmstart geht jetzt auch :)

Hurrraaaaaa heh

Man dankt herzlichst für die Hilfe :)
 
Last edited by a moderator:

PP Frank

Staff member
Melde dich mal via Mail beim Support und frag nach ner Runde Teamviewer.... So aus der Ferne kann ich dir auch nicht sagen was an deinem Windows so extrem verfrickelt ist....
 
Top