Asus RT AC 86u DNS Leak

Discussion in 'Anonymität, Privatsphäre und Schutz' started by wolfibär44, Mar 12, 2019.

  1. w

    wolfibär44 Member

    Hallo zusammen leider habe ich ein wenig Probleme mit dem Router es befindet sich die aktuelle Asus merlin Software drauf. Leider kommt es sobald mein Router für Internet neu startet oder abstürzt auf dem Asus zum DNS Leak . Ich habe auch alles nach der Anleitung probiert die perfect zur verfügung stellt. das ganze hängt alles hinter einer fritzbox.

    Was ich bereits eingestellt habe:

    WAN-DNS-Einstellungen

    steht mometan auf Automatisch mit DNS-Server verbinden JA

    ich habe es auch auf Nein probiert und die DNS von Perfect probiert sowie opendns usw. das problem wird zwar dann gelöst aber es wird alles total langsam und träge der Seitenaufbau dauert total lange selbst YouTube Videos ruckeln dann.

    Alles läuft über openvpn auf 1,3,5 da ja hier bekanntlich die kernel besser genutzt werden aber immer nur eine verbindung.

    Die Einstellungen sehen wie folgt aus:


    Schnittstellentyp: TUN

    Protokoll: UDP

    Server Address and Port also adresse port 1151 port wechsel habe ich probiert keine änderung.

    Accept DNS Configuration: exclusive das hatte ich vorher auf strict wo manuell der dns eingetragen war.

    Cipher Negotiation : Disable

    Legacy/fallback cipher AES 256 CBC

    Komprimieren LZO ADAPTIVE

    Redirect Internet traffic : ALL hier wurden auch die punkte police rules sowie police strict probiert dann kommt es direkt zum dns leak. bei ALL nicht .

    Block routed clients if tunnel goes down JA habe ich auch eingestellt.

    Firewall white list wurde eingerichtet.

    Sobald die VPN verbindung weg ist geht nixs mehr was auch richtig ist. Aber sobald die fritzbox neustartet oder verbindung verliert und neu aufbaut besteht zwar die vpn verbindung noch aber es wird auch die DNS meines internet providers angezeigt. Das Problem tritt nur auf wenn die fritz die verbindung verliert oder neustartet.

    Ich weiss leider nicht mehr weiter wollte eigentlich bei perfect bleiben aber wenn so läuft werde ich nicht mehr verlängern.

    Ich hoffe ihr könnt mir helfen.
     
  2. Ghost

    Ghost Junior Member

    Also Perfect Privacy kann da wirklich nichts dafür, wenn du ein DNS-Leak hast.

    Vorläufig, bis du eine Lösung hast, würde ich an der Fritz!Box anstatt den DNS vom Provider einen anderen DNS-Server eintragen. z.B. 8.8.8.8
    Viel wichtiger ist ja, dass du kein IP-Leak hast.
     
  3. w

    wolfibär44 Member

    Leider tritt dieses problem nur auch seitdem ich bei perfect habe. Was ich beobachten konnte unter Wan einstellung sieht es momentan wie folgt aus :

    Verbindungstyp : Automatisch

    Wan IP kommt von der Fritz habe ich fest gelegt immer diese Adresse.

    DNS: hier steht die ip der Fritzbox wo man die Fritz drüber erreichen kann.

    Gateway: hier steht die ip der Fritzbox wo man die Fritz drüber erreichen kann.

    wird nun die einstellung im Asus vorgenommen das zb keine automatische dns zuweisung stattfindet sondern der DNS server manuell eingetragen wird ändert sich unter WAN einstellung im asus folgendes.

    bei DNS steht dann die manuell eingetragene DNS zb 8.8.8.8 drin ab dann läuft nixs mehr flüssig es stockt nur noch youtube und co puffern nurnoch der seitenaufbau ist total langsam ?
     
  4. O

    Opsecbase Member

    Hallo Wolfi, folgendes musst du machen:
    WAN DNS von Router auf die Server von Cloudflare
    1.1.1.1
    1.0.0.1
    IPv6 DNS von Router auf die Server von Cloudflare
    2606:4700:4700::1111
    2606:4700:4700::1001

    So bei den Opnvpn Settings bei Accept DNS Configuration auf
    Exclusive

    Policy Rules kannst du entweder auf Strict stellen und die dementsprechenden Geräte mit der Mac zuweisen und Verbindung auf per VPN stellen oder du stellst es auf Policy Rules All, dann wird der komplette Traffic durch den VPN geroutet. Habe parallel zwei VPN Clients auf 1 und 3 am laufen und unterschiedliche Geräte zugewiesen, läuft ohne Probleme.

    Die DNS Server von PerfectPrivacy kannst du nicht als ersten DNS einstellen, da sonst keine Verbindung zu den PP Servern aufgebaut werden kann, weil der erst die Domain des PP Servers auflösen muss.

    Ansonsten wenn die Verbindung ruckelt liegt es nicht an den DNS Einstellungen. Hast du Custom Configs vorgenommen? When dein Upload nur 1mbit oder so ist, was vermutlich der Fall ist musst du in den OpenVPN Dateien die Option

    fast-io

    hinzufügen. Dann läuft es wie es soll:).
     
  5. w

    wolfibär44 Member

    So hab mal ein paar Fotos von denn momentan Einstellungen gemacht eine Änderung der IPV6 ist nicht möglich sagt der Asus Router IP ungültig. An denn Benutzer definierten einstellungen habe ich nixs geändert.
     

    Attached Files:

  6. w

    wolfibär44 Member

    So läuft es mometan flüssig aber sobald die fritzbox die verbindung verliert kommt es zum DNS leak oder wenn die Fritz neustartet. Die IP von Perfect Privacy stimmt aber beim DNS Leak test wird dann die des Internet providers angezeigt. Ich werde mal die einstellungen mit der cloudflare beim dns machen sobald diese eingetragen ist läuft alles total träge werde dazu mal ein foto machen da bei wann sich auch was ändert im gegenzug zu vorher.
     
  7. l

    lilboy New Member

    Hast du den Asus Router in der FritzBox als Exposed Host freigegeben?

    Dann unter den WAN-Einstellungen die Einstellung "Automatisch mit DNS-Server verbinden" NEIN auswählen.
     
  8. w

    wolfibär44 Member

    Nein habe die einstellungen jetzt angepasst bis jetzt gab es kein dns leak hatte testweise mal die Fritzbox neu gestartet. Unter Openvpn Client habe ich denn Punkt : Redirect Internet traffic : hier habe ich All ausgewählt jetzt sollte doch eigentlich alles über die VPN laufen oder ?

    folgendes steht da zur auswahl : No , All, Policy Rules, Policy Rules Strict .

    Hier nochmal Fotos von denn neuen einstellungen ist das so ok ?

    Habe testweise auch mal die VPN Manuell getrennt dann läuft nixs mehr. Also sollte der Killswitch ja eigentlich auch klappen .

    Denn Asus Router habe ich in der Fritzbox nicht als Exposed Host freigegeben ist das nötig oder wichtig?

    Also laut Speedtest im Down habe ich 83Mbps / Up 34Mbps mit Vpn ping ca 20ms.
     

    Attached Files:

  9. w

    wolfibär44 Member

    Das einzige was beim Perfect check nicht angezeigt wird ist die IPV6 die wird überhaupt nicht angezeigt also ob diese nicht aktiv ist .
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice