SSH Manager started nicht, Linux Mint 18.01

ex1t

New Member
Hallo,

ich habe soeben den PP SSH Manager installiert, nutze Linux Mint 18.01.

Sobald ich ihn starten möchte erhalte ich allerdings folgenden Fehler:

Traceback (most recent call last):
File "/usr/bin/perfect-privacy-ssh", line 19, in <module>
current_locale, encoding = locale.getdefaultlocale()
File "/usr/lib/python2.7/locale.py", line 545, in getdefaultlocale
return _parse_localename(localename)
File "/usr/lib/python2.7/locale.py", line 477, in _parse_localename
raise ValueError, 'unknown locale: %s' % localename

Über Hilfe bin ich dankbar.
 

ex1t

New Member
Hey eig nicht, wie kann ich die denn einstellen?
python getlocale sagt mir:
(None, None)


und einfach in der shell locale -a gibt mit:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
C.UTF-8
POSIX
de_AT.utf8
de_BE.utf8
de_CH.utf8
de_DE.utf8
de_LI.utf8
de_LU.utf8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
 

tanjalein

New Member
Ich habe die drei Fehlermeldungen zusammen in Google geworfen und drei Links gefunden.
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory

(1) https://askubuntu.com/questions/33025/locale-settings-are-not-right-how-can-i-reset-them
(2) https://askubuntu.com/questions/599808/cannot-set-lc-ctype-to-default-locale-no-such-file-or-directory
(3) https://help.ubuntu.com/community/EnvironmentVariables

in (1) werden Konfigfiles erwähnt, die man durchsuchen sollte, um die fehlenden Spracheinstellungen zu finden.
Die Antworten #2 und #4 sahen recht vernünftig aus.
 
Top