Random sites failing to resolve and connect

Discussion in 'Services - Questions & Answers (Q&A)' started by Bri Bri, Jun 6, 2018.

  1. B

    Bri Bri New Member

    I've been having a problem lately where I will be unable to connect to arbitrary websites when connected to Perfect Privacy's VPN. Most of the time I have no trouble connecting to sites, but occasionally (around 1-3 times a day) there will be a site that will timeout and not load.

    I'm not 100% sure, but I think the issue is that the hostnames are not being resolved by DNS. I say this because if I try to ping the website using its hostname, it never gets as far as resolving it and trying to ping its IP address.

    I am generally connected to the New York and Chicago US servers. I can't recall if I've seen this issue on non-US servers. And I've experienced this issue on multiple different devices, including two macs and an iPhone.

    Sometimes when a site won't connect, simply disconnect and reconnecting to the VPN clears it up. Other times, that doesn't work, but changing to a different server will clear it up. And generally the issue clears up on its own after some number of minutes, sometime just a few minutes, and sometimes after an hour. In all cases, disconnecting from the VPN and connecting without it will reliably allow me to connect to the site.

    Is anyone else experiencing this? Is there anything I can do to fix it, other than trying a different DNS server? (I'd prefer to use Perfect Privacy's DNS.)
     
  2. PP Stephan

    PP Stephan Staff Member

    Do you have any TrackStop filters active? Try to deactivate TrackStop to see if that fixes the issue.
     
  3. B

    Bri Bri New Member

    I have already tried that, and it had no effect.
     
  4. B

    Bri Bri New Member

    Also, I can add that it's not just a DNS problem. Yesterday I experienced this issue in a new way: I was disconnected from a server I was already connected to, and was unable to reconnect to it even if I used its IP address. After disconnecting from the VPN, I could connect just fine again. And then the issue with the VPN cleared up within about ten minutes.
     
  5. PP Stephan

    PP Stephan Staff Member

    What error message does the website display? The only thing I can think of is that some other software on your computer might intefere.
     
  6. B

    Bri Bri New Member

    It just says the page cannot be displayed. Fundamentally the problem is that the connection to the server is timing out. I can neither resolve the server's DNS name nor can I ping its IP address.

    I don't see how it could be software that's interfering, as this has happened now on two macs and two iPhones. I'm not ruling it out, but particularly on iOS there's not a lot you can do to interfere with this sort of thing.
     
  7. B

    Bri Bri New Member

    Correction: it may primarily be a DNS issue, and the server isn't actually timing out. I just encountered the problem again, and the connection to the web server immediately failed. If I tried to resolve the DNS name I was connecting to, it would immediately fail with the error "Unknown host".

    I then used another system to figure out the IP address for that DNS name, and then manually added an entry to the failing system's hosts file so that it wasn't necessary to look it up. I could then successfully connect to the web server.

    So for some reason, random websites are failing to have their name resolve when connected to Perfect Privacy. The issue I reported on June 7 where I was disconnected from a server may be related, but more likely it was a separate one time issue.
     
  8. MixMaster

    MixMaster Member

    Do you have any Trackstop filters enabled? That feature would block DNS resolution for filtered names.
     
  9. B

    Bri Bri New Member

    Yes, that was my first thought, but the issue persisted after disabling them. It's also the case that switching between VPN servers or disconnect and reconnecting from the VPN often clears this up, and you wouldn't expect that to happen with sites blocked by TrackStop.
     
  10. B

    Bri Bri New Member

    Is there anyway I can check whether a particular site is being blocked by one or more TrackStop filters?