[pfSense] VPN nur in einem einzigen VLAN benutzen

circle024

Freshly Joined Member
Moin :D

Ich habe mehrere VLANs, die komplett voneinander getrennt sind und ich möchte nun, dass nur eins davon durch den OpenVPN Tunnel läuft.
Nach dieser Anleitung habe ich mir nun mein Vlan Nr. 20 (Auf den Screenshots "Atlas" genannt) eingerichtet und der Tunnel & die Verbindung funktioniert auch.

Auf der NAT Seite habe ich wie in der Anleitung nun die "ISAKMP" Regel(n) alle gelöscht. (Bild unten)
1. Frage: War das so richtig, oder soll man nur die ISAKMP Einträge löschen, die man durch den VPN routen möchte?

NAT.PNG


Leider habe ich nun aber, sobald ich ich in den Rules als Destination etwas anderes als "any" setze, keine Internet-Verbindung mehr. (und zwar in allen VLANs, die ich ausprobiert habe)
Als Fehler erscheint mir im Firefox, dass die jeweilige IP nicht aufgelöst werden konnte, deswegen vermute ich, dass es etwas mit dem DNS Resolver zu tun haben könnte.

Dieser ist bei mir aktuell noch wie unten auf dem Screenshot eingestellt.
Wenn ich das korrekte verstehe, müsste es aber auch reichen, wenn ich hier einfach nur "WAN" und "VPN_PP_FRANKFURT" anwähle, weil ja sowieso nur die beiden Interfaces direkt nach außen kommunizieren, korrekt?

DNS Resolver.PNG


Die Regel des VPN VLANs sieht wie folgt aus:
VPN.PNG

Wie gesagt, das Problem tritt auf, wenn ich als Desination in den VLAN Regeln statt "any" z.B. "OpenVPN Net" oder in dem VLAN ohne VPN "Wan Net" auswähle.
Seltsamerweise geht es, wenn ich einfach "any" als Destination setze und alle anderen VLANs blockiere...

Kann mir damit bitte jemand weiterhelfen?

Beste Grüße :)
Markus
 
Top