Perfect-Privacy-VPN startet nach Update nicht mehr (Linux)

Discussion in 'Linux' started by krischperl, Apr 22, 2017.

  1. k

    krischperl New Member

    Hallo,

    Perfect-Privacy-VPN lief bis einschließlich Version 1.3.8 problemlos auf einer virtuellen Debian-Jessie-Installation.
    Das Update Version 1.3.9 führte dazu, dass sich Perfect-Privacy-VPN nicht mehr mit normalen Benutzerrechten, sondern nur noch als Root starten lässt.

    De- und komplette Neuinstallation von Perfect-Privacy mit der aktuellen Version auf unterschiedlichen virtuellen Debianmaschinen zeigte den gleichen Effekt.

    Beim Vergleich der Installation Version 1.3.8 mit 1.3.9 habe ich keine Unterschiede bei den Zugriffsrechten sowie der Benutzer- und Gruppenzugehörigkeit der Verzeichnisse und Dateien gefunden.

    Wie bekomme ich die Version 1.3.9 mit normalen Benutzerrechten zum Laufen?
     
    fbn6 likes this.
  2. f

    fbn6 New Member

    Hi, sorry don't speak German, but I can confirm this is happening to me as well, I'm on Ubuntu Mate 16.04 and it was working just fine before the new client. Now I can only run it as root.
     
  3. Ghost

    Ghost Junior Member

    Kann ich bestätigen, allerdings mit virtuellen Linux Mint Mate 18.1
    PP Manager startet nicht mehr.
     
  4. PP Stephan

    PP Stephan Staff Member

    Wir sind da dran. Problem ist im Startscript. Momentaner workaround, in der Konsole folgendes eingeben

    pkexec perfect-privacy-vpn

    Wir werden das in Kürze beheben.
     
    Last edited: Apr 24, 2017
  5. U

    UPhmWgXe33g9 Member

    Ergänzend unter Xubuntu 17.04:

    Version 1.3.9 läßt sich einwandfrei installieren und der Erststart funktioniert auch.
    Beendet man das Programm und möchte es erneut starten, so erfolgt keine Reaktion.

    Workaround: Das PP-VPN-Paket (bspw. über Synaptic) erneut installieren, danach funktioniert es in diesem Szenario zumindest wieder einwandfrei.
    Etwaige Nutzerproblematiken konnte ich nicht feststellen.

    Gruß
     
  6. PP Stephan

    PP Stephan Staff Member

    Ja, ein Update steht nun bereit. Noch einmal auf die letzte Version updaten (apt-get upgrade) und das Problem sollte behoben sein.
     
    UPhmWgXe33g9 likes this.
  7. Ghost

    Ghost Junior Member

    Confirmed :)
     
  8. k

    krischperl New Member

    Es funktioniert- danke
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice