Solved: Perfect Privacy Tunnel Manager setup issues

Zonie241

Junior Member
Hello, I installed the "Perfect Privacy Tunnel Manager" and used settings to add port 8020 and an name to all the servers. I have Firefox and set up the access to "Manual proxy config" with localhost and port 8020 in all options. When I restart the Firefox browser I get the error "The Connection was reset. The connection to the server was reset while the page was loading"

I tried Firefox without the proxy and it works fine so it is not the firewall and the internet is running perfectly. any ideas on what else I may have overlooked while setting this up?
 

PP Daniel

Staff member
Hi,

I'm not exactly sure if I get what you tried correctly. A couple of questions: The port 8020 you were using, which type of proxy was it for? HTTP or SOCKS5?

In Firefox it should be sufficient to fill the HTTP proxy fields (localhost & port) and use the checkbox underneath to apply this setting to the fields below.
Are you sure you established a connection with the Tunnelmanager? Was the icon green?

It would be very helpful if you could provide some screenshots of your settings in the Tunnelmanager and Firefox as well. Please cover your username though.
 

Zonie241

Junior Member
Here are the details.

I have problems connecting using the PP Tunnel Manager (no problems before when I was using the SSH).

My steps:
I downloaded “PP_TunnelManager_Setup.exe 643.80 KB 08/23/13 11:35 (UTC)” and installed it
I updated the server list
Chose Amsterdam1 at port 8020 with “store Password” “Auto reconnect on disconnect” and to server “amsterdam1 perfect-privacy.com” and put the user name and password. Using the SOCKS option
I connected fine and shows a green colored “PP” on my tray

My Firefox:
Options
Network
Under connections clicked “Settings”
Click Manual proxy configuration
Localhost port 8020

When I try to open any website I get this error:
“The connection was reset”
The connection to the server was reset while the page was loading.
Etc etc

Could you please guide me in what step I missed in the set up?

I tested….
I run the SSH to Luxemburg and it runs fine
I run the Open VPN and it runs fine with the proper IP address
I tried the same as above with and without the McAfee Firewall and in both cases I get the same "The connection was reset...."

Enclosed please find the three pics to explain it better.

Thanks in advance for your help.
 

PP Daniel

Staff member
Hi,

for SOCKS5 your settings in Firefox seem to be wrong. They would work using an http proxy like Squid though. My recommendation: in the PP Tunnel Manager use the HTTP PROXY, not the SOCKS PROXY, for webbrowsers generally you want an http proxy, not a SOCKS one. If you switch to an http proxy you might need to pick another port, but then your settings would be correct.

If you want to use SOCKS5 with your Firefox anyway, you need to uncheck the box ("..for all protocols"), empty the upper fields and only have "localhost" and the configured port in the "SOCKS-Host" line, which would in this case not be grayed-out. But using SOCKS in a webbrowser is not recommended.
 
Top