Solved: OpenVPN on DD-WRT with Linksys WRT3200ACM

Can somebody help me quickly to solve my config issue/s urgently?

  • can be solved with the configuration changes/updates

    Votes: 0 0.0%
  • apply this changes

    Votes: 1 100.0%

  • Total voters
    1

esoenmez

New Member
Hi there
Somehow I can't get my OpenVPN Client up and running with DD-WRT on Linksys WRT3200ACM with the latest Firmware: DD-WRT v3.0-r30796 std (10/25/16), I've tried many guides but no Tunnel and no connection with the following config:
Screenshot 2016-11-10 um 16.41.11.png Screenshot 2016-11-10 um 16.46.25.png Screenshot 2016-11-10 um 16.47.16.png Screenshot 2016-11-10 um 16.49.46.png
Many thanks in advance to all great admins here.
 

esoenmez

New Member
activated still no change - tunnel interface is still not established, but something is strange with one interface:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MULTICAST MTU:65536 Metric:1
RX packets:117 errors:0 dropped:0 overruns:0 frame:0
TX packets:117 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7826 (7.6 KiB) TX bytes:7826 (7.6 KiB)

I've also tried now with Frankfurt server settings - the same result no connection
 

esoenmez

New Member
with DD-WRT v3.0-r30826 std (11/01/16) and after turning on IPv6 with radvd the following additional config setup the connection could be established:
client
comp-lzo
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
ns-cert-type server
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
remote-random
reneg-sec 3600
resolv-retry 60
route-delay 2
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4
tun-ipv6
auth-nocache
redirect-gateway def1
 

privacy

Junior Member
IPv6, AES 128 for tls and additional config works

redirect-gateway def1
reneg-sec 86400
mssfix
float
persist-remote-ip
route-method exe
route-delay 2
tls-timeout 5
hand-window 120
inactive 604800
ping 5
ping-restart 90
replay-window 512 60
mute-replay-warnings

Edit:

If you choose AES 128 as tls cipher then no additional config need it works
 
Last edited:
Top