Beantwortet: OpenVPN mit Win 10 1709 - keine Verbindung

ViperVP

New Member
Gestern Abend hatte ich mein Windows 10 auf die Version 1709 upgedated. Heute habe ich bemerkt, dass ich über den VPN-Manager keine OpenVPN-Verbindung mehr herstellen kann. IPSEC funktioniert aber.

Direkt über den Asus Router kann ich eine OpenVPN-Verbindung aufbauen.

An einem anderen PC mit Windows 10 Version 1703 funktioniert eine OpenVPN-Verbindung über den VPN-Manager dagegen einwandfrei.

Ich vermute also eine Inkompatibilität zwischen dem VPN-Manager und der neuen Windows 10 Version. Kann das jemand bestätigen?
 
Last edited:

ViperVP

New Member
Liegt es vielleicht an der Netzwerk-Einstellung "Automatische Metrik"? Hier mehr dazu:
https://gedankenausbruch.com/tipps-...-und-verbindung-langsam-nach-creators-update/

Leider kann ich diese Einstellung nicht vornehmen, da die Netzwerkverbindung ja nicht zustande kommt. Wenn es wirklich an der Metrik liegt, müsste wohl der VPN-Manager dahingehend geändert werden.
Der Wert 1 soll angeblich die Lösung sein.

Windows 10, Version 1709 ist ja nicht erst seit gestern verfügbar. Wundert mich, dass sonst niemand Probleme gemeldet hat.
 

ViperVP

New Member
Wunderbar, das war die Lösung. Habe die Firewall auf Standard zurückgesetzt und nun funktionierts wieder. Habe im Forum aber vorher nichts dazu gefunden.
 

Nytro87

Junior Member
Ist auch nicht die Regel. Ich musste nach Fall Creators Update 1709 nix zurück setzen, lief einwandfrei!

Manchmal macht Win10 beim Update wohl irgendein Mist.
 

Hoppla

Junior Member
Ähnliches Problem:
neuer Rechner windows 10.
Verbindung nur über IPSec möglich
bei OpenVPN verlangt er plötzlich nach Zugangsdaten akzeptiert sie aber nicht
und die eigentlich bereits gespeicherten sind weg.

Alle updates installiert
Firewall zurückgesetzt
Netzwerk zurückgesetzt
Mit oder ohne Avast.
OpenVPN will einfach nicht.

Leicht überfordert, da ich auch noch Neueinsteiger für Win 10 bin und erstmal alles suchen muß.

Hoppla
 

omert4

New Member
Das selbe Problem auch bei mir, hab die Platte jetzt 2x formatiert und Win10 neu aufgesetzt und hats alles nicht gebracht.

Habe ebenfalls alles auf Standart zurückgesetzt und all das was hier halt angegeben wurde, bring auch wieder nichts.

Keine verbindung mit oVPN, wie auch keine verbindung über IPSEC, bei IPSEC fragt er immer wieder meine Zugangsdaten ab, folgt aber auch keine Verbindung.

Log:
=======================================
25.12.2017 16:42:26 Debug Debug: config connect called
25.12.2017 16:42:26 Log DisconnectReason set to NoDisconnect in connect_thread
25.12.2017 16:42:26 Log Debug: connect_thread started
25.12.2017 16:42:27 Log State Change Event - Initializing
25.12.2017 16:42:27 Log Waiting for OpenVPN.exe to get ready
25.12.2017 16:42:27 Log OpenVPN.exe ready
25.12.2017 16:42:27 Log Checking firewall and DNS leak protection settings
25.12.2017 16:42:29 Log Waiting for network to get ready
25.12.2017 16:42:29 Debug Debug: Serviceconnection connect called
25.12.2017 16:42:30 Management Connecting to management interface 127.0.0.1:11242
25.12.2017 16:42:30 Log MANAGEMENT: CMD 'state on'
25.12.2017 16:42:30 Log MANAGEMENT: CMD 'hold release'
25.12.2017 16:42:30 Log MANAGEMENT: CMD 'username 'Auth' "<Username Removed>"'
25.12.2017 16:42:31 Log MANAGEMENT: CMD 'password [...]'
25.12.2017 16:42:31 Log MANAGEMENT: CMD '"'

Bin jetzt von Win7 auf Win10 umgestiegen und dann sowas.. weiß jetzt echt nicht mehr weiter, brauchte dringend Verbindung.
 

omert4

New Member
Moin, der log endet exakt wie oben angegeben.

Ich habe den Client schon desöfteren deinstalliert und nochmal Neu installiert, Updates gab es keine, die Firewall von Win10 wurde auf "Standart" zurückgesetzt und im Client ebenfalls die Netzwerkeinstellungen zurückgesetzt.

Laut Win10 Firewall, blockiert es 3 ausgehende verbindungen von PP, wenn ich mich recht erinnere waren es DNSleak block, UDP und noch etwas. Wenn ich diese nun versuche freizugeben, sperrt er sie mir aber wieder beim nächsten versuch zu verbinden.

Habe es vorerst komplett deinstalliert und werde mir für die zwischenzeit womöglich Win7 auf die VM installieren müssen, bis es dann eine Lösüng für Win10 gibt.

Haltet mich bitte auf dem laufenden, die oVPN Software scheint auch davon betroffen zu sein, deshalb vermute ich, das es einfach nur an Win10 liegen kann. Brauche dringend die richtigen Settings.

OS Info: Win10 Version 1709 (Build 16299.15)

LG
 

omert4

New Member
Unten ist der Log nochmal vollständig.

Ich habe es soeben noch einmal versucht über Win10 laufen zu bekommen, doch leider vergebens und es liegt definitiv an der Win-Firewall.

Wenn ich die Regel selbst bestimme, dann folgt bei erneutem Verbindungsversuch einfach neue Regeln zum VPN die geblockt werden, also dann doppelt.

Log:
26.12.2017 16:33:36 Debug Debug: config connect called
26.12.2017 16:33:36 Log DisconnectReason set to NoDisconnect in connect_thread
26.12.2017 16:33:36 Log Debug: connect_thread started
26.12.2017 16:33:36 Log State Change Event - Initializing
26.12.2017 16:33:37 Log Waiting for OpenVPN.exe to get ready
26.12.2017 16:33:37 Log OpenVPN.exe ready
26.12.2017 16:33:37 Log Checking firewall and DNS leak protection settings
26.12.2017 16:33:39 Log Waiting for network to get ready
26.12.2017 16:33:39 Debug Debug: Serviceconnection connect called
26.12.2017 16:33:40 Management Connecting to management interface 127.0.0.1:11205
26.12.2017 16:33:40 Log MANAGEMENT: CMD 'state on'
26.12.2017 16:33:40 Log MANAGEMENT: CMD 'hold release'
26.12.2017 16:33:40 Log MANAGEMENT: CMD 'username 'Auth' "<Username Removed>"'
26.12.2017 16:33:41 Log MANAGEMENT: CMD 'password [...]'
26.12.2017 16:33:41 Log MANAGEMENT: CMD '"'
26.12.2017 16:35:36 Log Hangtimer has elapsed, connection might be stalled, disconnecting
26.12.2017 16:35:36 Log Tunnel Frankfurt Disconnect Called Reason:Error
26.12.2017 16:35:36 Debug Debug: Serviceconnection Disconnect called
26.12.2017 16:35:36 Debug killConnection called
26.12.2017 16:35:36 Management Sending signal to close connection
26.12.2017 16:35:36 Log MANAGEMENT: CMD 'exit'
26.12.2017 16:35:36 Management Disconnecting from management interface
26.12.2017 16:35:36 Debug SendDisconnect done
26.12.2017 16:35:36 Management Disconnecting from management interface
26.12.2017 16:35:36 Debug DisconnectLogic done
26.12.2017 16:35:36 Log State Change Event - Stopping
26.12.2017 16:35:38 Log State Change Event - Stopped
26.12.2017 16:35:38 Log state changes to stoped, reason: Error
26.12.2017 16:35:38 Log Handle disconnect for reason Error error:HangTimerElapsed
26.12.2017 16:35:38 Debug Debug: config connect called
26.12.2017 16:35:38 Log DisconnectReason set to NoDisconnect in connect_thread
26.12.2017 16:35:38 Log Debug: connect_thread started
26.12.2017 16:35:38 Log State Change Event - Initializing
26.12.2017 16:35:39 Log Waiting for system to get ready..
26.12.2017 16:35:39 Log Waiting for OpenVPN.exe to get ready
26.12.2017 16:35:39 Log OpenVPN.exe ready
26.12.2017 16:35:39 Log Checking firewall and DNS leak protection settings
26.12.2017 16:35:40 Log Waiting for network to get ready
26.12.2017 16:35:41 Debug Debug: Serviceconnection connect called
26.12.2017 16:35:41 Log Tunnel Frankfurt Disconnect Called Reason:UserClicked
26.12.2017 16:35:41 Debug Debug: Serviceconnection Disconnect called
26.12.2017 16:35:41 Log State Change Event - Stopping
26.12.2017 16:35:41 Debug killConnection called
26.12.2017 16:35:41 Management Sending signal to close connection
26.12.2017 16:35:41 Debug SendDisconnect done
26.12.2017 16:35:41 Management Disconnecting from management interface
26.12.2017 16:35:41 Debug DisconnectLogic done
26.12.2017 16:35:42 Management Connecting to management interface 127.0.0.1:11205
26.12.2017 16:35:42 Management Disconnecting from management interface
26.12.2017 16:35:42 Log State Change Event - Stopped
26.12.2017 16:35:42 Log state changes to stoped, reason: UserClicked
26.12.2017 16:35:42 Log Handle disconnect for reason UserClicked error:NoError
26.12.2017 16:44:45 Debug Debug: config connect called
26.12.2017 16:44:45 Log DisconnectReason set to NoDisconnect in connect_thread
26.12.2017 16:44:45 Log Debug: connect_thread started
26.12.2017 16:44:46 Log State Change Event - Initializing
26.12.2017 16:44:46 Log Waiting for OpenVPN.exe to get ready
26.12.2017 16:44:46 Log OpenVPN.exe ready
26.12.2017 16:44:46 Log Checking firewall and DNS leak protection settings
26.12.2017 16:44:48 Log Waiting for network to get ready
26.12.2017 16:44:49 Debug Debug: Serviceconnection connect called
26.12.2017 16:44:50 Management Connecting to management interface 127.0.0.1:11205
26.12.2017 16:44:50 Log MANAGEMENT: CMD 'state on'
26.12.2017 16:44:50 Log MANAGEMENT: CMD 'hold release'
26.12.2017 16:44:50 Log MANAGEMENT: CMD 'username 'Auth' "<Username Removed>"'
26.12.2017 16:44:51 Log MANAGEMENT: CMD 'password [...]'
26.12.2017 16:44:51 Log MANAGEMENT: CMD '"'

LG
 

omert4

New Member
Hast du IPSec mal versucht? Ansonsten könntest du auch mal StealthVPN aktivieren....

Bei IPSec verschwinden einfach nur die Zugangsdaten und verbindet ebenfalls nicht.
StealthVPN per stunel oder SSH hatte ich schon getestet, da ich dies hauptsächlich nutze, aber auch nicht möglich.

Lieber wäre mir die Verbindung über oVPN, was aber selbst mit der Hauseigenen software nicht funktioniert, die Win10 Firewall nimmt leider keine Regeln an, bzw. hält sie nur kurzfristig und beim nächsten versuch tauchen dann wieder die selben Regeln neu auf (blockiert).
 

omert4

New Member
Nabend,

ich weiß zwar nicht woran es jetzt gelegen hat, da ich auch nichts mehr am System geändert hatte, aber nach erneutem versuch & neuem Account funktionierte nun plötztlich alles, was mich natürlich sehr erfreut. :D

LG
 
Top