OpenVPN auf Synology Router (RT2600ac)

Yonex

New Member
Hallo,

Ich komme da nicht mehr weiter. Ich habe OpenVPN auf meinem Synology Router (RT2600ac) eingerichtet. In der Router-Einstellung steht zwar, dass ich mit VPN verbunden bin. Doch gemäss Perfect-Privacy Tests, ist meine Verbindung ungeschützt. Kann mir da jemand weiterhelfen?

Vielen Dank
 

Attachments

Gerd

Junior Member
Für welches Gerät hast du im Mitgliederbereich die .ovpn Datei runter geladen? Gibt es eine OpenVPN Logdatei?

Edit: Welche Einstellungen hast du beim Download der .ovpn Datei gewählt?
 
Last edited:

Yonex

New Member
Also ich habe hier die .ovpn Datei heruntergeladen: https://www.perfect-privacy.com/de/...tocol=udp&cipher=AES-256-CBC&keyformat=inline

Ich wählte die
Version 2.3 (die Version 2.2 kann man irgendwie nicht herunterladen)
Protokoll: UDP / TCP (habe beides probiert, aber es geht trotzdem nicht)
Verschlüsselung: AES-256-CBC
Schlüsselformat: Inline
Gruppierung: Stadt
Dateityp: zip

Edit: Vermutlich muss ich etwas am Router einstellen. Ich habe schon mit jeglichen Einstellungen beim Download der .ovpn Datei probiert.
 

Attachments

Last edited:

Gerd

Junior Member
hmm

Eine Logdatei wäre hilfreich.

So kann man nur spekulieren woran es liegen könnte.

Ist z. B. IPv6 eingeschaltet?

Hast du schon AsusWRT (nicht AsusWRT Merlin) .ovpn Datei ausprobiert?
 

Yonex

New Member
Bei mir steht sowas

Edit: IPv6 ist aktiviert. Ich habe es auf automatisch eingestellt. Aber trotzdem zeigt es auf der PP Seite, dass ich keine IPv6 Verbindung habe.
 

Attachments

Last edited:

Gerd

Junior Member
In der Logdatei sollte so etwas stehen wie:

Initialization Sequence Completed.

Kann man die Logdatei ausführlicher einstellen?
 

Gerd

Junior Member
Edit: IPv6 ist aktiviert. Ich habe es auf automatisch eingestellt. Aber trotzdem zeigt es auf der PP Seite, dass ich keine IPv6 Verbindung habe.
Ob das jetzt an IPv6 liegt, kann ich nicht sagen.

Auf Asus Routern hat man z. B. IPv6 native eingestellt. Native Option gibt es wohl beim rt2600ac nicht. Ich würde aber auch andere Optionen versuchen, wie z. B. DHCPv6-PD.
 

Yonex

New Member
Die Logdatei über die GUI ausführlicher einzustellen geht nicht.

Das ist alles völliges Neuland für mich. Ich versuche über SSH die Logdatei zu finden.

Sind diese Daten relevant?
ovpnclient.conf
openvpn.conf
 

Attachments

Gerd

Junior Member
Die Einstellungen die dein Router übernommen hat stehen in openvpn.conf. Es scheint so als ob viele Einstellungen nicht passen.
Ich erstelle mal kurz eine andere .ovpn Datei mit Zertifikaten und lade die hier hoch.
 

Gerd

Junior Member
hier ein Link von Basel Konfigurationsdateien: https://1drv.ms/u/s!AnaMqM-sYsgbgQlpSGUnpAZ2aLuG

Edit: Es wäre nicht schlecht, wenn du nachdem du die .ovpn Datei und die Zertifikate importiert hast, eine vollständige openvpn.conf Datei vom Router hier einfügst. Nur um es gegen zu checken, ob alles richtig übernommen wurde.
 
Last edited:

Yonex

New Member
Deine konfigurierte .ovpn Datei funktioniert irgendwie auch nicht. Diesmal steht nicht mal, dass es verbunden ist. Seltsam.

ovpnclient.conf
Code:
[o1558749284]
nat=yes
redirect-gateway=yes
create_via_conf=yes
pass=qfwxrN28Aal1lfPY
reconnect=yes
conf_name=Connection
user=XXXXXX
remote=82.199.134.162
client_o1558749284
Code:
client
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4
tun-mtu  1500
proto udp
fragment 1300
mssfix
comp-lzo
remote 82.199.134.162 148
cipher AES-256-CBC
auth SHA512
ns-cert-type server
key-direction 1

up /usr/syno/etc.defaults/synovpnclient/scripts/ovpn-up
route-up /usr/syno/etc.defaults/synovpnclient/scripts/route-up
plugin /lib/openvpn/openvpn-down-root.so /usr/syno/etc.defaults/synovpnclient/scripts/ip-down
ca ca_o1558749284.crt
key client_key_o1558749284.key
cert client_crt_o1558749284.crt
tls-auth ta_o1558749284.key 1
 

Attachments

Yonex

New Member
vpnc_last_connect
Code:
[curr_info]
route=82.199.134.162 via 192.168.1.1 dev br0  src 192.168.1.141
server_ip_num=1
server_ip0=82.199.134.162
ds_mask=255.255.255.0
conf_id=o1558750296
mask=255.255.255.0
start_time=19768
ip=10.4.132.240
kill=yes
ds_if=br0
proto=openvpn
server=82.199.134.162
reconnect=yes
reconnect_times=0
conf_name=Connection
ds_ip=192.168.1.141
ds_dns=8.8.8.8 via 192.168.1.1 dev br0  src 192.168.1.141
if=tun0
def_gw=192.168.1.1
 

Gerd

Junior Member
Auf jeden Fall sieht die client_o1558749284 schon mal besser aus. Ich vermute mal das bei mir irgendwo ein Fehler eingeschlichen ist.

Vorher konnte dein Router irgendetwas schlecht umsetzen.

Entweder mehrere remote Befehle mit remote-random:

Code:
remote-random
remote 82.199.134.162 148
remote x.x.x.x 149
remote x.x.x.x 150
remote x.x.x.x 151
remote x.x.x.x 1148
remote x.x.x.x 1149
remote x.x.x.x 1150
remote x.x.x.x 1151
oder:

Code:
ignore-unknown-option ncp-disable
ncp-disable
oder dein Router versteht die .ovpn Datei nicht, die Zertifikate beinhaltet.

Nimm mal diese Konfiguration:
  • MacOS
  • OpenVPN
  • 2.3
  • UDP
  • AES-256-CBC
  • Separat
  • zip
Öffne die .ovpn Datei und entferne diese Zeilen:

Code:
ca   ca.crt
cert Basel1_cl.crt
key  Basel1_cl.key
tls-auth Basel1_ta.key
Edit: ca.crt ist für alle Server.
 

Yonex

New Member
Ich glaube es liegt an meinem Router, dass es nicht funktioniert. Ich werde in nächster Zeit mit Synology Kontakt aufnehmen.

Entweder mehrere remote Befehle mit remote-random:
ovpnclient.conf
Code:
[o1558796255]
nat=yes
redirect-gateway=yes
create_via_conf=yes
reconnect=yes
conf_name=Connection
user=xxxxxxx
remote=82.199.134.162
client_o1558796255
Code:
client
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4
tun-mtu  1500
proto udp
fragment 1300
mssfix
comp-lzo

remote-random

remote 82.199.134.162 148

remote 82.199.134.162 149

remote 82.199.134.162 150

remote 82.199.134.162 151

remote 82.199.134.162 1148

remote 82.199.134.162 1149

remote 82.199.134.162 1150

remote 82.199.134.162 1151

remote 80.255.7.66 148

remote 80.255.7.66 149

remote 80.255.7.66 150

remote 80.255.7.66 151

remote 80.255.7.66 1148

remote 80.255.7.66 1149

remote 80.255.7.66 1150

remote 80.255.7.66 1151

cipher AES-256-CBC
auth SHA512
ns-cert-type server
key-direction 1

up /usr/syno/etc.defaults/synovpnclient/scripts/ovpn-up
route-up /usr/syno/etc.defaults/synovpnclient/scripts/route-up
plugin /lib/openvpn/openvpn-down-root.so /usr/syno/etc.defaults/synovpnclient/scripts/ip-down
ca ca_o1558796255.crt
key client_key_o1558796255.key
cert client_crt_o1558796255.crt
tls-auth ta_o1558796255.key 1
vpnc_last_connect
Code:
[curr_info]
route=82.199.134.162 via 192.168.1.1 dev br0  src 192.168.1.141
server_ip_num=1
server_ip0=82.199.134.162
ds_mask=255.255.255.0
conf_id=o1558795850
mask=255.255.255.0
start_time=65319
ip=10.4.132.242
kill=yes
ds_if=br0
proto=openvpn
server=82.199.134.162
reconnect=yes
reconnect_times=0
conf_name=Connection
ds_ip=192.168.1.141
ds_dns=8.8.8.8 via 192.168.1.1 dev br0  src 192.168.1.141
if=tun0
def_gw=192.168.1.1
 

Yonex

New Member
Nimm mal diese Konfiguration:
  • MacOS
  • OpenVPN
  • 2.3
  • UDP
  • AES-256-CBC
  • Separat
  • zip
Öffne die .ovpn Datei und entferne diese Zeilen:

Code:
ca ca.crt
cert Basel1_cl.crt
key Basel1_cl.key
tls-auth Basel1_ta.key
Die MacOS Konfiguration zeigt wenigstens, dass es verbunden ist. Aber es ist eben noch ungeschützt. Merkwürdig.

ovpnclient.conf
Code:
[o1558797560]
nat=yes
redirect-gateway=yes
create_via_conf=yes
reconnect=yes
conf_name=Connection
user=xxxxx
remote=82.199.134.162
client_o1558797560
Code:
auth-user-pass /tmp/ovpn_client_up
client
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
remote-random
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4


tun-mtu  1500

proto udp
fragment 1300
mssfix

comp-lzo


remote 82.199.134.162 148

remote 82.199.134.162 149

remote 82.199.134.162 150

remote 82.199.134.162 151

remote 82.199.134.162 1148

remote 82.199.134.162 1149

remote 82.199.134.162 1150

remote 82.199.134.162 1151

remote 80.255.7.66 148

remote 80.255.7.66 149

remote 80.255.7.66 150

remote 80.255.7.66 151

remote 80.255.7.66 1148

remote 80.255.7.66 1149

remote 80.255.7.66 1150

remote 80.255.7.66 1151



cipher AES-256-CBC
auth SHA512

ignore-unknown-option ncp-disable
ncp-disable

ns-cert-type server

key-direction 1






up /usr/syno/etc.defaults/synovpnclient/scripts/ovpn-up
route-up /usr/syno/etc.defaults/synovpnclient/scripts/route-up
plugin /lib/openvpn/openvpn-down-root.so /usr/syno/etc.defaults/synovpnclient/scripts/ip-down
ca ca_o1558797560.crt
key client_key_o1558797560.key
cert client_crt_o1558797560.crt
tls-auth ta_o1558797560.key 1

vpnc_last_connect
Code:
[curr_info]
route=82.199.134.162 via 192.168.1.1 dev br0  src 192.168.1.141

server_ip_num=1
server_ip0=82.199.134.162
ds_mask=255.255.255.0
conf_id=o1558797560
mask=255.255.255.0
start_time=67032
ip=10.4.133.33
ds_if=br0
proto=openvpn
server=82.199.134.162
reconnect=yes
reconnect_times=0
conf_name=Connection
ds_ip=192.168.1.141
ds_dns=8.8.8.8 via 192.168.1.1 dev br0  src 192.168.1.141

if=tun0
def_gw=192.168.1.1
 

Gerd

Junior Member
Füge mal der Client_xxxxxxxxxxxx Datei nachträglich

Code:
log-append /tmp/openvpn.log
oder

Code:
log /tmp/openvpn.log
hinzu.

Das Verzeichnis muss /tmp/ sein. Passe es gegebenenfalls an, wenn das tmp Verzeichnis woanders ist.

Starte danach dein Router neu.

Wenn "log-append" oder "log" in der Client Datei nach dem Neustart erhalten bleibt, dann kannst du die Datei auslesen.

Edit: Wenn du es in die .ovpn Datei einfügst und importierst, dann bleibt es natürlich erhalten.
 

Yonex

New Member
Für welche Client soll ich es ändern? Die von dir erstellte .ovpn Datei oder die von MacOS?

Meine "openvpn.log" Datei befindet sich tatsächlich im /tmp/
 
Last edited:
Top