Answered: Open VPN GUI 2.3.2 cannot connect to PP servers, why?

Pease

Member
Hi! This is my latest thread from the old forum:

I wrote: "Hi folks!
I installed the latest version of Open VPN GUI. It is 2.3.2. I could see that .csr files are missing in config . Is this how it should be? In version 2.2.2 there were lots of .csr files in config. Am I doing something wrong? I have windows 7.
I have 32 bit and installed openvpn-install-2.3.2-I001-i686.exe and ppConfig_win.zip 139.79 KB for the config files, but i couldn´t see the .csr files???

.csr = Security Certificate files

Thanks for helping me out in advance. "

PP wrote. "Hi,

you seem to be using the latest config files, and the right version of OpenVPN which is a good thing
smile.gif
We tried to have the configuration files packages as small as possible, and included only the neccessary files. Citing from the OpenVPN documentation:
".csr files -> certificate signing request (not directly used by OpenVPN)"

So although it looks a little different, everything OpenVPN needs is in the package.

Kind regards,

Daniel "

I wrote: "But it doesn´t work with the latest version. Now I use version 2.2.2 of Open VPN GUI and the old configfiles, luckily I made an backup of them before trying the latest version 2.3.2. I got a message that GUI cannot connect to your servers. So thats why I started this thread. So what can be wrong??? "

PP Wrote: "Hi,

oops I thought you just had a question, I did not realize you could not establish a connection. I just tried to reproduce the error you described, but failed to do so.. works flawlessly. I am using the 64 bit version (since my host is a 64 bit one) and the latest configuration files.

To further look into this matter, can you please post your OpenVPN logfile (the one that appears on establishing a connection)? You may want to replace your own IP address with XXX.XX.XX.XXX for privacy reasons, and/or send it as a private message.

The old configuration files will not allow a connection to the updated servers! The reason is simply that the servers configuration has also changed, to allow for more services. With the old configuration files you are likely limited to using the Steinsel1-6 servers, which still run the old configuration.

Regardless of the OpenVPN version used, the updated servers require using the new configuration files. "

I wrote: "I dont know if this will help you? But the log look like this when it works with connection to your servers with the old config files and Open VPN GUI v 2.2.2.: I deleted the log because it was the wrong one I wrote this her in this new forum today130829"

PP wrote: "Hi,

sadly not really. Since that log is one of a working connection, there is no information about any errors included in it. But the good thing is, at least now we know the old steinsel configurations work for you. This also indicates your OpenVPN installation is working.

My suggestion: Delete the old configurations for all other servers except Steinsel. You won't lose anything, since they don't work anyway. Copy the new configuration files in your OpenVPNs config folder. Since Steinsel is not in the new package it won't get overwritten. Then try one of the new configurations and we should have a log with an error in it. Post that log here, and I will be able to narrow it down. "

I wrote: "It is now working to log in to PP servers now when i use Open VPN GUI. It is 2.2.2. and the latest configuration files: ppConfig_win.zip 139.79 KB.

Why does it not work with Open VPN GUI v 2.3.2 ??????"
You can read about this in the old forum also. See https://forum.perfect-privacy.com/showthread.php?p=27776#post27776

Can it be my Firewall wich stops the latest GUI?

Thanks for all help in advance.
 
Solution
Hi,

first off, IPv6 has absolutely nothing to do with the issue at hand. We do not even use it on our servers yet.

This looks like ZoneAlarm is preventing connections over OpenVPN. It might work with the old OpenVPN because of the settings neccessary in ZoneAlarm have been made, and not work with the most recent version of OpenVPN because these settings/permissions are missing.
In ZoneAlarm is a table with the different programs and their permissions, it should be located under "Program settings" or sth. similar. Make sure the "openvpn.exe" and the "openvpn-gui.exe" of the new OpenVPN version have the neccessary permissions. Next, under "Firewall" you have "Zones", in there you should find a list of your (virtual and physical)...​

PP Daniel

Staff member
Good question.. I know it's not the config files, they work with the latest version.
Could it be your Firewalll? Which one are you using, by the way?
As I said, post some logfiles of the non working setup, and we might be able to narrow it down. Anything else is pretty much an insolvable puzzle. Perhaps there is something stange going on on your system, who knows..
 

Pease

Member
Hi! I use ZoneAlarm. I know that it’s the firewall which cause the problem because when I close ZoneAlarm everything is working with the latest GUI and the latest config files. When I use ZoneAlarm its only works with GUI version 2.2.2. and the latest config files.

I get this error from the log when ZoneAlarm is on and I cannot connect to PP servers (I write the last three rows):

“Thu Aug 29 22:34:28 2013 us=820312 OpenVPN 2.3.2 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Aug 22 2013
Thu Aug 29 22:34:28 2013 us=820312 ERROR: could not not read Management password from stdin
Thu Aug 29 22:34:28 2013 us=820312 Exiting due to fatal error”

I hope its enough with the last three rows to help me?

I wonder if i must have IPv6 on on my computer? Because i only have IPv4 on.

Thanks for all help in advance as usual.
 

PP Daniel

Staff member
Hi,

first off, IPv6 has absolutely nothing to do with the issue at hand. We do not even use it on our servers yet.

This looks like ZoneAlarm is preventing connections over OpenVPN. It might work with the old OpenVPN because of the settings neccessary in ZoneAlarm have been made, and not work with the most recent version of OpenVPN because these settings/permissions are missing.
In ZoneAlarm is a table with the different programs and their permissions, it should be located under "Program settings" or sth. similar. Make sure the "openvpn.exe" and the "openvpn-gui.exe" of the new OpenVPN version have the neccessary permissions. Next, under "Firewall" you have "Zones", in there you should find a list of your (virtual and physical) network adapters. One or more might be named like "TAP-Win32 Adapter V9 - Paketplaner-Miniport" or sth. like this. Make sure this is considered a safe zone by ZoneAlarm. There might be an older version also, most likely from the older version of OpenVPN.

I hope this helps you using the new OpenVPN version.
 
Solution
Top