Mehrere VPN Standorte in einer .ovpn Datei

CFVPN

New Member
Hi,

ich habe folgende Frage an euch:

Ich bin bei einem meiner Endgeräte auf eine .ovpn datei angewiesen. Allerdings würde ich gerne mehrere verschiedene VPN Standorte (zb. Frankfurt,Strasbourg,London) nutzen. Ich kann allerdings nur 1 .ovpn datei in diesem Endgerät nutzen.
Gibt es eine möglichkeit mehrere Standorte in diese eine ovpn Datei einzutragen? Ich bräuchte ja dann verschiedene "Keys" und " Zertifikate" von den Standorten zusammen in dieser 1 ovpn Datei.
Lässt sich das irgendwie realisieren? Und wenn ja: Auf was genau muss ich achten bzw. muss ich bestimmte zeilen einfügen damit dies funktioniert?
 

Gerd

Active Member
Ich kann allerdings nur 1 .ovpn datei in diesem Endgerät nutzen.

Was für ein Endgerät ist das, wenn ich fragen darf?

Gibt es eine möglichkeit mehrere Standorte in diese eine ovpn Datei einzutragen?

Ausprobiert habe ich es nicht, aber bestimmt möglich. Die OpenVPN Software auf deinem Endgerät (was immer das auch ist), würde die Server nacheinander abklappern, bis eine Verbindung erfolgreich zustande kommt.

Die OpenVPN Verbindung wäre aber in den meisten Fällen schon beim ersten Server aufgebaut. So könntest du die anderen Server nicht nutzen. Diese Art von OpenVPN Verbindung entspricht nicht deiner Vorstellung, oder?
 

CFVPN

New Member
Endgerät ist ein vu+ sat receiver daher bin ich was open vpn betrifft sehr eingeschränkt.

Und doch genau so eine verbindung suche ich. Falls server 1 mal ausfällt gehts auf server 2 weiter usw.

Sollten halt nur eben verschiedene standorte sein und nicht zb frankfurt1+frankfurt2.
Das ich die mehreren remote adressen untereinander eintragen muss weiß ich, nur wie handhabe ich das in einer config datei mit mehreren keys und zertifikaten für die verschiedenen server? Einfach untereinander mit den keys und zertifikaten hatte ich mal kurz getestet aber dann kam keine verbindung mehr zustande
 

Gerd

Active Member
Einfach untereinander mit den keys und zertifikaten hatte ich mal kurz getestet aber dann kam keine verbindung mehr zustande

Also auf diese Art und Weise funktioniert es nicht?

Code:
auth-user-pass /etc/openvpn/password.txt
client
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4
tun-ipv6
tun-mtu  1500
proto udp
fragment 1300
mssfix
comp-lzo

remote 85.17.28.145 148

cipher AES-256-CBC
auth SHA512
key-direction 1

<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
</key>
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
-----END OpenVPN Static key V1-----
</tls-auth>

client
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4
tun-ipv6
tun-mtu  1500
proto udp
fragment 1300
mssfix
comp-lzo

remote 82.199.134.162 148

cipher AES-256-CBC
auth SHA512
key-direction 1

<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
</key>
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
-----END OpenVPN Static key V1-----
</tls-auth>

Ein PP Admin kann bestimmt mehr dazu sagen.

Hast du an eine Alternative gedacht? Z. B. VU+ hinter einem Asus Router mit Merlin Firmware? Wenn die Verbindung abbrechen würde, dann könntest du über kleine Umwege auf Asus Router einloggen und ein neuen Server starten.
 
Last edited:

CFVPN

New Member
Also mit dieser "schreibweise" bzw diese anordnung in der config habe ich noch nicht probiert. Werde ich aber gleich morgen mal tun sobald ich zeit habe.
Falls es damit trotzdem nicht geht, wäre es super wenn ein admin vll.mal dazu noch etwas sagen kann.

An die lösung mit dem router zwischen hängen habe ich auch schon dran gedacht, allerdings sind die geräte die wirklich etwas können auch doch nicht ganz billig und da meine vpn verbindung doch relativ stabil läuft wollte ich es erstmal auf diese art versuchen.
 

Gerd

Active Member
Ich weiß nicht ob hier die Option <connection> vom nutzen wäre. Wenn ja, dann könnte man es auch so beim VU+ einfügen:

Code:
auth-user-pass /etc/openvpn/password.txt
client
dev tun
hand-window 120
inactive 604800
mute-replay-warnings
nobind
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
tls-timeout 5
verb 4
tun-ipv6
tun-mtu  1500
proto udp
fragment 1300
mssfix
comp-lzo
cipher AES-256-CBC
auth SHA512
key-direction 1

<connection>
remote 85.17.28.145 148
<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
</key>
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
-----END OpenVPN Static key V1-----
</tls-auth>
</connection>

<connection>
remote 82.199.134.162 148
<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
</key>
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
-----END OpenVPN Static key V1-----
</tls-auth>
</connection>
 

CFVPN

New Member
also: ich habe beide varianten nun probiert aber leider auch ohne erfolg.
variante 1 mit dem untereinander schreiben habe ich zuerst probiert und openvpn auf meiner vu+ nimmt die config so auch an und startet ganz normal, allerdings zieht es sich keine ip vom server. laut log gibt es auch keinen fehler sondern er läuft bis dahin wenn er sich zum server verbinden möchte und dann geht es einfach nicht mehr weiter.

variante 2 mit dem <connection> funktioniert überhaupt nicht. sobald ich diesen befehl nutze in der config, akzeptiert die vu+ die config nicht mehr und startet auch das vpn protokol nicht mehr.

wie könnte ich es denn noch versuchen? bzw woran könnte es liegen das er keine ip zieht? so falsch kann die config ja nicht sein wenn er keinen fehler auswirft .... denke ich mal

vll könnte hier auch ein admin von pp mal etwas dazu sagen, falls er eine idee dazu hat?!

ich habe mal meine config angehängt, vll bringt das ja licht ins dunkel

die route 0.0.0.0 0.0.0.0. muss in der config stehen da sonst meine verbindung nicht zustande kommt, sprich diese zeile habe ich immer in meiner config und wenn ich die server einzeln anspreche läuft es damit auch
 

Attachments

  • openvpnvti.conf.txt
    28.1 KB · Views: 5

Gerd

Active Member
variante 1 mit dem untereinander schreiben habe ich zuerst probiert und openvpn auf meiner vu+ nimmt die config so auch an und startet ganz normal, allerdings zieht es sich keine ip vom server. laut log gibt es auch keinen fehler sondern er läuft bis dahin wenn er sich zum server verbinden möchte und dann geht es einfach nicht mehr weiter.

In deiner Config stehen am Ende 2 remote Server-IPs:

Code:
remote 94.242.243.162 1150
remote 94.242.243.66 1151

Sobald mehrere IPs hintereinander von Servern mit gleichen Zertifikaten aufgelistet werden, müsste (glaube ich) die Option remote-random hinzu.

variante 2 mit dem <connection> funktioniert überhaupt nicht. sobald ich diesen befehl nutze in der config, akzeptiert die vu+ die config nicht mehr und startet auch das vpn protokol nicht mehr.

Hast du das neuste OpenVPN Plugin drauf?
 
Last edited:
Top