Know-How: Enigma2(ATV&VTI) PP Plugin Guide&Download

PP Daniel

Staff member
ATTENTION: This is a community project from our user murxer. Therefore there is no OFFICIAL support from PP.
This is the translation of the original german post, please use the links below to find the files for download.

[1] Original german post in this forum, translation:
Murxer has completely revised the plugins: To make this easier for the future we link his thread of another forum, because he has no rights to edit this post here.
All guides and information regarding the current version can be found here: [2]

The downloads will be made available in this post too. So you don't have to download from elsewhere. Usually this will happen within 24 hours after Murxer made an update.

[2] Murxer's post in boxpirates.to forum, translation:
Hello community,

I have created a plugin for the OpenVPN provider Perfect Privacy, so you don't have to customize the configs or exchange them using FTP anymore.

To be able to use the plugin you need an account at Perfect Privacy.
This is a hobby project, I'm not a programmer so it is possible to experience issues sometimes.

Functionality which can be configured from the menu:
- OpenVPN Autostart

- Default DNS Server
Are saved automatically, but can also be adjusted and set in the menu.

- Perfect-Privacy DNS servers can be chosen freely (optional)
A resolv-update-conf is included in the plugin, the Perfect Privacy DNS servers are always used.

- Cascaded connection up to 2 hops
You don't have to choose the two hops from the menu any longer, you can just pick them in the server list.
Select hop 1 and press OK, then select hop 2 and press OK again to establish the connection.
In the menu you can activate the cascade check, this check starts automatically after a reboot or GUI restart.
If you have cascading activated the check verifies it, and if no cascaded connection exists it is reestablished.
You can also configure a delay so the check is not triggered too early.

- IPtables can be activated (sadly not on all boxes because some lack kernel-module-xt-multiport and kernel-module-xt-conntrack)
Iptables, kernel-module-xt-multiport and kernel-module-xt-conntrack don't get installed before you activate IPtablesin the menu.
If the packages can not be installed you get an error message stating which ones could not be installed.

- Config's TCP or UDP and AES-256-CBC or AES-128-CBC
Before the first start of the plugin please stop OpenVPN to ensure the correct default DNS servers get stored.
Every time you exit the menu you will get asked whether new configs should be loaded.
After installing or updating the plugin you first have to load the configs.

Hints regarding version OE2.0:
- With VTI the autostart of the cascade does not work, because when the box boots it's date is in the year 1970.
Therefore the reboot delays for aboout 20 seconds.
Then a normal OpenVPN connection is established using 1 hop only.

Hints regarding version OE2.5/OE2.6
- Tested images original Unstable, Merlin, Newnigma2 and Oozoon on DM9x0, 820 and 7080
- At plugin install a start script of the connman is adjusted, so that the DNS proxy is deactivated.

Install:
Depending on OE, FTP the respective packets to /tmp

OE2.0
enigma2-plugin-extensions-perfectprivacy_xxx_all.ipk
python-beautifulsoup_4-4.8.0_all.ipk

OE2.5 - >
ATTENTION ATTENTION

It is important to first uninstall the plugin and perform a reboot, a regular update can not be done until version 1.4.0.

enigma2-plugin-extensions-perfectprivacy_xxx.deb
python-beautifulsoup4_4-4.8.0.deb

DreamBox One
enigma2-plugin-extensions-perfectprivacy_xxx.deb
python-beautifulsoup4_4.8.0-r0.0_arm64.deb (Thanks to pclin for this)


Use telnet or ssh to enter to following:
OE2:
Code:
opkg update && opkg install /tmp/*.ipk

OE 2.0 python-beautifulsoup:
Code:
opkg update && opkg install python-beautifulsoup
oder python-beautifulsoup4:
Code:
opkg update && opkg install python-beautifulsoup4
OpenATV --> python-beautifulsoup
VTI --> python-beautifulsoup4

OE2.5 ->

Code:
apt-get update
dpkg -i /tmp/*.deb
apt-get -f install

OE2.5 -> python-beautifulsoup4
Code:
apt-get update && apt-get install python-beautifulsoup4

Attention VTI users, if you only get the error message in the menu
Code:
Login failed!
Please check login data
and the OpenVPN connection is established anyway, you have to install additional packages.
1- python-webencodings_0.5.1_all.ipk
2- python-html5lib_1.0.1_all.ipk
These packages are available below.

Deb Version and IPTables:
As some images don't offer the packages for IPtables anymore, you may use these packages from Newnigma2.

DM 7080 mipsel.deb:
[The files are available in the original posts linked above.]

DM900 armhf.deb:
[The files are available in the original posts linked above.]

DM920 armhf.deb:
[The files are available in the original posts linked above.]

Have fun! 👋


Files
[The files are available in the original posts linked above.]
 
Top