Tipps & Tricks: Enigma2(ATV&VTI) PP Plugin Anleitung&Download

murxer

Active Member
Update in Post 1
Version 1.3.6
- deb Installation Fix -> getestet mit der DreamBox One
- diverse kleinere Fixes
 

spacewalker

New Member
Hey!
Soweit klappt nun die Installation bei einer Dreambox 920 UHD mit Merlin 4 Image... Nur leider zerschießt die Installation nun dpkg!

Führe ich den Befehl
dpkg --configure -a
aus, läuft kurz was durch, aber die Fehlermeldung
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem

kommt auch nach jedem Neustart, wenn man ein Paket über Telnet installieren möchte und wenn man auf die Plugins im GUI zugreifen und verschwindet nicht mehr.

Hat jemand eine Idee, wie ich den Fehler korrigieren kann?

Gruß Spacewalker
 

murxer

Active Member
@spacewalker

Also mit
Code:
dpkg --configure -a
sollte das Problem wieder beheben.

Kann das sein das es wegen dem Reboot nach der Installation die dpkg nicht mehr korrekt funktioniert?
 

daf2003

New Member
@murxer

Erstmal danke für das Plugin!

Ich habe gerade von Version 1.3.0 auf 1.3.6 upgedatet.

Normal konnte ich immer durch editieren der Datei pp_iptables.sh die ports für iptables konfigurieren.

Bei der neuen Version fehlt jetzt diese Datei.

Irgendeine Idee?


LG
 

murxer

Active Member
@daf2003
Liegt in /etc/init.d/pp_iptables hier kannst du sie anpassen.
Musste hier einiges umstellen, da es bei der Installation und Deinstallation immer Probleme gab.
Erstelle heute noch eine Neue Version, dann sollte das mit dpkg wieder funktionieren.
 

spacewalker

New Member
@spacewalker

Also mit
Code:
dpkg --configure -a
sollte das Problem wieder beheben.

Kann das sein das es wegen dem Reboot nach der Installation die dpkg nicht mehr korrekt funktioniert?
Ich weiß leider nicht, ob der Reboot dafür verantwortlich war... Ich denke aber ja, da nun wieder alles passt!

Wenn man über dpkg das Paket neu konfigurieren lassen wollte, klappte dies auch. Nur musste ich den Befehl immer wieder neu ausführen, weil der Fehler immer wieder präsent war.

Der Fehler kam immer wenn man:
- "apt-get update" oder "up" über Telnet ausführte
- die Erweiterungen über den Addonmanager oder das Erweiterungsmenü installieren wollte
- ein Paket manuell über Telnet installieren wollte

Somit war leider keine (De)Installation der Addons möglich. Mir half da nur eine Neuinstallation des Images (Backup)

Update Version 1.3.7
- deb dpkg - Installation Foix
https://www.file-upload.net/downloa...ugin-extensions-perfectprivacy_1.3.7.deb.html

Sorry Leute, habe nicht gedacht das der reboot so viele Probleme verursacht
Alles gut, jetzt klappt es wieder einwandfrei. Tausend Dank für den schnellen Fix! Sowas hätte ich nicht erwartet, um ehrlich zu sein. Es ist Sonntag vormittag... ;-)

Gruß Spacewalker
 
Hallo ich hoffe ihr könnt mir helfen ich würde es auch gerne installieren das plugin und zwar unter VTI letzte version auf eine vu uno4k nur leider habe ich da ein paar probleme. Und zwar bekomme ich die Version 1.1.3 per telnet über controllcenter installiert es starte auch aber http error ich kann keine configs abrufen. die neuste version bekomm ich auch nicht zum laufen wohl liegt der fehler habe opkg update usw alles gemacht ?
 

Hilfiger

New Member
Hallo und fröhliche Weihnachten noch :)
Ist hier jemand der mit aktivierten IP Tables seine Synology Diskstation via NFS Freigabe zum Laufen bekommen hat ? Oder auch ein anders NAS System ?
Ich bekomme es nicht hin ! Sobald ich ip tables aktiviere, ist der Mount für NFS geblockt !
Evtl hat jemand einen Lösungsvorschlag ?
 

Hilfiger

New Member
Schon gut, vielen dank trotzdem. Ich habe es jetzt anders gelöst.

Die IP' Tables bleiben aus, und die Ports über die er nicht verbinden soll habe ich in der FritzBox blockiert, somit geht die Verbindung nur wenn der Tunnel aktiv ist, sobald er mal zusammenbrechen sollte, wird die Verbindung zu den Servern wo es nur getunnelt hin soll gekappt.
 
Juhuuu murxer

Du, bei der neuen 1.4er Version von der Verlinkung ins BoxPirates...müssten wir bei den neueren Boxen etwas beachten? Ich glaub ich bin nicht der einzige der ne 900er mit nem NewNigma Image und da frag ich lieber gleich mal nach bevor ich wieder Unsinn anstelle. 🙃
Da steht was von IP Tables und so....gilt das nu grundsätzlich oder is das eher was spezielles nur bei einigen Anbietern von den Images?

p.s.
Du müsstest vielleicht noch die ganzen Verlinkungen zum download hier mit rein holen, denn hier ham bestimmt einige keinen Zugang zum Boxpirates Forum gemacht. Wär das noch machbar bei Gelegenheit?
 

murxer

Active Member
@evolver_xxl
Servus, du ich habe jetzt wieder eine Dream Box, das ist die One, jetzt kann ich wieder alles selber testen.
Darum kann ich dir versichern das alles in Ordnung ist.
Die 1.4 läuft auch auf allen Images, es geht nur um python-beautifulsoup4, das fehlt bei manchen.
Ich konnte das nicht automatisch mit installieren lassen, weil viele Image Hersteller das nicht anbieten.
Bei IPTables ist es so, das man dies nicht bei allen Image Hersteller nutzen kann, weil diese bei manchen nicht mehr angeboten werden.

Installiere dir erst die 1.4 dann mach einen Gui-Neustart, wenn dann beim Aufruf des Plugins ein Import Fehler kommt, dann muss du noch die
python-beautifulsoup4_4-4.8.0.deb installieren.

Wegen Verlinkungen, hier werde ich mich bei PP-Frank melden, so das dieser den ersten Post anpasst.
Weil im Thread geht es jedes mal verloren.
Anhängen kann ich auch nichts, hier wird keine zip, ipk, deb oder rar geduldet.
 
Top