Debian 9 SSH2 mit Perfect Privacy SSH Client

Discussion in 'Dienste - Fragen & Antworten (Q&A)' started by ink0gnito, Mar 13, 2018.

  1. i

    ink0gnito New Member

    Hallo zusammen ich nutze Debian stretch und bekomme den Perfect Privacy SSH Client nicht zum laufen.
    Die erforderlichen Abhängigkeiten habe ich installiert.
    Hier mal die Fehlermeldung:
    Code:
    perfect-privacy-ssh (1.2.6) wird eingerichtet ...
    /etc/cron.daily/perfect-privacy-ssh: Zeile 85: /etc/aptsources.list.d/perfect-privacy-ssh.list: Datei oder Verzeichnis nicht gefunden
    dpkg: Fehler beim Bearbeiten des Paketes perfect-privacy-ssh (--configure):
     Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     perfect-privacy-ssh
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  2. PP Stephan

    PP Stephan Staff Member

    Also das sollte nicht passieren, ich habe as auch gerade getestet und die Installation funktioniert. Hast Du da mal manuell die sources editiert? Es fehlt ein / in /etc/aptsources.list.d/perfect-privacy-ssh.list es muss heißen: /etc/apt/sources.list.d/perfect-privacy-ssh.list.

    Was gibt

    apt-config dump |grep Dir::Etc

    aus?
     
  3. i

    ink0gnito New Member

    Ne ich habe nichts manuell editiert das stretch ist sogar sehr frisch aufgesetzt.
    Code:
    Dir::Etc "etc/apt";
    Dir::Etc::sourcelist "sources.list";
    Dir::Etc::sourceparts "sources.list.d";
    Dir::Etc::main "apt.conf";
    Dir::Etc::netrc "auth.conf";
    Dir::Etc::parts "apt.conf.d";
    Dir::Etc::preferences "preferences";
    Dir::Etc::preferencesparts "preferences.d";
    Dir::Etc::trusted "trusted.gpg";
    Dir::Etc::trustedparts "trusted.gpg.d";
    
    die vpn.deb von PP konnte ich auch einwandfrei installieren.
     
  4. PP Stephan

    PP Stephan Staff Member

    Ich habe gerade mit unserem Linux-Entwickler gesprochen, das ist offenbar ein Problem nur auf einigen Systemen/Distributionen. Können wir aber beheben, sollte morgen funktionieren (stellen update bereit).