Windows WSL2 IP Leak + Fix

PP Lars

Staff member
Falls ihr euch manchmal fragt wieso ihr eigentlich bei uns Kunden seid, und nicht bei den anderen :)

Gestern hat Mullvad ein Ip Leak reported das das Windows 10 Linux subsystem betrifft [1].
Kurzgesagt geht alles in dem Linux Subsystem an der Firewall vorbei.
Das betrifft alle VPN Provider, Mullvad hat wohl noch keine Fix. (Tipp: nullrouting statt firewalling, for now )
Beta Version unseres Windows Clients mit Workaround ist hier online:
Wenn da keine Beschwerden kommen machen wir das update im Laufe des Tages für alle User verfügbar.

Grüße
Lars

[1] https://mullvad.net/en/blog/2020/9/30/linux-under-wsl2-can-be-leaking/



Falls das bei jemandem nicht funktioniert:
Ihr könntet mir die Ausgabe von "route print -4" vor und nach dem verbinden zukommen lassen,
und schreibt mir bitte dazu welche Windows Version
 
Last edited:

Lucy2018

New Member
Top von Euch. Ich würde mich freuen, wenn Ihr häufiger so etwas schreiben würdet, vor allem für User, die technisch nicht so bewandert sind.

Habe die Beta Version getestet. Keine Probleme bisher.
 

PP Lars

Staff member
Hey, ich hoffe doch das wir NICHT häufiger von fiesen leaks schreiben müssen :D
Bis jetzt hält unser Firewall und Netzwerk Setup immer, und jetzt mit dem nullrouting da drin hat das nochmal einen 2. Sicherheitslayer, selbst wenn die eigentliche firewall nicht greift, also im Idealfall müssen wir nie über leaks berichten :)

Grüße
Lars
 

Bu6GuH

Freshly Joined Member
Habe mir die Version installiert, habe mit der Version ein Problem mit Ipv4. Zum Hintergrund:

Habe IPSEC aktiviert und damit funktioniert kein IPv4. Mir wird zwar im VPN Manager eine angezeigt, aber wenn ich meine öffentliche IP Checke sagen mir die Seiten das ich nur eine IPv6 Adresse zugeweisen bekommen habe und keine IPv4 was auch stimmt kann keine Ipv4 Adressen anpingen etc.

Mit der aktuellen nicht Beta Version 1.10.32.0 funktioniert es Problemlos.
 

Bu6GuH

Freshly Joined Member
Daten zum System:

Windows 10 Pro 64bit - 2004 (neuste Updates)
VPN Manager die Beta - 1.10.34.0
IPSEC
Bei der Firewall alles auf aktiv gesetzt und DNS außer Zugriff auf Localen Router blockieren.
Problem: IPv4 geht nicht

Mit dem VPN Manager 1.10.32.0 und den gleichen Einstellungen geht alles so wie es soll und auch Ipv4.
 

Hanna

New Member
Also so wie ich das jetzt verstanden habe, ist Perfect-Privacy allerdings nicht von diesem Leak betroffen gewesen, wegen dem Firewall-Setup? Sollte man im 1. Beitrag eventuell etwas deutlicher vermerken, der schnelle Leser könnte das überlesen.

Ansonsten: Seriös von Mullvad, dass die diesen Fehler so transparent offengelegt haben.
 

Florian2833z

Junior Member
Wenn dir noch langweilig ist, könntest du ja im VPN Manager mal das "obfs3proxy" in ein "obfs4proxy" umbennen. Das setzt ihr ja schon länger ein.
@PP Lars

Ansonsten gibts noch den Bug, dass IPv6 nicht mehr funktioniert, wenn man den IPv6-Leakschutz anhatte und dann die Verbindung trennt. Dann geht IPv6 nur noch nach Zurücksetzen der Firewall und Neustarten des LAN-Adapters.
 

PP Lars

Staff member
Ansonsten gibts noch den Bug, dass IPv6 nicht mehr funktioniert, wenn man den IPv6-Leakschutz anhatte und dann die Verbindung trennt. Dann geht IPv6 nur noch nach Zurücksetzen der Firewall und Neustarten des LAN-Adapters.
Hm.. hast du da mehr Details zu? Welches IPv6 genau funktioniert nicht mehr? Ipv6 über VPN wenn du danach eine neue VPN Verbindung machst, oder dein normales LAN/Internet Ipv6? Ich nehme an den Computer Neustarten hilft auch? Oder musst du tatsächlich ein Firewall reset machen? Verbindung über Ipsec oder OpenVPN? Wenn du den IPv6-Leakschutz nicht aktivierst funktioniert Ipv6 dauerhaft?

Grüße
Lars
 

Florian2833z

Junior Member
Hm.. hast du da mehr Details zu? Welches IPv6 genau funktioniert nicht mehr? Ipv6 über VPN wenn du danach eine neue VPN Verbindung machst, oder dein normales LAN/Internet Ipv6? Ich nehme an den Computer Neustarten hilft auch? Oder musst du tatsächlich ein Firewall reset machen? Verbindung über Ipsec oder OpenVPN? Wenn du den IPv6-Leakschutz nicht aktivierst funktioniert Ipv6 dauerhaft?

Grüße
Lars
Das IPv6 von meinem Internetanschluss. Hier sind jetzt zwar paar IPs drinnen, aber egal. Bevor ich mich verbinde, sieht das ganze so aus:


IPAddress : fe80::5dea:657f:3b9f:eb1b%10
InterfaceIndex : 10
InterfaceAlias : LAN-Verbindung
AddressFamily : IPv6
Type : Unicast
PrefixLength : 64
PrefixOrigin : WellKnown
SuffixOrigin : Link
AddressState : Preferred
ValidLifetime : Infinite ([TimeSpan]::MaxValue)
PreferredLifetime : Infinite ([TimeSpan]::MaxValue)
SkipAsSource : False
PolicyStore : ActiveStore

IPAddress : 2a01:c22:7655:6000:c92e:8acd:22f8:568b
InterfaceIndex : 10
InterfaceAlias : LAN-Verbindung
AddressFamily : IPv6
Type : Unicast
PrefixLength : 128
PrefixOrigin : RouterAdvertisement
SuffixOrigin : Random
AddressState : Preferred
ValidLifetime : 01:58:49
PreferredLifetime : 00:58:49
SkipAsSource : False
PolicyStore : ActiveStore

IPAddress : 2a01:c22:7655:6000:5dea:657f:3b9f:eb1b
InterfaceIndex : 10
InterfaceAlias : LAN-Verbindung
AddressFamily : IPv6
Type : Unicast
PrefixLength : 64
PrefixOrigin : RouterAdvertisement
SuffixOrigin : Link
AddressState : Preferred
ValidLifetime : 01:58:49
PreferredLifetime : 00:58:49
SkipAsSource : False
PolicyStore : ActiveStore

IPAddress : 192.168.178.23
InterfaceIndex : 10
InterfaceAlias : LAN-Verbindung
AddressFamily : IPv4
Type : Unicast
PrefixLength : 21
PrefixOrigin : Dhcp
SuffixOrigin : Dhcp
AddressState : Preferred
ValidLifetime : 119.16:28:10
PreferredLifetime : 119.16:28:10
SkipAsSource : False
PolicyStore : ActiveStore


IPv6 funktioniert. Jetzt verbinde ich mich per IPSec mit einem beliebigen Server.
VPNManager_2020-10-05_00-25-05.png
Das sind die Firewalleinstellungen. Wenn ich jetzt den VPN trenne, dann ist IPv6 nicht mehr funktionsfähig.


IPAddress : fe80::5dea:657f:3b9f:eb1b%10
InterfaceIndex : 10
InterfaceAlias : LAN-Verbindung
AddressFamily : IPv6
Type : Unicast
PrefixLength : 64
PrefixOrigin : WellKnown
SuffixOrigin : Link
AddressState : Preferred
ValidLifetime : Infinite ([TimeSpan]::MaxValue)
PreferredLifetime : Infinite ([TimeSpan]::MaxValue)
SkipAsSource : False
PolicyStore : ActiveStore

IPAddress : 192.168.178.23
InterfaceIndex : 10
InterfaceAlias : LAN-Verbindung
AddressFamily : IPv4
Type : Unicast
PrefixLength : 21
PrefixOrigin : Dhcp
SuffixOrigin : Dhcp
AddressState : Preferred
ValidLifetime : 119.16:27:25
PreferredLifetime : 119.16:27:25
SkipAsSource : False
PolicyStore : ActiveStore


Wenn ich jetzt IPv6 am Netzwerkadapter deaktiviere und wieder aktiviere, funktioniert IPv6 für eine gewisse Zeit, danach geht es leider wieder nicht mehr. Dann sind die IPv6-Adressen alle im Netzwerkadapter eingetragen, eine Verbindung nach draußen geht aber nicht. Ping liefert "Allgemeiner Fehler". Wenn ich den IPv6-Leakschutz aus lasse, dann funktioniert IPv6 ohne VPN immer einwandfrei (mit VPN natürlich auch über den VPN-Server).
 
Last edited:
Top