Answered: Windows 10 Creators Update


Hi Frank,

I'm wondering if you guys are experiencing any issues running the VPN manager on a clean installation of the new Windows 10 Creators Update. A lot of error messaging are popping up and the applications exits when configuring DNS leak protection, Firewall features?


  • Capture1.PNG
    15.9 KB · Views: 28
  • Capture2.PNG
    27.6 KB · Views: 26
  • Capture3.PNG
    7.1 KB · Views: 22
  • Capture4.PNG
    47.8 KB · Views: 24
Last edited:
Hi Stephan, I got it working now by doing the following.
1. Removed all languages and re-added English (United States) - Picture 1
2. In advanced settings, I made sure that English (united States) is set as display language, and did apply the settings to the welcome screen, system accounts and new user accounts - Picture 2
3. Installed the VPN Manager and connected to OSLO server and it rocks :) - Picture3

Thank you so much for pointing me to right direction regarding language settings. I appreciate it alot :)


New Member
I installed Win10 with English (UK) as the operating system's language and used a different language for the keyboard layout. Sorry, I don't know about any codepage. I tried different things and only got it to work once I deinstalled all languages other than English (United States), installed the VPN Manager and then installed the language pack for my Keyboard again.


New Member
This has been bugging me too since Creators Fall Update 1709 and I have three languages installed on my PC. The problem has been that VPN Manager says I am connected and is waiting for confirmation which never comes. It tries repeatedly to reconnect and a window appears telling me it is setting up network adapters. On a whim I changed the settings from OpenVPN to IPSEC and it connected instantly. Changing back to OpenVPN the problem returns. Back to IPSEC and bingo, game on. Hopefully this will help your techs.


New Member
Mikael, I had a similar problem since 1709. For me the solution was to reset the (Windows-)Firewall. After that I could connect via OpenVPN again.
THANK YOU, Viper. That did it! Is there no end to the variations of "Have you tried turning it off and turning it on again"? So simple when you know.


New Member
Here are my logs. I cannot connect if the firewall option is enabled. The same happens for DNS leak protection as well. This is a pretty large log file (attached)... If I disable the firewall and dns leak protection, then I can connect. This is right after installing Windows Creator Update. Please check out these logs..

If I leave the firewall enabled, the connection drops after some time and can't re-connect. If I try to connect with the firewall enabled, it sits there trying to connect endlessly. It also seems to try to re-install the TAP adapter and still can't connect. Windows seemingly broke your VPN client... please help. I love this VPN and don't want to switch. :/ [LOG FILE ATTACHED]


  • PerfectPrivacy Log.txt
    226.1 KB · Views: 4