thread kann gelöscht werden.

Xulux

New Member
Das ist ein Fehler in der Anleitung.

ASUS Router können über OpenVPN kein IPv6.

Das heißt der Traffic über IPv4 geht über den Tunnel, von IPv6 kriegt der OpenVPN auf dem Router aber nichts mit...der geht regulär ins Netz.

Deine Anleitung funktioniert nur, wenn
  1. Ihr den ASUS hinter eure Fritzbox (oder vergleichbar) geklemmt habt und das (ggf.) an der Fritzbox anliegende IPv6 vom Anbieter nicht konform weiter delegiert habt. Dann kommt aber auch auf "native" gar kein funktionales IPv6 am ASUS an.
  2. Ihr mit dem ASUS direkt (bspw. per Modem) am Anschluss hängt, aber der Anbieter kein IPv6 liefert....kommt auch kein IPv6 an.
In allen anderen IPv6-aktiven Konstellationen gibt das Probleme.

Um das mit Stand heute sicher und konform zu betreiben, muss auf den ASUS-Routern IPv6 deaktiviert werden und bei der OpenVPN Custom Config folgendes hinzugefügt werden (wenn der VPN-Anbieter wie bspw. PP IPv6-VPN anbietet):

pull-filter ignore "ifconfig-ipv6 "
pull-filter ignore "route-ipv6 "
(ggf. ohne die "")

PS: Das liegt schlicht daran, dass viele VPN-Anbieter die drölfzigtausend Router nicht konkret testen (können/wollen) und erst Recht nicht im Rahmen der weiteren Entwicklung (bspw. neue Firmware) nachtesten. Da werden Anleitungen von Stand "irgendwann" für gängige Router eingestellt und das wars. Auch ist es nicht leistbar, jeden Router in allen erdenklichen Konstellationen zu testen und für jeden Fall eine eigene Anleitung bereitzustellen.
 
Last edited:
Zu 386.3 Version. Wie kann man folgendes realisieren

1. Gerät A verbindet sich zu VPN 1
2. Gerät B verbindet sich zu VPN 2
3. Alle anderen Geräte sollen sich mit VPN 3 Verbinden.

wenn ich bei VPN 3 Redirect Internet traffic through tunnel auf Yes (All) Stelle dann geht auch Gerät A und B über VPN 3.


Wenn ich Redirect Internet traffic through tunnel auf VPN Director Rules Stelle müssen die IP Adressen gepflegt sein um Zugang zum Internet zu erhalten.

Grundsätzlich könnte ich damit leben, aber was ist mit dem Gäste WLAN dann. Diese Geräte können ja dann nicht ins Internet soll deren IP nicht gepflegt sind.

Mit der letzten Version konnte man das so einstellen.
 

passle

Freshly Joined Member
Hallo,
habe alles wie im vorherigem Post eingestellt und die gleiche Firmware verwendet.
Leider verbindet er sich nicht und bleibt bei "Connecting" hängen,
Habe es auch mit verschiedenen Servern probiert. woran kann das liegen?
vielen dank im voraus !

hier noch meine Einstellungen dazu :
asus.JPG
 

Rider

New Member
Könnte auch am WAN DNS liegen, die Server von Cloudflare/Google funktionieren einwandfrei.
Getestet mit Frankfurt und Merlin 386.4 (Stable Main Release), die Server gehen komischerweise nicht.

IPV6 auf Nativ und den Rest wie oben eingestellt (Post #8).

VPN Config vom AsusWRT -> dann rechts auf "Alernativer OpenVPN download" in blau.
Dann so einstellen wie oben beschrieben.

Edit:
ich mach mal ne neue Anleitung zur Merlin 386.4 demnächst,
villeicht mit SSH und Skynet Plugin:
wolte mal fragen machst du nohc ne anleitung ?
 
Top