Solved: slow connections

fcond6800

Junior Member
hey guys. i don't know why - but my connections are very slow. the average speed is 900kb/s. i'm asking because that's a little bit expensive. shoud i use the udp protocols or what?
 

PP Daniel

Staff member
Hi,

which kind of connection are we talking about and which service(s) are you using? Which server(s) have you tried?
If you are using OpenVPN with the TCP protocol, that is most likely not what you want. In general OpenVPN works best with UDP. TCP is more of a fallback solution in case UDP does not work (often times the case with mobile data plans).
 

zokker13

Junior Member
I also have such speeds.
I tried Amsterdam 2 now, 1 500 KB/s (Has 850/1000)
Bucharest runs with 900 KB/s (Has 953/1000).

Couldn't get more than 3 000 KB/s from any server in like 3 months now.


I'm using the Perfect Privacy OpenVPN Manager.
Maybe I set up something completely wrong.
But I'm not satisfied with the speed! :(
 

PP Daniel

Staff member
Hi zokker13,

I take it you are using OpenVPN with the Perfect Privacy VPN Manager, but of course it would be helpful if you could provide some more information regarding your setup. Like internet access speed, the protocol used (udp or tcp?) and other settings/software that might possibly affect the speed of the VPN tunnel. A screenshot of the VPN Manager settings etc. would be helpful also. You may of course send this using a private message if you prefer so. I'll have a look at it and then hopefully be able to figure out the reason and find a solution.
 

zokker13

Junior Member
Hi,

sorry for not posting required information.
Wasn't quiet sure what you need. :)


My internet access speed:
50 000 kbps download
10 000 kbps upload


I'm not sure which protocol I'm using. Where is that information?


Some screenshots:








I'm afraid I can not set the language to English. Hope you can still read it!


Thanks for your help!
 

PP Daniel

Staff member
Hi zokker13,

thank you for the screenshots. Sometimes it's hard to tell what exactly seems to be the reason for an issue without some informations being provided, but there's no need to excuse. With your Internet connection speed you should be able to have a VPN tunnel running faster than yours does.

You wrote "I'm not sure which protocol I'm using. Where is that information?". I can see from your first screenshot that you are using the tcp protocol indeed, which most likely is the reason for a slower connection. You have a checkmark next to "TCP Konfigurationsdateien herunterladen", remove that and use the button below to update your configuration. This will make your OpenVPN tunnels use the udp protocol, which is the standard setting.

Using tcp does add a lot of overhead, as every packet that gets routed via VPN will then indirectly have transfer control, which is not desireable für udp data. A tunnel is capable of routing tcp and udp packets, regardless of the tunnel being run with udp or tcp protocol, but when using tcp for your tunnel you will end up with tcp beeing used even for udp packets running through it, and an additional layer of tcp for your tcp packets. As I explained in my post above, this is not desireable unless the udp tunnel does not work and there is no other option. Using a VPN server with a tcp tunnel which is located far away does decrease the tunnel speed even more, as packet travel time increases and client and server are witing for acknowledgements for the tcp packets beeing sent.

One more important thing: Of course it always helps using a VPN server which is geographically located close to you. Having data to travel around the world there and back doesn't help speeding things up.
 

zokker13

Junior Member
Hi Daniel,

thanks for your explanation and tips!

I disabled the TCP protocol and connected to "Amsterdam 2".
It didn't really improve. :/

Amsterdam 2:
739/1000
Download: 19 000 kb/s
Upload: 8 500 kb/s

I tried Erfurt like 30 minutes ago, If I remember correctly, it had like 950/1000 with a downloadspeed of 700 KB/s - 1 000 KB/s
 

PP Daniel

Staff member
Hi zokker13,

that really doesn't look like an improvement, I agree. Sometimes things just are a little more difficult I guess.

Another option would be to use IPsec instead of OpenVPN. Our current beta VPN Manager comes with this option, if you want to try it you can download it here: https://www.perfect-privacy.com/german/member/download/?file=Perfect-Privacy-VPN_BETA_Setup.exe
Before installing it, you need to uninstall the currently installed (non beta) version of our VPN Manger. The beta comes with the option to choose between IPsec and OpenVPN as connection method. We have had other members with speed issues using OpenVPN which did not have any such trouble after switching to IPsec as VPN. Maybe you want to try using IPsec too?
 

zokker13

Junior Member
Hi Daniel,

I installed the beta Client as described.
Here are my results:

IPsec/OpenVPN to Amsterdam2 [755/1000]
OpenVPN (udp):
Around 5 000 KB/s

IPsec (Not to "Amsterdam2" as the servers can not be splitted - connection to "Amsterdam" instead! [1529/2000]):
Around 5 000 KB/s

"Pure" connection:
Around 5 000 KB/s


So it's either the new Client which works better or something weird happened!
For now, I thank you very much!

Great support. :)
 

PP Daniel

Staff member
Hi zokker13,

I'm happy to read we found a solution that is working! Keep in mind though that you are now using a beta version (as a lot of others do too without having any trouble). So once the new stable version of the VPN Manger is released you might consider testing it and maybe upgrade to it.
 
Top