RT-AC66U

didi12

New Member
Hallo an @lle,


nach Tagelangen tüfteln muss ich um eure Mithilfe bitten.



Ich versuche die Merlin Software auf dem RT-AC66U zu konfigurieren. (nach dem ich die TomatoUSB von Shibby schon zum Laufen gebracht habe nach Unterstützung vom PP, ist die Merlin Software relativ ähnlich) mit einem kleinem aber.

Die Config vermute ich, ist bei allen ASUS Routern fast gleich.

Diese links habe ich schon ausprobiert. https://board.perfect-privacy.com/threads/open-vpn-mit-asus-rt-ac56u.752/

Das auch https://board.perfect-privacy.com/threads/openvpn-client-with-perfect-privacy-on-asus-rt-ac66u.302/

Leider immer noch kein Erfolg. Der ASUS ist an der Fritz-Box und hat Internet Verbindung.
Was habe ich schon alles ausprobiert.
1. Asuswrt-Merlin RT-ACU_380.57_0.zip ASUS geflasht


2. VPN Konfig für mobile_singl_udp beim OVPN eingespielt (Connect…. keine Verbindung)
3. VPN: linux_udp die Static Key-> (Amsterdam_ta.key) -Certificate Authority-> (ca.crt)
-Client Certificate-> (Amsterdam_cl.crt) -Client Key-> (Amsterdam_cl.key)

Einzeln eingespielt. (Connect…. keine Verbindung)

4. OVPN angepast. In der Datei nur 1 remote Link eingestellt (Connect…. keine Verbindung)

# Fallbacks just in case.. remote erfurt.perfect-privacy.net 1149

5. Nach einigen Tagen RT-AC66U_378.56_2.zip geflasht (3.0.0.4.374.43_2-17BAj9527 )
(kleiner Erfolg) mobile_singl_udp wurden über OVPN Hochladen, angenommen.
VPN Status: Running (im System Log Fehler)

Zertifikate einzeln importiert.

VPN Status: Running (im System Log Fehler)



Immer diese Fehlermeldung:
RESOLVE: Cannot resolve host address: montreal2.perfect-privacy.com: Name or service not known

https://www.dropbox.com/s/dj78skspa27y227/ovpn4.txt?dl=0


Ist die Software OK
Oder liegt es an den Einstellungen?
Hat jemand da ein Tipp für mich was ich noch ausprobieren könnte, bzw. was falsch eingestellt wurde?
 

didi12

New Member
Beim Accept-DNS Configuration sollte natürlich "Strict" stehen!
Beim Start with WAN: x JA

nach der änderung trotzdem

Feb 9 12:39:11 openvpn[566]: RESOLVE: Cannot resolve host address: montreal2.perfect-privacy.com: Name or service not known
 

PP Daniel

Staff member
Hi,

irgendwie liest sich das als versuchst du mit Key/Cert von Amsterdam zu Montreal2 zu verbinden. Aber evtl. liest sich das ja auch nur so.
Der Fehler unten sagt es gibt ein Problem mit der DNS Auflösung. Geht denn das ohne VPN? Kannst du IPs und DNS Adressen ohne/mit VPN pingen?
Und warum die mobile-Config ist mir auch nicht klar, ich nehme die von Linux (konkret Server als Gruppe, UDP) in leicht angepasster Form. Als Gruppe, da es so noch Fallbacks gibt falls mal ein Server der jeweiligen Gruppe nicht erreichbar sein sollte.
 

PP Daniel

Staff member
Der Beitrag von Gerd ist eigentlich sehr hilfreich was die Einstellungen angeht, das ist letztlich ja das Selbe in grün vom Aussehen her. Key/Certs kann man natürlich auch per c&p im Karteireiter "Keys" einfügen und kann sich das kopieren das Dateien sparen, ich habe das so gemacht und es läuft.
 

didi12

New Member
Hi Daniel, nee nee war nur Beispiel vom dem Forum
https://board.perfect-privacy.com/threads/openvpn-client-with-perfect-privacy-on-asus-rt-ac66u.302/

deswegen übernommen die Keys habe schon manuel 3x angepasst/ kontroliert. über OVPN Mobil left es ja fasst von alleine.

Die OVPN Datei Mobil enthält die Key auch? oder ist es zwingend die Linux und die Key einzeln in den

Einzutragen?

Als Gruppe habe ich es nocht nicht versucht.
An der WAN habe ich als DNS1/2 die 8.8.8.8 & 8.8.4.4 noch stehen.
 

didi12

New Member
JA ich weis dass es das selbe in grün ist, geb ich dir 100% recht, beim Tomato lief bei mir auch schon der Router würde gern mit (merlin) probieren den unterschied.
Genau deswegen verstehe ich nicht welche kleinigkeit ich übersehe.
 

PP Daniel

Staff member
Ja, an sich macht das schon Sinn, da sind in dem Post am Anfang ein paar Zeilen zu viel in der config. Bei mir läuft es mit folgendem im custom Feld:

tun-mtu 1500
fragment 1300
mssfix
auth SHA512
client
comp-lzo
hand-window 120
inactive 604800
mute-replay-warnings
ns-cert-type server
persist-key
persist-remote-ip
persist-tun
ping 5
ping-restart 120
redirect-gateway def1
remote-random
reneg-sec 3600
resolv-retry 60
route-delay 2
route-method exe
script-security 2
tls-cipher DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-CAMELLIA256-SHA:DHE-RSA-AES256-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-RSA-AES128-SHA:CAMELLIA256-SHA:AES256-SHA:CAMELLIA128-SHA:AES128-SHA
tls-timeout 5
verb 4
 

PP Daniel

Staff member
Hi,

sieht soweit richtig aus, sofern die IP Adressen passen. Wenn da Ping und DNS Auflösung funktioniert ist das auf jeden Fall schonmal nicht falsch.
 

didi12

New Member
die IP sollte passen PING probiere wenn ich nicht über VPN mit dem HOME netzt verbunden bin, heute Abend.

kann sein das der Router mit NTP Server problem hat, zeitlan ohne probleme danach, keine uhrzeit mehr




Welche Firmware hast du drauf?


PING geht ja ueber Netzwerkwerkzeuge auch cool ....


Das ist schon mal nicht gut ....

 

didi12

New Member
wenn ich auf der WAN seite automatische DNS einstelle dann erhält der Router die infos von der FritzBox

es funzt mit Automatische DNS Server

somit blockiert der Provieder alternative DNS ????? Möglich ...

wenn ich tracert ausführe ueber den Router
traceroute to www.google.com (92.226.2.49), 30 ...
IP router
IP Extern vom Router
das wars

ist es normal?

ich passe heute die Config an der Fritz-Box an mal schauen oder es wegen dem Gast Port an der Fritz box ist....
 
Last edited:
Top