Really Slow Speeds

Thor

New Member
I'm in Southern California and I have internet service up to 300 Mbps. Typically I'll get about 120 Mbps download speed and about 20 Mbps up without the VPN. With Perfect-Privacy, connecting to the Los Angeles server that says it's 80%-90% free, I get 21 ms latency, download speeds of only about 7.5 Mbps, and upload speeds of 11 Mbps.

I'm connecting to Perfect-Privacy on a Unifi USG via PPTP.

Any idea why my download speeds are so slow? Is this typical??

Thank you!
 

Thor

New Member
After further testing, it appears the bottleneck is not Perfect-Privacy, but is instead the Unifi USG. It just can't keep up with the load.
 

M S

New Member
You got the Unifi USG working?? Has anyone posted how to do this? I've been fiddling with it in the VPN setup and CLI for hours and can't get it to connect yet
 

Thor

New Member
Yes, I did, and it wasn't hard, as I remember. I don't believe I had to use CLI at all; I was able to do it all through the Unifi interface. Unfortunately, the throughput was so bad, I don't use the USG for VPN anymore.
 
  • Like
Reactions: M S

praxis

New Member
I experienced slow downloads also when connecting to the Melbourne, Australia server. It is apparently a 100Mbit connection and I've tested when it is apparently 0% loaded and still receive the same maximum throughput. When not connected to the VPN, my usual speeds are 90Mbit downstream / 30Mbit upstream. When I connect to the Melbourne server, the latency is not an issue with an average of 15-19ms but the download speeds top out at 30Mbit downstream and around 15Mbit upstream. I've never been able to obtain speeds faster than this, tested on multiple networks (my 4G LTE cellular carrier) and I can confirm that two other VPN competitors with highest encryption settings enabled (PIA, NordVPN) allow for full use of my bandwidth. This is also the maximum speed I can get using any of other other servers, with the added issue of much higher latency (150ms is the starting point in Japan, and it goes up from there).

Anyone else from Australia using the Melbourne server having these issues, and subsequently the other servers as far as max download speed goes?
 

Zach

New Member
I experienced slow downloads also when connecting to the Melbourne, Australia server. It is apparently a 100Mbit connection and I've tested when it is apparently 0% loaded and still receive the same maximum throughput. When not connected to the VPN, my usual speeds are 90Mbit downstream / 30Mbit upstream. When I connect to the Melbourne server, the latency is not an issue with an average of 15-19ms but the download speeds top out at 30Mbit downstream and around 15Mbit upstream. I've never been able to obtain speeds faster than this, tested on multiple networks (my 4G LTE cellular carrier) and I can confirm that two other VPN competitors with highest encryption settings enabled (PIA, NordVPN) allow for full use of my bandwidth. This is also the maximum speed I can get using any of other other servers, with the added issue of much higher latency (150ms is the starting point in Japan, and it goes up from there).

Anyone else from Australia using the Melbourne server having these issues, and subsequently the other servers as far as max download speed goes?
I'm also having these issues. It gets to a point where I need to change servers numerous times throughout the day in order to have a usable internet connection through perfect privacy. In my prior experience with other paid VPNs, I have never had this issue. It's frustrating.
 
Top