Really Slow Speeds

Discussion in 'Services - Questions & Answers (Q&A)' started by Thor, Dec 12, 2017.

  1. T

    Thor New Member

    I'm in Southern California and I have internet service up to 300 Mbps. Typically I'll get about 120 Mbps download speed and about 20 Mbps up without the VPN. With Perfect-Privacy, connecting to the Los Angeles server that says it's 80%-90% free, I get 21 ms latency, download speeds of only about 7.5 Mbps, and upload speeds of 11 Mbps.

    I'm connecting to Perfect-Privacy on a Unifi USG via PPTP.

    Any idea why my download speeds are so slow? Is this typical??

    Thank you!
     
  2. webslap

    webslap Member

    May I ask you`?
    You are connecting from Unifi USG directly to the VPN Server?
     
  3. T

    Thor New Member

    Yes, directly from the USG.
     
  4. T

    Thor New Member

    After further testing, it appears the bottleneck is not Perfect-Privacy, but is instead the Unifi USG. It just can't keep up with the load.
     
  5. webslap

    webslap Member

    Yes the Unifi USG ist not made for high VPN encryption speed.
     
  6. M

    M S New Member

    You got the Unifi USG working?? Has anyone posted how to do this? I've been fiddling with it in the VPN setup and CLI for hours and can't get it to connect yet
     
  7. T

    Thor New Member

    Yes, I did, and it wasn't hard, as I remember. I don't believe I had to use CLI at all; I was able to do it all through the Unifi interface. Unfortunately, the throughput was so bad, I don't use the USG for VPN anymore.
     
    M S likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice