How-To: Perfect Privacy VPN with Ubuntu

Discussion in 'Linux' started by PP Stephan, Aug 8, 2016.

  1. PP Stephan

    PP Stephan Staff Member

    This thread refers to the Howto Perfect Privacy VPN with Ubuntu. Please only post in this thread if you have questions, comments or feedback regarding this howto. To keep this thread updated and free from obsolete and redundant information, this thread will be cleaned up occasionally.
     
    Last edited: Aug 8, 2016
  2. t

    trevor1317 New Member

    I have ubuntu 17.10 and it is not possible to install the perfect privacy openvpn manager
    it is also not possible to install gdebi
     
  3. Q

    QQQ New Member

    repro, crashes on ubuntu 17, uninstall/re-install does not fix it
    x@X:~$ perfect-privacy-vpn
    Invalid MIT-MAGIC-COOKIE-1 keyUnable to init server: Could not connect: Connection refused
    Invalid MIT-MAGIC-COOKIE-1 keyUnable to init server: Could not connect: Connection refused
    /usr/bin/perfect-privacy-vpn: line 3: 17703 Segmentation fault pkexec /opt/perfect_privacy/perfect-privacy-vpn/bin/perfect-privacy-vpn
     
  4. PP Stephan

    PP Stephan Staff Member

    This sounds unusual. What exact Ubuntu version is that?

    Did you install any other desktop/Windows manager?

    Also, can you please check the file usr/share/polkit-1/actions/com.perfect-privacy.perfect-privacy-vpn.policy

    Look for that line that says

    Code:
    rg.freedesktop.policykit.exec.allow_gui 
    Does it say "TRUE" for this entry? If so, please try changing it to "true".
     
    Last edited by a moderator: Apr 16, 2018
  5. PP Stephan

    PP Stephan Staff Member

    Can you try open and installing it with "Ubuntu Software"?
     
  6. Z

    Zandros New Member

    Hi. I have a Windows and a Linux PC. Windows is easy and works fine. On the Linux PC I'm using Mint 19.
    Installation went fine but when I connect to a server it blocks all my internet traffic. The test page from the tutorial doesn't load. I have no clue what I'm doing wrong.
     
  7. n

    nobodysfool New Member

    You do nothing wrong,it happens to me too,on linux 19.1 and the latest ubuntu,it connects to PP but no browser works,all blocked,With earlier Mint it works like always
     
    Last edited: Jan 19, 2019
  8. n

    nobodysfool New Member

    also on 19.1 ?
     
  9. Z

    Zandros New Member

    I was in contact with Werner from PP and after a few exchanges we came to a solution for the Mint 19 problem: sudo apt-get install resolvconf
    The problem was with the DNS resolving. I hope this helps you out as well.
    Thanks Werner!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice