Packetloss mit OpenVPN

Discussion in 'Fragen & Antworten (Q&A)' started by pearf1337, May 2, 2019.

Tags:
  1. p

    pearf1337 New Member

    Hallo zusammen,

    ich nutze nun etwa 2 Monate PP mit OpenVPN. Leider muss ich Packetloss von ~2-5% feststellen. Dies äußert sich in Dropouts von mehreren hundert Millisekunden bis Sekunden die zB. Discord und Gaming unmöglich machen.

    Ich nutze ausschließlich die Frankfurter Server, zum Test auch den Hamburger.

    VPN Endpunkte die ich getestet habe:

    diverse Android Geräte
    Pfsense Router
    Desktop wired Windows 10
    Thinkpad Fedora 29

    Alle zeigten das selbe Phänomen. Als WAN kam Telekom VDSL 100 bzw. LTE zum Einsatz. Eine weitere parallele VPN Connection zu IPVanish funktioniert ohne Aussetzer und dazu noch mit einer deutlich niedrigeren Latenz.

    Ich bin was Netzwerktechnik L2/L3 angeht nicht auf den Kopf gefallen und habe zeitweise beruflich viel in dem Bereich gemacht. Momentan reiße ich mir aber die Haare seit einer Woche aus und finde den Fehler nicht. Ich habe alle Verschlüsselungen durch, die Kompressionsarten usw. Ich habe alle "Spezialoptionen" im Kundencenter deaktiviert.

    Wer weiß Rat?
     
    WKV likes this.
  2. G

    Gerd Junior Member

    So eine Frage kann nur ein PP Admin beatworten. Wende dich am besten an den Support.

    Für mich wäre es auch interessant, wie du auf diversen Endgeräten Packetloss festgestellt hast. Vielleicht können es die anderen dann auch bestätigen.
     
  3. p

    pearf1337 New Member

    zB mit ICMP-Paketen (PING) zum Google DNS. S
     
  4. p

    pearf1337 New Member

    Entschuldigung Post war noch nicht zu Ende ;)

    zB mit ICMP-Paketen (PING) zum Google DNS. Gutes Tool ist MTR.

    Direktverbindung Client -> Frankfurt:

    Start: 2019-05-04T21:38:05+0200
    HOST: localhost.localdomain Loss% Snt Last Avg Best Wrst StDev
    1.|-- _gateway 2.3% 300 26.2 30.8 25.7 374.4 20.6
    2.|-- te-2-2.ce21.fra-10.de.leaseweb.net 2.3% 300 27.3 30.9 25.9 283.9 16.4
    3.|-- te-0-3-0-9.br02.fra-10.de.leaseweb.net 1.7% 300 34.2 35.1 26.3 1160. 66.6
    4.|-- ffm-b10-link.telia.net 1.7% 300 37.0 37.9 25.8 1185. 90.6
    5.|-- ffm-bb4-link.telia.net 2.0% 300 31.6 30.3 26.2 129.8 7.8
    6.|-- ffm-b1-link.telia.net 0.7% 300 28.4 45.8 26.1 2005. 136.7
    7.|-- google-ic-319727-ffm-b1.c.telia.net 1.3% 300 37.5 33.4 26.4 796.7 44.9
    8.|-- ??? 100.0 300 0.0 0.0 0.0 0.0 0.0
    9.|-- 216.239.47.246 1.3% 300 31.0 38.3 28.2 1617. 92.4
    10.|-- 108.170.236.91 0.7% 300 40.8 70.5 38.3 2644. 243.2
    11.|-- google-public-dns-a.google.com 1.0% 300 40.2 69.4 37.8 2555. 234.5

    Client -> pfSense -> Frankfurt:

    Start: 2019-05-04T22:27:11+0200
    HOST: localhost.localdomain Loss% Snt Last Avg Best Wrst StDev
    1.|-- 10.0.197.1 2.3% 300 34.2 28.8 25.0 43.9 4.4
    2.|-- v415.ce01.fra-10.de.leaseweb.net 1.7% 300 28.5 28.9 25.0 78.7 5.0
    3.|-- be-1.br02.fra-10.de.leaseweb.net 1.7% 300 36.5 29.6 25.6 45.1 4.4
    4.|-- ffm-b11-link.telia.net 1.0% 300 50.9 30.9 25.3 90.0 6.8
    5.|-- google-ic-319727-ffm-b1.c.telia.net 1.7% 300 25.7 29.0 25.5 46.0 4.0
    6.|-- ??? 100.0 300 0.0 0.0 0.0 0.0 0.0
    7.|-- 66.249.94.134 1.7% 300 41.2 51.2 37.1 3162. 181.8
    8.|-- 108.170.236.89 2.0% 300 28.6 29.1 25.5 81.8 5.0
    9.|-- google-public-dns-a.google.com 1.7% 300 27.5 29.0 25.4 45.7 4.1

    pfSense -> kein VPN

    Start: 2019-05-04T23:51:46+0200
    HOST: myPfsense.example.com Loss% Snt Last Avg Best Wrst StDev
    1.|-- PUBLIC_WANIP 0.0% 300 19.3 10.9 6.7 68.7 6.8
    2.|-- 217.5.118.2 0.0% 300 15.2 15.8 13.0 30.6 3.8
    3.|-- 80.156.160.118 0.0% 300 13.8 16.7 13.4 34.6 4.6
    4.|-- ??? 100.0 300 0.0 0.0 0.0 0.0 0.0
    5.|-- 108.170.235.252 0.0% 300 19.7 15.8 12.9 43.4 4.7
    6.|-- 209.85.242.9 0.0% 300 13.8 17.1 13.7 59.1 4.9
    7.|-- google-public-dns-a.google.com 0.0% 300 13.4 15.9 12.9 50.0 4.5
     
  5. G

    Gerd Junior Member

    Also ich habe das Tool WinMTR benutzt. Alle "Spezialoptionen" im Kundencenter deaktiviert. PC direkt ans Kabelmodem per LAN verbunden.


    Frankfurt1 mit 300 Durchläufe, 1% Packetloss:
    Frankfurt1.JPG


    Frankfurt2 mit 420 Durchläufe, 1% Packetloss:
    Frankfurt2.JPG

    Amsterdam1 mit 300 Durchläufe, 1% Packetloss:
    Amsterdam1.JPG


    Hamburg1 mit 300 Durchläufe, 5% Packetloss:
    Hamburg1.JPG


    Bei Erfurt1 erst gegen dem Ende von 700 Durchläufe, 1% Packetloss:
    Erfurt1.JPG



    Ohne VPN mit 1000 Durchläufe, 0% Packetloss:
    Ohne-VPN.JPG

    So wie ich das sehe, hat jeder PP Server früher oder später Packetloss. Zum Glück habe ich keine Anwendungen laufen, wo das wichtig ist.
     
    WKV likes this.
  6. p

    pearf1337 New Member

    Ok das Problem ist reproduzierbar. Gut zu wissen.

    Ich habe schon ein Ticket dazu aufgemacht. Mal schauen was der Support dazu sagt.

    Ein wenig Packetloss ist ja zu verkraften. Die hier festgestellte Menge ist in meinen Augen absolut nicht in Ordnung.
     
  7. bohumil

    bohumil Member

    CapturFiles.jpg

    macOS Mojave, Server Frankfurt, OpenVPN.


    Die möglichen Ursachen für einen Packetloss bei VPN sind schier endlos, vielleicht liegt es an der Firewallkonfiguration?
     
  8. p

    pearf1337 New Member

    Mach mal min. 5 Minuten also 300 Pings
     
  9. bohumil

    bohumil Member

    Also nach 300 pings (Google raucht), kein loss:

    CapturFiles_1.jpg
     

    Attached Files:

  10. bohumil

    bohumil Member

  11. W

    WKV New Member

    Kurze Rückfrage:
    Bedeutet Packetloss, dass der komplette Datenstrom "kurz" dadurch unterbrochen wird (ohne dass die Verbindung getrennt wird), d.h. das in diesem Zeitpunkt auch nichts anderes durch die Leitung geht (z.B. der Internetstream auch kurz milisekunden unterbrochen wird) oder betrifft dieser Packetloss nur "einzelne" Bestandteile einer bestehenden Verbindung?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice