OpenVPN - Raspberry Pi 3 stockt

Discussion in 'Router' started by PRISM, Sep 4, 2019.

  1. PRISM

    PRISM Junior Member

    Hallo

    Hab seit geraumer Zeit ein echt nervendes Problem. Ich komm nicht dahinter was es sein könnte...

    Seit zwei Monaten habe ich ne 1 Gbit/s Leitung. Als Router habe ich eine AVM Fritz!Box 5490 Fiber.
    Über die Bundesligapause fiel dies mir gar nicht auf, da ich den RPi. sonst nur zum Abspielen von Filmen brauche.

    Aber:
    Die Streams stocken und laggen wie verrückt. Ohne VPN läuft alles wie Butter. Habe "VPN Manager für OpenVPN" installiert und die aktuellen TCP Files für OpenVPN 2.4 geladen. => stockt immer noch.
    Dann die 2.3 und 2.2 Files. Immer noch stocken. Selbstverständlich habe ich auch div. Server probiert.

    Auf dem PC geht alles. Da verwende ich allerdings Sealth VPN über Port 443 Obfsproxy 3.

    Müsste ich irgendwas im Modem einstellen oder wo ist der Hund begraben?

    Für Hilfe wäre ich dankbar ;)
     
  2. 8

    8vn5acnmf5 New Member

    Kommt das Raspi denn CPU mäßig hinterher?
     
  3. PRISM

    PRISM Junior Member

    Hallo
    Ich schau mal nach. Denke aber ja, da es ja davor (also mit ner VDSL Leitung) auch ging...
     
  4. PRISM

    PRISM Junior Member

    kann leider nicht mehr editieren. Hier die Ausgabe
    Code:
    top - 12:37:03 up 2 min,  1 user,  load average: 0.38, 0.15, 0.06
    Tasks: 139 total,   1 running, 138 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  5.1 us,  3.1 sy,  0.4 ni, 90.4 id,  0.0 wa,  0.0 hi,  1.0 si,  0.0 st
    KiB Mem :   769568 total,   286660 free,   247420 used,   235488 buff/cache
    KiB Swap:        0 total,        0 free,        0 used.   464676 avail Mem
    
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
      384 root      20   0  844744 278008  56200 S  20.8 36.1   0:53.87 kodi.bin
      331 root      20   0    5084   4292   3560 S  15.9  0.6   0:09.18 openvpn
      570 root      20   0    2960   1752   1444 R   1.6  0.2   0:00.72 top
        3 root      20   0       0      0      0 S   1.3  0.0   0:00.68 ksof
    
     
  5. PP Frank

    PP Frank Staff Member

    Da läuft Codi UND VPN. Das ist für so eine Büchse aber mächtig CPU Last. OpenVPN auf 15,9 Prozent was aber nur einen Kern nutzen kann. Dazu noch Kodi und da vermute ich das der eine Kern der von openVPN genutzt wird einfach auf Anschlag läuft.
     
  6. PRISM

    PRISM Junior Member

    Gestern war opvenvpn bei 20% und der RPi3 zeigte das Überhizungssymbol an (81°C) und alles stockte wieder.
    Wie gesagt, es lief jetzt 3 Jahre durch. Aber nun stimmt irgendwas nicht mehr. Ein Speedtest zeigt mir bei Strasbourg und Steinsel 3.8 Mbit Upload und einen Ping von 178 ms.
    Ohne VPN 68 Mbit Upload. und Ping von 5ms.
    ca. min. 10-15 Mbit müsstens sein, damit die Full HD Buli Streams nicht ruckeln. ggf. ist auch die SD Karte nach all den Jahren am Ende.

    Soll ich mal anstelle von VPN SSH testen?
     
  7. t

    tlo335 New Member

    Dein rpi quält sich.

    Versuch mal lieber nen rpi 4. mit Lüfter.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice