Not a bug: OpenVPN Overhead - Probleme mit dem Upload

Discussion in 'Linux' started by findus, Sep 6, 2018.

  1. f

    findus New Member

    Hallo, ich habe eine Frage zum Overhead bei OpenVPN.
    Ich habe gestern ein paar Downloadtests gemacht, und habe bemerkt, dass über OpenVPN wärend eines Downloads der Upload auch sehr stark beansprucht wird.
    Meine Frage ist deshalb: Ist das normal?

    • Internetleitung: 11 MBit Download | 1 Mbit Upload
    • VPN Server: Amsterdam über UDP ( über TCP das gleiche Problem)
    • Ich benutze die Standard Config Datei von Perfect Privacy

    Der Testdownload war ein normal http Download von Ubuntu-Linux

    Ich habe danach noch folgende Tests gemacht:

    • Normaler Download ohne VPN (Normale Auslastung des Uploads) photo_2018-09-06_17-30-47.jpg
    • Download mit IkeV2 über iOS (Etwas mehr aber bei weitem nicht so viel wie bei OpenVPN photo_2018-09-06_17-30-56.jpg
    • Download mit OpenVPN ( fast der gesamte Upload wird verbraucht) photo_2018-09-06_17-30-59.jpg
    Ich habe den OpenVPN-Test bereits bei 3 seperaten Rechner durchgeführt, alle mit gleichem Ergebnis. Ich weiß,dass mein Upload im Verhältnis zum Download eher mickrig ist, und deshalb schon bei Downloads ohne VPN der Upload durch TCP teilweise schon zu 1/4 ausgelastet wird, die Ressourcennutzng von OpenVPN kommt mir aber extrem hoch vor, muss ich die Config-Datei eventuell noch anderweitig anpassen?

    Gruß
    Findus

    Code:
    proto udp
    tun-mtu 1500
    mssfix 1500
    fragment 1500
    cipher AES-256-CBC
    ignore-unknown-option ncp-disable # ovpn 2.3 to 2.4 transition
    ncp-disable
    
    #Server urls ....
    
    auth SHA512
    auth-user-pass
    client
    comp-lzo
    dev tun
    #float
    hand-window 120
    inactive 604800
    mute-replay-warnings
    nobind
    #ns-cert-type server  # deprecated in openvpn 2.5
    remote-cert-tls server # new
    persist-key
    persist-remote-ip
    persist-tun
    ping 5
    ping-restart 120
    redirect-gateway def1
    remote-random
    reneg-sec 3600
    resolv-retry 60
    route-delay 2
    route-method exe
    script-security 2
    tls-cipher
    TLS-DHE-RSA-WITH-AES-256-GCM-SHA384:TLS-DHE-RSA-WITH-AES-256-CBC-SHA256:TLS-DHE-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-CAMELLIA-256-CBC-SHA:TLS-RSA-WITH-AES-256-CB$
    tls-timeout 5
    verb 4
    tun-ipv6
    
    #certs
     
  2. f

    findus New Member

    Hi,

    Ich habe das Problem zwar nicht gefunden, aber kann es umgehen, indem ich den AES-GCM Mode anstelle des AES-CBC Modes benutze.

    Gruß
    Findus
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice