How-To: OpenVPN on Linux terminal

Discussion in 'Linux' started by PP Stephan, Aug 8, 2016.

  1. PP Stephan

    PP Stephan Staff Member

    This thread refers to the Howto OpenVPN on Linux Terminal. Please only post in this thread if you have questions, comments or feedback regarding this howto. To keep this thread updated and free from obsolete and redundant information, this thread will be cleaned up occasionally.
    Last edited: Aug 8, 2016
  2. i

    iceking351 New Member


    The file "update-resolv-conf" is missing from the openvpn .opvn zip bundle.
    It is missing from both the UDP and TCP zip files.

    Is there a link that can be used to download the file?
    As a new member, I am excited to use the product, but without the file, I can not start the vpn connection.

  3. i

    iceking351 New Member


    ### For context, I am running a non-Debian based distro
    ### The below steps allowed me to get everything up and running

    o I was able to get it everything working by actually going
    through the openvpn package:
    $ rpm -ql openvpn | grep -i resolv

    o I read "/usr/share/doc/openvpn/contrib/pull-resolv-conf/client.up"
    and saw the instructions to make
    the necessary changes to /etc/resolv.conf

    # Place this in /etc/openvpn/client.up
    # Then, add the following to your /etc/openvpn/<clientconfig>.conf:
    # client
    # up /etc/openvpn/client.up
    # Next, "chmod a+x /etc/openvpn/client.up"

    o I copied both files
    # cp /usr/share/doc/openvpn/contrib/pull-resolv-conf/client*

    o Made them both executable
    # chmod +x /etc/openvpn/client*

    o I added the lines to the NewYork.opvn file:
    up /etc/openvpn/client.up
    down /etc/openvpn/client.down

    o Ran openvpn with the above profile
    # sudo openvpn /etc/openvpn/NewYork.ovpn

    o Received "Initialization Sequence Completed"

    o /etc/resolv.conf successfully updated.

    o I also confirmed no DNS leak at
  4. p

    privacyaddicted New Member

    When I get "Initialization Sequence Completed", I open another tab in the terminal and
    , nothing happens.
    Am I doing something wrong?
    Last edited: Oct 29, 2018
  5. g

    gumba New Member

  6. p

    privacyaddicted New Member

    It looks like my dns name can't get resolved. If I do:
    then the traffic goes through. Otherwise it times out. Any ideas. I'm using qubes os 4.0
    Last edited: Oct 29, 2018
  7. p

    privacyaddicted New Member

    what should I put into /etc/resolv.conf ? Mine just has:
  8. g

    gumba New Member

    Looks like the IP addresses in your resolv.conf are Qubes' own DNS servers, normally you would expect to find two of Perfect Privacy's servers there. I'm sorry but I don't think I can help you there as I have no experience with Qubes. Since it is by design a very locked down OS I'd assume that something prevents the VPN connection from getting set up as it would on other systems. I'm just guessing though.
  9. L

    Lamp New Member

    For privacy reasons I've disabled ipv6 at my Ubuntu 18.04 and it seems I cannot connect because of this:

    Is there any way to use your service with ubuntu + openvpn command line + without ipv6?
    Or maybe this issue is something else?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice