Anleitung: OpenVPN auf einem Router mit OpenWRT

PP Daniel

Staff member
Dieser Thread bezieht sich auf die Anleitung OpenVPN auf einem Router mit OpenWRT. Bitte schreibt hier nur, wenn Ihr Fragen, Anmerkungen oder anderes Feedback zu dieser Dokumentation habt. Um diesen Thread übersichtlich und frei von veralteten Postings zu halten, wird er ab und zu vom Moderatoren-Team aufgeräumt.
 

Gerd

Active Member
Die Erstellung mehrerer OpenVPN Clients



Wenn ihr mehrere OpenVPN Clients erstellen wollt, dann müsst ihr folgendes beachten:

  • In der /etc/openvpn/ppserver.ovpn Datei “dev tunX“ angeben (X steht hier für eine beliebige Zahl)
  • Dann für jeden OpenVPN Client im OpenWRT Menü (Network=>Interfaces) ein Interface mit tunX erstellen. X steht hier für eine Zahl, die ihr unter /etc/openvpn/ppserver.ovpn ausgewählt habt. Unter "Firewall Settings Tab" die Firewall-Regel "PP_Firewall" wie gewohnt angeben
  • Das Script für IPv6 dürft ihr bei mehreren Clients nicht aktivieren. Deaktivieren könnt ihr es mit WinSCP, indem ihr unter "/etc" die Datei "firewall.nat6" und unter "/etc/config/firewall" diese Option löscht:
Code:
config include 'nat6'
    option path '/etc/firewall.nat6'
    option reload '1'

Routen einzelner Endgeräte könnt ihr dann z. B. mit dem Package VPN Policy Routing festlegen.
 
Last edited:

Gerd

Active Member
VPN Policy Routing Package



Diese Anleitung beschreibt, wie man VPN Policy Routing Package auf OpenWRT 18.06.x einrichtet. Hier die englische Beschreibung. Damit könnt ihr z. B. OpenVPN Routen einzelner Endgeräte festlegen.

Hinweis: Für die Nutzung des VPN Policy Routing Package müsst ihr den OpenVPN Kill-Switch ausschalten. (Danach wird wie bei jedem Router ohne Kill-Switch, zwischen dem “Hochbooten“ und dem OpenVPN Start für eine kurze Zeit ein IP-Leak entstehen.)

Zur Konfiguration:
Öffnet das Programm PuTTY oder ein Terminal Programm und führt folgende Kommandos für OpenWRT aus: (Quelle)

Code:
opkg update; opkg install ipset resolveip ip-full kmod-ipt-ipset iptables

Code:
opkg update; if ubus -S call system board | grep -q '15.05'; then opkg install ca-certificates wget libopenssl; else opkg install uclient-fetch libustream-mbedtls ca-bundle ca-certificates; fi
echo -e -n 'untrusted comment: OpenWrt usign key of Stan Grishin\nRWR//HUXxMwMVnx7fESOKO7x8XoW4/dRidJPjt91hAAU2L59mYvHy0Fa\n' > /etc/opkg/keys/7ffc7517c4cc0c56
! grep -q 'stangri_repo' /etc/opkg/customfeeds.conf && echo 'src/gz stangri_repo https://raw.githubusercontent.com/stangri/openwrt-repo/master' >> /etc/opkg/customfeeds.conf

Code:
opkg update; opkg install vpn-policy-routing luci-app-vpn-policy-routing

Das Menü könnt ihr danach unter Services=>VPN Policy Routing aufrufen.

  • Endgeräte die an den OpenWRT Router angeschlossen bzw. mit dem OpenWRT Router verbunden sind, können unter Local addresses eingetragen werden
  • Geräte die vor OpenWRT angeschlossen sind, wie z. B. DSL/Cabel Router, könnt ihr unter Remote addresses eintragen
Routing.jpg


Wie man an dem oberen Bild sehen kann, benutzt PC1 und PlayStation das Interface PP_VPN1. PP_VPN1 ist in meinem Beispiel Amsterdam1.

PC2 und iPhone nutzen das Interface PP_VPN2. PP_VPN2 ist in meinem Beispiel Basel1.

Alle anderen Endgeräte nutzen das WAN Interface. Diese sind vom OpenVPN ausgeschlossen.

Im oberen Post wird erklärt, wie man ein Client (z. B. Amsterdam1) mit tunX an ein Interface (z. B. PP_VPN1) bindet.
 
Last edited:

moejoe

Member
Funktioniert das Tut auch mit dem GLi-Net Router ? Muss man evtl. vorh. interfaces deaktivieren ?



beste grüsse
 
Last edited:

Gerd

Active Member
Funktioniert das Tut auch mit dem GLi-Net Router ?

Hier das Tut mit OpenWRT für dein GLi-Net Router. Mit dem Prozessor wirst du aber nicht glücklich. Es gibt genug schnellere OpenWRT Router.

Das PP OpenWRT Tut ist aber etwas zu alt. Ich habe das neue Tut schon vor ein paar Monaten PP zugeschickt. Bis jetzt ist es aber nicht online.
 

Gerd

Active Member
Sorry moejoe. Habe erst jetzt gesehen das es dir um ein Travel Router geht.

Es gibt ein ganz normalen Router "EdgeRouter X" und ist etwas größer als eine Zigarettenschachtel. CPU ist 800 MHz ist aber nicht WiFi fähig. Ob es auch dafür eine Power Bank gibt, kann ich nicht sagen.

Daher ist GL-MT300N-V2 Mini Smart Router schon eine gute Wahl.
 

moejoe

Member
Kein Thema
Der Gli Router ist auch eher ein Versuchsrouter aber wenn er ausreicht, wird er zum 2t Router.

Edit:

Ist das TUT von PP aber nicht eher für die Config von dem VPN-client ?

grüsse
 
Last edited:

Matt

New Member
Guten Abend,

ich habe eine kleine Box (Nexx WT3020) auf der vorher schon eine modifizierte Version von OpenWRT/(LuCI eines VPN Betreibers lief.
Nun habe ich die Box geflasht und OpenWRT Version 19.07 installiert. Ich habe mich soweit an die ausführliche Anleitung gehalten. Wenn ich OpenVPN allerdings starte bekomme ich keine Internetverbindung.

Habe ich etwas falsch eingestellt oder übersehen?

Viele Grüße
 

Matt

New Member
Folgendes stand im Log

Code:
Mon Nov  9 16:38:05 2020 us=20346 OpenVPN 2.4.7 mipsel-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]
Mon Nov  9 16:38:05 2020 us=20626 library versions: OpenSSL 1.1.1h  22 Sep 2020, LZO 2.10
Mon Nov  9 16:38:05 2020 us=36803 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Mon Nov  9 16:38:05 2020 us=47022 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon Nov  9 16:38:05 2020 us=47602 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon Nov  9 16:38:05 2020 us=48042 LZO compression initializing
Mon Nov  9 16:38:05 2020 us=49341 Control Channel MTU parms [ L:1626 D:1140 EF:110 EB:0 ET:0 EL:3 ]
Mon Nov  9 16:38:05 2020 us=50401 Data Channel MTU parms [ L:1626 D:1300 EF:126 EB:407 ET:0 EL:3 ]
Mon Nov  9 16:38:05 2020 us=50881 Fragmentation MTU parms [ L:1626 D:1300 EF:125 EB:407 ET:1 EL:3 ]
Mon Nov  9 16:38:05 2020 us=51601 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 1,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-client'
Mon Nov  9 16:38:05 2020 us=52001 Expected Remote Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 0,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-server'
Mon Nov  9 16:38:05 2020 us=52461 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.244:1149
Mon Nov  9 16:38:05 2020 us=52921 Socket Buffers: R=[163840->163840] S=[163840->163840]
Mon Nov  9 16:38:05 2020 us=53321 UDP link local: (not bound)
Mon Nov  9 16:38:05 2020 us=53761 UDP link remote: [AF_INET]95.211.95.244:1149
Mon Nov  9 16:38:05 2020 us=88556 TLS: Initial packet from [AF_INET]95.211.95.244:1149, sid=cad14fcf 2de7aad8
Mon Nov  9 16:38:05 2020 us=90015 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Mon Nov  9 16:38:05 2020 us=246692 VERIFY KU OK
Mon Nov  9 16:38:05 2020 us=247152 Validating certificate extended key usage
Mon Nov  9 16:38:05 2020 us=247572 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Mon Nov  9 16:38:05 2020 us=247952 VERIFY EKU OK
Mon Nov  9 16:38:05 2020 us=248352 VERIFY OK: depth=0, C=CH, ST=Zug, O=Perfect Privacy, CN=Server_amsterdam.perfect-privacy.com, emailAddress=admin@perfect-privacy.com
Mon Nov  9 16:38:17 2020 us=799998 WARNING: 'cipher' is used inconsistently, local='cipher AES-128-CBC', remote='cipher AES-256-CBC'
Mon Nov  9 16:38:17 2020 us=800758 WARNING: 'keysize' is used inconsistently, local='keysize 128', remote='keysize 256'
Mon Nov  9 16:38:17 2020 us=803118 Control Channel: TLSv1.2, cipher TLSv1.2 DHE-RSA-AES256-GCM-SHA384, 4096 bit RSA
Mon Nov  9 16:38:17 2020 us=803718 [Server_amsterdam.perfect-privacy.com] Peer Connection Initiated with [AF_INET]95.211.95.244:1149
Mon Nov  9 16:38:19 2020 us=58749 SENT CONTROL [Server_amsterdam.perfect-privacy.com]: 'PUSH_REQUEST' (status=1)
Mon Nov  9 16:38:19 2020 us=82146 PUSH: Received control message: 'PUSH_REPLY,topology subnet,redirect-gateway def1,sndbuf 131072,rcvbuf 131072,comp-lzo adaptive,route-gateway 10.0.67.2,redirect-gateway ipv6,route-ipv6 2000::/3,ping 10,ping-restart 60,dhcp-option DNS 185.17.184.3,dhcp-option DNS 95.211.199.144,ifconfig-ipv6 fdbf:1d37:bbe0:0:4:11:0:1e/112 fdbf:1d37:bbe0:0:4:11:0:1,ifconfig 10.0.67.30 255.255.255.0,peer-id 14'
Mon Nov  9 16:38:19 2020 us=83606 OPTIONS IMPORT: timers and/or timeouts modified
Mon Nov  9 16:38:19 2020 us=83986 OPTIONS IMPORT: compression parms modified
Mon Nov  9 16:38:19 2020 us=84506 LZO compression initializing
Mon Nov  9 16:38:19 2020 us=84926 OPTIONS IMPORT: --sndbuf/--rcvbuf options modified
Mon Nov  9 16:38:19 2020 us=85446 Socket Buffers: R=[163840->262144] S=[163840->262144]
Mon Nov  9 16:38:19 2020 us=85826 OPTIONS IMPORT: --ifconfig/up options modified
Mon Nov  9 16:38:19 2020 us=86226 OPTIONS IMPORT: route options modified
Mon Nov  9 16:38:19 2020 us=86646 OPTIONS IMPORT: route-related options modified
Mon Nov  9 16:38:19 2020 us=87046 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Mon Nov  9 16:38:19 2020 us=87426 OPTIONS IMPORT: peer-id set
Mon Nov  9 16:38:19 2020 us=87826 OPTIONS IMPORT: adjusting link_mtu to 1629
Mon Nov  9 16:38:19 2020 us=88326 Data Channel MTU parms [ L:1609 D:1300 EF:109 EB:407 ET:0 EL:3 ]
Mon Nov  9 16:38:19 2020 us=89786 Outgoing Data Channel: Cipher 'AES-128-CBC' initialized with 128 bit key
Mon Nov  9 16:38:19 2020 us=90346 Outgoing Data Channel: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon Nov  9 16:38:19 2020 us=90786 Incoming Data Channel: Cipher 'AES-128-CBC' initialized with 128 bit key
Mon Nov  9 16:38:19 2020 us=91346 Incoming Data Channel: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon Nov  9 16:38:19 2020 us=92946 GDG6: remote_host_ipv6=n/a
Mon Nov  9 16:38:19 2020 us=93485 GDG6: NLMSG_ERROR: error Permission denied

Mon Nov  9 16:38:19 2020 us=98525 TUN/TAP device tun0 opened
Mon Nov  9 16:38:19 2020 us=105124 TUN/TAP TX queue length set to 100
Mon Nov  9 16:38:19 2020 us=105604 do_ifconfig, tt->did_ifconfig_ipv6_setup=1
Mon Nov  9 16:38:19 2020 us=106184 /sbin/ifconfig tun0 10.0.67.30 netmask 255.255.255.0 mtu 1500 broadcast 10.0.67.255
Mon Nov  9 16:38:19 2020 us=133322 /sbin/ifconfig tun0 add fdbf:1d37:bbe0:0:4:11:0:1e/112
Mon Nov  9 16:38:19 2020 us=141281 up.sh tun0 1500 1609 10.0.67.30 255.255.255.0 init
udhcpc: started, v1.30.1
udhcpc: sending discover
udhcpc: no lease, failing
Mon Nov  9 16:38:24 2020 us=953635 /sbin/route add -net 95.211.95.244 netmask 255.255.255.255 gw 192.168.178.1
Mon Nov  9 16:38:24 2020 us=959735 /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.0.67.2
Mon Nov  9 16:38:24 2020 us=965594 /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.0.67.2
Mon Nov  9 16:38:24 2020 us=971354 add_route_ipv6(2000::/3 -> fdbf:1d37:bbe0:0:4:11:0:1 metric -1) dev tun0
Mon Nov  9 16:38:24 2020 us=971894 /sbin/route -A inet6 add 2000::/3 dev tun0
Mon Nov  9 16:38:24 2020 us=977893 add_route_ipv6(::/3 -> fdbf:1d37:bbe0:0:4:11:0:1 metric -1) dev tun0
Mon Nov  9 16:38:24 2020 us=978433 /sbin/route -A inet6 add ::/3 dev tun0
Mon Nov  9 16:38:24 2020 us=984253 add_route_ipv6(2000::/4 -> fdbf:1d37:bbe0:0:4:11:0:1 metric -1) dev tun0
Mon Nov  9 16:38:24 2020 us=984793 /sbin/route -A inet6 add 2000::/4 dev tun0
Mon Nov  9 16:38:24 2020 us=990752 add_route_ipv6(3000::/4 -> fdbf:1d37:bbe0:0:4:11:0:1 metric -1) dev tun0
Mon Nov  9 16:38:24 2020 us=991292 /sbin/route -A inet6 add 3000::/4 dev tun0
Mon Nov  9 16:38:24 2020 us=997171 add_route_ipv6(fc00::/7 -> fdbf:1d37:bbe0:0:4:11:0:1 metric -1) dev tun0
Mon Nov  9 16:38:24 2020 us=997711 /sbin/route -A inet6 add fc00::/7 dev tun0
Mon Nov  9 16:38:25 2020 us=3591 Initialization Sequence Completed
Mon Nov  9 17:38:17 2020 us=861524 TLS: soft reset sec=0 bytes=214560/-1 pkts=1303/0
Mon Nov  9 17:38:18 2020 us=39825 VERIFY KU OK
Mon Nov  9 17:38:18 2020 us=40305 Validating certificate extended key usage
Mon Nov  9 17:38:18 2020 us=40705 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Mon Nov  9 17:38:18 2020 us=41105 VERIFY EKU OK
Mon Nov  9 17:38:18 2020 us=41505 VERIFY OK: depth=0, C=CH, ST=Zug, O=Perfect Privacy, CN=Server_amsterdam.perfect-privacy.com, emailAddress=admin@perfect-privacy.com
Mon Nov  9 17:38:26 2020 us=952531 WARNING: 'cipher' is used inconsistently, local='cipher AES-128-CBC', remote='cipher AES-256-CBC'
Mon Nov  9 17:38:26 2020 us=953291 WARNING: 'keysize' is used inconsistently, local='keysize 128', remote='keysize 256'
Mon Nov  9 17:38:26 2020 us=956330 Outgoing Data Channel: Cipher 'AES-128-CBC' initialized with 128 bit key
Mon Nov  9 17:38:26 2020 us=956890 Outgoing Data Channel: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon Nov  9 17:38:26 2020 us=957330 Incoming Data Channel: Cipher 'AES-128-CBC' initialized with 128 bit key
Mon Nov  9 17:38:26 2020 us=957890 Incoming Data Channel: Using 512 bit message hash 'SHA512' for HMAC authentication
Mon Nov  9 17:38:26 2020 us=958830 Control Channel: TLSv1.2, cipher TLSv1.2 DHE-RSA-AES256-GCM-SHA384, 4096 bit RSA
 

Gerd

Active Member
OpenVPN Verbindung steht. Das sieht man an:

Code:
Mon Nov  9 16:38:25 2020 us=3591 Initialization Sequence Completed

Ich würde erstmal auf Firewall tippen. Was steht in /etc/config/firewall?
 

Matt

New Member
Code:
config defaults
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option synflood_protect '1'

config zone
    option name 'lan'
    list network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config zone
    option name 'wan'
    list network 'wan'
    list network 'wan6'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fc00::/6'
    option dest_ip 'fc00::/6'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-IPSec-ESP'
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option name 'Allow-ISAKMP'
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config zone
    option network 'PP_VPN'
    option forward 'REJECT'
    option name 'PP_Firewall'
    option output 'ACCEPT'
    option input 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option dest 'PP_Firewall'
    option src 'lan'
 

Gerd

Active Member
Bei dir ist nicht mal KillSwitch aktiviert. Dafür müsste man folgendes löschen:

Code:
config forwarding
    option src 'lan'
    option dest 'wan'

Deshalb verstehe ich nicht, warum du kein Internet hast.

Die Firewall Konfiguration sieht auch ok aus.
Dann vermute ich mal, dass du etwas bei der Konfiguration übersehen hast.
 

Matt

New Member
Das einzige was ich evtl. anders gemacht hätte wäre dieser Punkt.
  • Name of the new interface: PP_VPN
  • Protocol of the new interface: Unmanaged
  • Cover the following interface: Custom Interface: tun0
"tun0" wurde mir nicht angezeigt, ich habe stattdessen "eth0" genommen.
 

Matt

New Member
Perfekt! jetzt passt es. Ich bin mit dem VPN verbunden.
Ok, dass mit dem tun0 habe ich wohl nicht ganz verstanden.

Vielen lieben Dank für die Hilfe
 

Gerd

Active Member
Ich bin mir jetzt nicht 100% sicher, aber von der Konfiguration her kann man glaube ich auch z. B. hausnr20 angeben.
Wenn man das aber macht, dann muss man auch hausnr20 in der OpenVPN Config angeben. Also
Code:
dev hausnr20

Verschiedene/mehrere Bezeichnungen sind erst von Bedeutung, wenn man mit routing arbeiten möchte.
Z.B. Endgerät1 und 3 geht über hausnr20
Und Endgerät2 und 4 geht über hausnr21.
 

Matt

New Member
Nachdem gestern alles lief, gab es heute wieder einen Rückschlag. Ich bin wieder nicht mit dem VPN verbunden.
Wenn ich im Interface nachschaue steht dort Error: Device ist not present. Habe versucht neu zu starten aber ohne Erfolg.

Könnte es vielleicht daran liegen, dass der IP Kreis unterschiedlich ist? Ich nutze eine Fritz Box für das Internet mit dem IP Kreis 192.168.178.x
Die Box nutzt aber den IP Kreis 192.168.1.x

Das Internet Signal wird mir aber durch die Box durchgeschleift.

Folgendes stand im OpenVPN Log

Code:
Tue Nov 10 15:55:21 2020 us=411966 OpenVPN 2.4.7 mipsel-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]
Tue Nov 10 15:55:21 2020 us=412266 library versions: OpenSSL 1.1.1h  22 Sep 2020, LZO 2.10
Tue Nov 10 15:55:21 2020 us=481083 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Tue Nov 10 15:55:21 2020 us=521321 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Tue Nov 10 15:55:21 2020 us=521881 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
Tue Nov 10 15:55:21 2020 us=522341 LZO compression initializing
Tue Nov 10 15:55:21 2020 us=523661 Control Channel MTU parms [ L:1626 D:1140 EF:110 EB:0 ET:0 EL:3 ]
Tue Nov 10 15:55:21 2020 us=524701 Data Channel MTU parms [ L:1626 D:1300 EF:126 EB:407 ET:0 EL:3 ]
Tue Nov 10 15:55:21 2020 us=525201 Fragmentation MTU parms [ L:1626 D:1300 EF:125 EB:407 ET:1 EL:3 ]
Tue Nov 10 15:55:21 2020 us=525921 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 1,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-client'
Tue Nov 10 15:55:21 2020 us=526321 Expected Remote Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 0,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-server'
Tue Nov 10 15:55:21 2020 us=526781 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:55:21 2020 us=527221 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue Nov 10 15:55:21 2020 us=527641 UDP link local: (not bound)
Tue Nov 10 15:55:21 2020 us=528081 UDP link remote: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:57:21 2020 us=395996 [UNDEF] Inactivity timeout (--ping-restart), restarting
Tue Nov 10 15:57:21 2020 us=396896 TCP/UDP: Closing socket
Tue Nov 10 15:57:21 2020 us=397696 SIGUSR1[soft,ping-restart] received, process restarting
Tue Nov 10 15:57:21 2020 us=401815 Restart pause, 5 second(s)
Tue Nov 10 15:57:26 2020 us=402332 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Tue Nov 10 15:57:26 2020 us=402812 Re-using SSL/TLS context
Tue Nov 10 15:57:26 2020 us=403232 LZO compression initializing
Tue Nov 10 15:57:26 2020 us=404352 Control Channel MTU parms [ L:1626 D:1140 EF:110 EB:0 ET:0 EL:3 ]
Tue Nov 10 15:57:26 2020 us=405252 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:57:26 2020 us=405752 Data Channel MTU parms [ L:1626 D:1300 EF:126 EB:407 ET:0 EL:3 ]
Tue Nov 10 15:57:26 2020 us=406192 Fragmentation MTU parms [ L:1626 D:1300 EF:125 EB:407 ET:1 EL:3 ]
Tue Nov 10 15:57:26 2020 us=406912 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 1,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-client'
Tue Nov 10 15:57:26 2020 us=407312 Expected Remote Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 0,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-server'
Tue Nov 10 15:57:26 2020 us=407772 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:57:26 2020 us=408232 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue Nov 10 15:57:26 2020 us=408632 UDP link local: (not bound)
Tue Nov 10 15:57:26 2020 us=409072 UDP link remote: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:57:26 2020 us=409792 write UDP: Network unreachable (code=128)
Tue Nov 10 15:57:26 2020 us=410332 Network unreachable, restarting
Tue Nov 10 15:57:26 2020 us=411112 TCP/UDP: Closing socket
Tue Nov 10 15:57:26 2020 us=411892 SIGUSR1[soft,network-unreachable] received, process restarting
Tue Nov 10 15:57:26 2020 us=415912 Restart pause, 5 second(s)
Tue Nov 10 15:57:31 2020 us=416418 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Tue Nov 10 15:57:31 2020 us=416938 Re-using SSL/TLS context
Tue Nov 10 15:57:31 2020 us=417358 LZO compression initializing
Tue Nov 10 15:57:31 2020 us=418438 Control Channel MTU parms [ L:1626 D:1140 EF:110 EB:0 ET:0 EL:3 ]
Tue Nov 10 15:57:31 2020 us=419338 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:57:31 2020 us=419838 Data Channel MTU parms [ L:1626 D:1300 EF:126 EB:407 ET:0 EL:3 ]
Tue Nov 10 15:57:31 2020 us=420338 Fragmentation MTU parms [ L:1626 D:1300 EF:125 EB:407 ET:1 EL:3 ]
Tue Nov 10 15:57:31 2020 us=421077 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 1,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-client'
Tue Nov 10 15:57:31 2020 us=421477 Expected Remote Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 0,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-server'
Tue Nov 10 15:57:31 2020 us=421917 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:57:31 2020 us=422377 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue Nov 10 15:57:31 2020 us=422777 UDP link local: (not bound)
Tue Nov 10 15:57:31 2020 us=423217 UDP link remote: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:59:31 2020 us=359965 [UNDEF] Inactivity timeout (--ping-restart), restarting
Tue Nov 10 15:59:31 2020 us=360885 TCP/UDP: Closing socket
Tue Nov 10 15:59:31 2020 us=361685 SIGUSR1[soft,ping-restart] received, process restarting
Tue Nov 10 15:59:31 2020 us=365724 Restart pause, 5 second(s)
Tue Nov 10 15:59:36 2020 us=366224 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Tue Nov 10 15:59:36 2020 us=366704 Re-using SSL/TLS context
Tue Nov 10 15:59:36 2020 us=367124 LZO compression initializing
Tue Nov 10 15:59:36 2020 us=368183 Control Channel MTU parms [ L:1626 D:1140 EF:110 EB:0 ET:0 EL:3 ]
Tue Nov 10 15:59:36 2020 us=369083 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:59:36 2020 us=369583 Data Channel MTU parms [ L:1626 D:1300 EF:126 EB:407 ET:0 EL:3 ]
Tue Nov 10 15:59:36 2020 us=370103 Fragmentation MTU parms [ L:1626 D:1300 EF:125 EB:407 ET:1 EL:3 ]
Tue Nov 10 15:59:36 2020 us=370843 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 1,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-client'
Tue Nov 10 15:59:36 2020 us=371243 Expected Remote Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 0,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-server'
Tue Nov 10 15:59:36 2020 us=371703 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 15:59:36 2020 us=372163 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue Nov 10 15:59:36 2020 us=372563 UDP link local: (not bound)
Tue Nov 10 15:59:36 2020 us=373003 UDP link remote: [AF_INET]95.211.95.232:1148
Tue Nov 10 16:01:36 2020 us=299977 [UNDEF] Inactivity timeout (--ping-restart), restarting
Tue Nov 10 16:01:36 2020 us=300877 TCP/UDP: Closing socket
Tue Nov 10 16:01:36 2020 us=301677 SIGUSR1[soft,ping-restart] received, process restarting
Tue Nov 10 16:01:36 2020 us=305716 Restart pause, 5 second(s)
Tue Nov 10 16:01:41 2020 us=306206 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Tue Nov 10 16:01:41 2020 us=306686 Re-using SSL/TLS context
Tue Nov 10 16:01:41 2020 us=307106 LZO compression initializing
Tue Nov 10 16:01:41 2020 us=308166 Control Channel MTU parms [ L:1626 D:1140 EF:110 EB:0 ET:0 EL:3 ]
Tue Nov 10 16:01:41 2020 us=309086 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 16:01:41 2020 us=309586 Data Channel MTU parms [ L:1626 D:1300 EF:126 EB:407 ET:0 EL:3 ]
Tue Nov 10 16:01:41 2020 us=310086 Fragmentation MTU parms [ L:1626 D:1300 EF:125 EB:407 ET:1 EL:3 ]
Tue Nov 10 16:01:41 2020 us=310846 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 1,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-client'
Tue Nov 10 16:01:41 2020 us=311266 Expected Remote Options String (VER=V4): 'V4,dev-type tun,link-mtu 1606,tun-mtu 1500,proto UDPv4,comp-lzo,mtu-dynamic,keydir 0,cipher AES-128-CBC,auth SHA512,keysize 128,tls-auth,key-method 2,tls-server'
Tue Nov 10 16:01:41 2020 us=311726 TCP/UDP: Preserving recently used remote address: [AF_INET]95.211.95.232:1148
Tue Nov 10 16:01:41 2020 us=312186 Socket Buffers: R=[163840->163840] S=[163840->163840]
Tue Nov 10 16:01:41 2020 us=312586 UDP link local: (not bound)
Tue Nov 10 16:01:41 2020 us=313026 UDP link remote: [AF_INET]95.211.95.232:1148
 

Gerd

Active Member
Liegt vielleicht daran, dass an dem Server Wartungsarbeiten gemacht werden, mit dem du dich verbinden willst.

Kannst du immer auf der PP Homepage unter "VPN Server" nachsehen.
 
Top