Solved: Linux Socks Proxy over SSH - need help

Durzo

Junior Member
Problem solved:
Code:
sshpass -p "*******" ssh -N *******@us.gigabit.perfect-privacy.com -D 127.0.0.1:8020
It works when executed as a regular user and NOT root


I really need some help here.
All I want is to automatically create a Socks Proxy over SSH that stores my password.
Everything I've tried failed.

Putty is unable to store passwords and it always crashes after login.
KSTM/KDE SSH Tunnel Manager does not work, I don't get an error but the proxy doesn't work.
sshpass + ssh over commandline doesn't work either.
sshpass -p myPasswrd ssh -N -D1080 username@us.gigabit.perfect-privacy.com

I can't express how annoyed I am right now, in Windows I use Bitvise Tunnelier which works perfectly but it's not available for Linux.

I hope someone can help me.

Browser settings:
SOCKS Host: 127.0.0.1 Port 1080
SOCKS v5

OS: Arch Linux x86_64 with KDE
 

Durzo

Junior Member
JackCarver;n3000 said:
sshpass -p "myPassword" ssh -N username@us.gigabit.perfect-privacy.com -D 127.0.0.1:8020

works for me in Iceweasel@debian-wheezy. Set socks Host 127.0.0.1 Port 8020 or whatever Port you want in Browser.
Thanks for your reply. I've just used the same command as you posted (with my username and password of course) but nothing happens when I execute it, just like before.
 

Durzo

Junior Member
Nothing:
[root@ArchHell ~]# sshpass -p "*******" ssh -N *******@us.gigabit.perfect-privacy.com -D 127.0.0.1:8020
[root@ArchHell ~]#

Update: When I execute it as a regular user and not root it works.
Thanks for your help.
 

JackCarver

Junior Member
Did you ever establish a Connection via ssh to this server? Otherwise the Server IP and Fingerprint isn't in your known hosts file and Linux refuses to connect
 

JackCarver

Junior Member
I think sshpass is Not sufficiant to get it in known hosts. You Need First ssh command without sshpass
 
Top