Komische Warnungen im VPN GUI

Discussion in 'Windows' started by Honeypot, Nov 2, 2019.

  1. H

    Honeypot New Member

    Hallo Leute ich habe mir gerade die neusten Server runtergealden und bekomme seit dem diese Warnungen in Roter Farbe wenn ich mich per VPN einloggen will.
    Bis jetzt hatte ich diese Meldungen nie gehapt.
    Mir geht es haupsächlich darum ob es Sicherheitsrelevate Dinge sind und ob die Sicherheit darunter leidet. Wenn sich dann noch ein User bereit erklärt mir kurz zu erklären was das ganze zu bedeuten hat wäre ich ihm sehr dankbar :)

    Kurz zur Info ich benutze OPEN VPN GUI zum connecten

    Sun Nov 03 00:12:35 2019 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1581', remote='link-mtu 1633'
    Sun Nov 03 00:12:35 2019 WARNING: 'keydir' is present in local config but missing in remote config, local='keydir 0'
    Sun Nov 03 00:12:35 2019 WARNING: 'cipher' is used inconsistently, local='cipher AES-256-GCM', remote='cipher AES-256-CBC'
    Sun Nov 03 00:12:35 2019 WARNING: 'auth' is used inconsistently, local='auth [null-digest]', remote='auth SHA512'
     
  2. Honk

    Honk Member

    Vermute, du hast die openVPN-Version 2.4 installiert, die Configdateien sind aber für 2.3.
     
    Honeypot likes this.
  3. H

    Honeypot New Member

    Das ist gut möglich das werde ich nacher mal testen und bescheid geben. Heisst es das ich jetzt sicherheitstechnisch nicht ganz "abgesichert" bin? Alle Tests zeigen das es keinen leak gibt aber wenn die Config Datein nicht auf das 2.4 GUI abgestimmt sind kann es evt Probleme geben?
     
  4. Honk

    Honk Member

    Es wäre sinnvoll, zu der Openvpn-Version die passenden Configdateien zu verwenden.
    Es spricht auch nichts dagegen, Openvpn auf dem neusten Stand zu halten.
     
  5. H

    Honeypot New Member

    Ich habe gesehen das ich aktuell die neuste Version vom VPN GUI habe also das kann nicht der Fehler gewesen sein! Ich habe trotzdem deinstalliert und neu installiert und auch noch mal die Config Datein neu runtergeladen welche sicher auch auf die Version 2.4 eingestellt sind aber trotzdem kommt die obige Fehlermeldung im VPN GUI? Hat einer evt eine Idee woran es liegen kann da man ja nun ausschliessen kann das es daran liegt was die beiden vorposter sagen?
     
  6. PP Daniel

    PP Daniel Staff Member

    Das sind keine Fehlermeldungen sondern Warnungen, deshalb steht da auch "Warning" und nicht etwa "Error" dran. Dass man solche Warnungen im Verbindungslog sieht ist durchaus normal. Unsere VPN-Server müssen Verbindungen mit unterschiedlichen Einstellungen ermöglichen, damit sich die Clients mit unterschiedlichen Einstellungen damit verbinden können. Dennoch haben die Server eine Standardeinstellung, die kann aber logischerweise nicht gleichzeitig zu jeder der unterschiedlichen Client-Konfigurationen passen, daher die Inkonsistenzen.
     
    Honeypot likes this.
  7. H

    Honeypot New Member

    Vielen Dank für die Erklärung Daniel :kiss::D
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice