Kleine technische Probleme

Snowdenwhite

Junior Member
Hallo!

ich nutze PP schon eine Weile und eingerichtet nach Standard eigentlich.

In letzter Zeit passiert es wiederholbar, dass der DNS-Eintrag auf meiner IP-Verbindung der Netzwerkkarte rausfliegt und dann - nach regulärem Trennen und Beenden des PP VPN Client - nicht wieder eingesetzt wird. Das DNS-Feld bleibt leer.
Ich mache das dann immer manuell und dann geht's auch gleich wieder. Aber es ist eben lästig. Auch das Zurücksetzen des Netzwerks bringt nichts. Aktualisierungen werden natürlich immer gefahren.

Und: nach dem letzten Windows Update war der Client plötzlich deinstalliert. Wie mag das kommen. Neuinstallation ist schnell gemacht, aber komisch ist das schon.

Beste Grüße
Snowy
 

PP Frank

Staff member
Die DNS-Leakoption setzt automatisch nach beenden der DNS-Leakprotection die DNS Einstellung auf automatisch. Ich hatte da selbst den Entwickler vor etlichen Monaten schon mal gefragt warum das so ist. Da Windows etliche Bugs in dem Bereich hat, ging das wohl nicht anders.
 

Snowdenwhite

Junior Member
Wäre es denn nicht einfach möglich vor dem Aufbau,den Gateway auszulesen und hinterher wieder zurückzuschreiben?
Ich habe das Problem jetzt in ca. 30 Installationen unter Windows 7 und 10 (1903) nachstellen können, wo feste IPs vergeben wurden oder die Vorgaben vom DHCP kommen. Das kann schon echt lästig werden.

Vielleicht mal drüber nachdenken, denn sonst sehe ich da als Windows-Admin für mehr als 400+ Workstations kein generelles "Windows-Problem".
 

Snowdenwhite

Junior Member
Scheinbar ein nicht durch PP lösbares Problem.
Aktuell löse ich dieses Problem immer durch die administrative Ausführung dieses Skriptes:


Code:
@echo off
netsh interface show interface
 
echo.
set /P Interface1=Name "Schnittstelle":
echo.
set /P ip="IP-Adresse":
echo.
set /P mask="Subnet Adresse":
echo.
set /P gate="Gateway Adresse":
echo.
set /P dns="DNS Adresse":
echo.
 
netsh interface ipv4 set address name="%Interface1%" source=static addr=%ip% mask=%mask%
netsh interface ipv4 set dns name="%Interface1%" source=static addr=%dns% register=PRIMARY
netsh interface ipv4 add address name="%Interface1%" gateway=%gate% gwmetric=1
 
echo.
ipconfig /all
pause
Das Skript kann auch nur auf das Setzen des Gateways eingekürzt werden. Die richtige Bezeichnung der Schnittstelle ist wichtig.
Damit sollte es dann wieder gehen.
 
Top