Beantwortet: Install Server

peberl

New Member
root@amazing-pascal:~# sudo openvpn /etc/openvpn/Amsterdam.conf
Fri Dec 11 12:07:33 2020 Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore.
Fri Dec 11 12:07:33 2020 us=793053 WARNING: cannot stat file 'password.txt': No such file or directory (errno=2)
Options error: --auth-user-pass fails with 'password.txt': No such file or directory (errno=2)
Options error: Please correct these errors.
Use --help for more information.
alles normal richtig eingegeben auch password.txt
username: xxxxxx
password: xxxxxxxxxx

root@amazing-pascal:~# wget -q -O - https://checkip.perfect-privacy.com/csv
IP,DNS,VPN,TOR,COUNTRY,CITY
194.22.112.10,194.22.112.10,false,false,Ukraine,root@amazing-pascal:~#


Alle Optionen überprüft

wo kann der fehler sein?
 
Solution
Ist es also "amtlich", dass man immer erst ins openvpn Verzeichnis wechseln muss, um den Dienst starten zu können?
Da, wie TurboDev sagt, OpenVPN die User/PW-Datei im aktiven Verzeichnis sucht, wenn in der .conf kein absoluter Pfad angegeben wurde, ja. Alternativ könntest du mal einen absoluten Verweis probieren, also in den entsprechenden Dateien auth-user-pass password.txt zu ändern in auth-user-pass /etc/openvpn/password.txt - könnte mir vorstellen, dass das dann klappt.

TurboDev

New Member
Ich glaube openvpn versucht die Datei vom aktuellen Verzeichnis zu laden, wenn du keinen absoluten Pfad angegeben hast. Probier mal in das Verzeichnis zu wechseln wo die config liegt.
Code:
cd /etc/openvpn/
sudo openvpn Amsterdam.conf
 

peberl

New Member
irgend etwas passt hier nicht
Password geändert aber ist immer nocht falsch

Fri Dec 11 14:26:29 2020 Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore.
Fri Dec 11 14:26:29 2020 us=496410 WARNING: cannot stat file 'password.txt': No such file or directory (errno=2)
Options error: --auth-user-pass fails with 'password.txt': No such file or directory (errno=2)
Options error: Please correct these errors.
 

peberl

New Member
ja das denke ich auch
aber das problem liegt immer nur bei passwort obwohl es korekt ist

Fri Dec 11 14:33:49 2020 us=960602 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
 

helium

New Member
Ich muss mich hier mit gleichem Problem ranhängen. Die "password.txt" ist im gleichen Verzeichnis wie die config files und das PW ist korrekt.

sudo openvpn /etc/openvpn/Rotterdam.conf

ergibt bei mir:

2020-12-17 11:25:58 Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore.
2020-12-17 11:25:58 WARNING: Compression for receiving enabled. Compression has been used in the past to break encryption. Sent packets are not compressed unless "allow-compression yes" is also set.
2020-12-17 11:25:58 DEPRECATED OPTION: ncp-disable. Disabling cipher negotiation is a deprecated debug feature that will be removed in OpenVPN 2.6
2020-12-17 11:25:58 us=352540 WARNING: cannot stat file 'password.txt': No such file or directory (errno=2)
Options error: --auth-user-pass fails with 'password.txt': No such file or directory (errno=2)
Options error: Please correct these errors.
Use --help for more information.

Was kann hier los sein?
 

Honk

Junior Member
ok aber schau dir mal die Konfiguration an

Fri Dec 11 13:48:03 2020 us=271797 WARNING: file 'password.txt' is group or others accessible
sagt er zu Beginn und
Fri Dec 11 13:48:07 2020 us=687576 AUTH: Received control message: AUTH_FAILED
zum Ende.

Wie sehen deine Rechte für die Passwortdatei aus?

Bei mir funktioniert es mit
-rwx------
 

helium

New Member
Ich habe jetzt erst den vierten Beitrag (von TurboDev) wahrgenommen und tatsächlich:

[ /etc/openvpn ] sudo openvpn Somewhere.conf --> das klappt

[ / ]
sudo openvpn /etc/openvpn/Somewhere.conf --> das klappt nicht, weil password.txt nicht gefunden wird

Ist es also "amtlich", dass man immer erst ins openvpn Verzeichnis wechseln muss, um den Dienst starten zu können?
 

gumba

Junior Member
Ist es also "amtlich", dass man immer erst ins openvpn Verzeichnis wechseln muss, um den Dienst starten zu können?
Da, wie TurboDev sagt, OpenVPN die User/PW-Datei im aktiven Verzeichnis sucht, wenn in der .conf kein absoluter Pfad angegeben wurde, ja. Alternativ könntest du mal einen absoluten Verweis probieren, also in den entsprechenden Dateien auth-user-pass password.txt zu ändern in auth-user-pass /etc/openvpn/password.txt - könnte mir vorstellen, dass das dann klappt.
 
Solution

helium

New Member
Ja das klappt, da hab ich ziemlich auf dem Schlauch gestanden 👍. Vielleicht sollte das Tutorial dementsprechend folgendermaßen angepasst werden:

Alternatively this can be accomplished for all the configuration files using the following command:
sudo find /etc/openvpn/*.conf -type f -exec sed -i 's_auth-user-pass_auth-user-pass /etc/openvpn/password.txt_g' {} \;
 
Top