Geschwindigkeitsverlust mit OpenVPN - DD-WRT!

KFC372

New Member
Hallo!

Auf meinem Netgear R7000P mit : DD-WRT v3.0-r37015M kongac (09/23/18) habe ich nach Anleitung, inkl. Killswitch das VPN konfiguriert und zum Glück läuft auch alles, aber eben merklich langsamer(~15Mbit) als ohne.( habe ein 50 Mbit Anbindung welche auch ohne Probleme läuft)


Um sicher zu gehen das dass an dem Router liegt habe ich auch die PP Software für Windows getestet(selbe Serverstandorte) und dort habe ich auch den vollen Speed.

Um auszuschließen das mein Router mit der Verschlüsselung überfordert ist habe ich erstens den Load bei mehreren Downloads beobachtet(nie über 60%) und auch die AES auf 128 gesetzt(mit dem selben Ergebnis wie die AES 256)

Dürfte anscheinend an den Router Einstellungen liegen (Es gibt noch einen neuere Build für meinen Router, den werde ich noch testen, glaube aber nicht das es daran liegt)


Vorschläge Ideen was man noch einstellen könnte?

Danke!
 

ianfraser

New Member
Ich schließe mich der frage mal an. Nutze die gleiche Hardware/Software (Netgear R7000P mit : DD-WRT).

Falls du @KFC372 was neues in Erfahrung bringst wäre ich dir sehr dankbar wenn du mich auf den neueren Stand bringen könntest. :)
 

Gerd

Junior Member
@KFC372 vieles hast du ja bereits getestet, wie:

  • Verschiedene Serverstandorte
  • AES-128-CBC statt AES-256-CBC
  • Mit PP-Manager gegengetestet

Benutzt du auch LAN statt WLAN?
Hast du bei einem Bekannten mit einem anderen ISP den VPN-Speed des Routers gegengetestet?
Mal Asus Merlin ausprobiert? "Könnte" evtl. minimal beschleunigen.
Versucht unter Additional Config den OpenVPN Durchsatz zu optimieren?
Code:
fast-io
sndbuf 524288
rcvbuf 524288
push "sndbuf 524288"
push "rcvbuf 524288"
Ansonsten könnte es auch an "Hash Algorithm: SHA512" liegen. Falls diese Option der Grund für langsamere Geschwindigkeit ist, dann kann man auch nichts weiteres machen. Man könnte höchstens auf einen anderen VPN Anbieter ausweichen.
 

KFC372

New Member
@KFC372 vieles hast du ja bereits getestet, wie:

  • Verschiedene Serverstandorte
  • AES-128-CBC statt AES-256-CBC
  • Mit PP-Manager gegengetestet

Benutzt du auch LAN statt WLAN?
Hast du bei einem Bekannten mit einem anderen ISP den VPN-Speed des Routers gegengetestet?
Mal Asus Merlin ausprobiert? "Könnte" evtl. minimal beschleunigen.
Versucht unter Additional Config den OpenVPN Durchsatz zu optimieren?
Code:
fast-io
sndbuf 524288
rcvbuf 524288
push "sndbuf 524288"
push "rcvbuf 524288"
Ansonsten könnte es auch an "Hash Algorithm: SHA512" liegen. Falls diese Option der Grund für langsamere Geschwindigkeit ist, dann kann man auch nichts weiteres machen. Man könnte höchstens auf einen anderen VPN Anbieter ausweichen.


Kabel habe ich nicht getestet, nur WLAN - werde ich noch nachholen.
Einen anderen ISP kann ich mal am Wochenende ausprobieren, vorausgesetzt ich bekomme meine Router wieder zum laufen.

...der hängt gerade in einer Bootschleife :( fest(Vorsicht vor dem neuesten DD-WRT Build (37305)!).... warte auf den USB-TTL adapter...

Das mit dem Durchsatz werde ich mir noch ansehen, muss aber gestehen das ich mir jetzt einen neuen Router bestellt habe(ASUS RT-AC86U), da kommt dann Asus Merlin rauf. Werde den Alten dann verkaufen(falls ich ihn wieder hinbekomme)...


Gruß KFC372.
 

Opsecbase

Member
Kabel habe ich nicht getestet, nur WLAN - werde ich noch nachholen.
Einen anderen ISP kann ich mal am Wochenende ausprobieren, vorausgesetzt ich bekomme meine Router wieder zum laufen.

...der hängt gerade in einer Bootschleife :( fest(Vorsicht vor dem neuesten DD-WRT Build (37305)!).... warte auf den USB-TTL adapter...

Das mit dem Durchsatz werde ich mir noch ansehen, muss aber gestehen das ich mir jetzt einen neuen Router bestellt habe(ASUS RT-AC86U), da kommt dann Asus Merlin rauf. Werde den Alten dann verkaufen(falls ich ihn wieder hinbekomme)...


Gruß KFC372.
Dein neuer Router wird dir viel Spaß machen, falls du Hilfe bei der Einrichtung benötigst, schreib unter dem Beitrag bezgüglich RT-AC86U, hab den auch seit ner Woche, der ist einfach nur super.
 

KFC372

New Member
Kurzes Update...


Der ASUS RT-AC86U ist inzwischen angekommen, eingerichtet und läuft, und siehe da -> Geschwindigkeit über VPN TOP! Kein Unterschied mehr zwischen "ohne und mit" VPN.

Lag wahrscheinlich wirklich am DD-WRT für den R7000P.

Den habe ich inzwischen auch wieder zum Laufen bekommen, nachdem der TTL Adapter nach einer gefühlten Ewigkeit doch noch angekommen ist, wen es interessiert -> https://www.myopenrouter.com/articl...-netgear-r7000-r6300v2-or-r6250-wi-fi-routers

Soweit alles gut, einzig das "Accept DNS Configuration = strict" funktioniert nicht (Asus Merlin 384.9), wobei zwar im Changelog:

..."
- CHANGED: No longer accept any server-provided route
when OpenVPN client set to Policy (Strict)

- FIXED: "Strict" DNS mode wasn't working properly with OpenVPN
clients
"....
angeführt ist. (werde das mal extra posten, vielleicht weiß jemand etwas dazu)

...
 
Last edited:
Top