Beantwortet: Geschwindigkeits-Probleme

anonymos

Junior Member
Moin,

bin seit Jahren zufriedener Perfect-Privacy-Nutzer, um das Positive direkt mal vorweg zu erwähnen!

System:
- Windows 10 Pro 64 Bit (frisch aufgesetzt)
- Aktueller Perfect-Privacy-Manager, default settings (nur Firewall und DNS-Leak habe ich auf dauerhaft gesetzt)
- Kein CCleaner oder ähnliches
- Avira Antivirus (macht ausgeschaltet allerdings keinen Unterschied)

Internet:
- Vodafone Kabel 32Mbit

Allerdings habe ich Probleme mit der Geschwindigkeit und ich habe mich jetzt mal zum Posten entschieden, da ich just mein System komplett neu aufgesetzt habe und ich so jedenfalls denke ausschließen zu können, dass mir irgendwas das System zerschossen hat.

Problem:
Ohne VPN kommen die 32 Mbits komplett durch - alles gut.
Mit VPN (OpenVPN) kommen nur etwa 22 Mbits im PP-Manager durch (mit dem OpenVPN-Client genauso wenig). Und zwar unabhängig vom VPN-Server. Der Upload passt mit 2 Mbits.
Wähle ich nun bspw. IPSEC (welches ich eigentlich gar nicht nutzen möchte), ist das zwar deutlich schneller, aber ich kann z.B. Seiten wie spiegel.de oder golem.de einfach nicht mehr nutzen - sie bauen sich schlicht nicht mehr auf. Die meisten anderen funktionieren. Ich habe keine Ahnung warum, das ist bei mir auch unabhängig vom Browser.

Frage 1:
Habe ich irgendwie die Möglichkeit, unter OpenVPN im PP-Manager meine Download-Geschwindigkeit zu erhöhen, bzw. woran liegt es, dass nur 22 statt 32 Mbits ankommen?

Frage 2:
Wieso zur Hölle laden manche Websites unter IPSEC einfach nicht mehr?


Über Rückmeldungen wäre ich sehr dankbar!

Gruß
anonymos
 

PP Frank

Staff member
Habe ich irgendwie die Möglichkeit, unter OpenVPN im PP-Manager meine Download-Geschwindigkeit zu erhöhen, bzw. woran liegt es, dass nur 22 statt 32 Mbits ankommen?

Du könntest es mit StealthVPN versuchen. Bei Vielen hilft da OBFSproxy3.

Wieso zur Hölle laden manche Websites unter IPSEC einfach nicht mehr?

Gute Frage. Mal zwei verschiedene Server probiert? Die Windows-Firewall mal auf Standard zurück gesetzt? Ist TrackStop aktiviert? Sind die DNS-Server im Manager fest gesetzt, oder bekommst du diese zufällig?
 

anonymos

Junior Member
Du könntest es mit StealthVPN versuchen. Bei Vielen hilft da OBFSproxy3.



Gute Frage. Mal zwei verschiedene Server probiert? Die Windows-Firewall mal auf Standard zurück gesetzt? Ist TrackStop aktiviert? Sind die DNS-Server im Manager fest gesetzt, oder bekommst du diese zufällig?

Erst mal vielen Dank für die Antwort!

Zu OpenVPN:
Habe es mit StealthVPN und OBFSproxy3 versucht. Die Geschwindigkeit schwankt damit dann relativ stark (zwischen 15 und 30 Mbits), im Mittel landet sie aber meist so bei 25 Mbits. Scheint also einen geringen, wenn auch unbeständigen, Geschwindigkeitszuwachs zu geben.
Habe es übrigens zusätzlich noch an einem anderen PC hier getestet, gleiches Ergebnis vorher und nachher.
Vielleicht ist meine Frage ja naiv und mir fehlt eventuell auch das technische Hintergrundwissen, aber woran kann das liegen, dass im VPN unter OpenVPN nicht so viel durchkommt - auch mit OBFSproxy3 nur ein bisschen mehr?

Ein Kumpel von mir ist auch bei euch und hat ebenfalls das Internet über Kabel von Vodafone (er hat aber ne 100er Leitung) und bei ihm kommen auch "nur" etwa 50 Mbits mit ähnlichem Setup an.
50 Mbits sind natürlich für den Alltag mehr als genug. Aber muss ich daraus schlussfolgern, dass ich auch eine 100er Leitung bräuchte um meinen Download-Speed (zwar mit deutlichen Verlusten, aber immerhin) erhöhen zu können?


Zu IPSEC:
Habe erfolglos verschiedene Server ausporibert und ebenfalls erfolglos die Windows-Firewall zurückgesetzt.
TrackStop ist nicht aktiviert, DNS-Server bekomme ich zufällig.

Gruß
anonymos
 

PP Frank

Staff member
Zu IPSEC:
Habe erfolglos verschiedene Server ausporibert und ebenfalls erfolglos die Windows-Firewall zurückgesetzt.
TrackStop ist nicht aktiviert, DNS-Server bekomme ich zufällig.

Kommt leider recht häufig vor. Liegt in den meisten Fällen and defekten Windowsinstallationen. Woran genau konnten wir bisher nicht nachvollziehen...



Wegen dem Speed.
Ist eine gute Frage. Kann immer an allem möglichen liegen. Vom verwendeten Router, bis hin zum ISP. Also bei einer 50iger Leitung sollten schon mit OpenVPN so 40 MBit übrigbleiben. Bei 100 MBit so um die 70 bis 75 MBit. Bei deiner Beschreibung scheint das an Vodafone zu liegen.
Versuch bei StealthVPN mal SSH und Port 22 zu nutzen. Wie sieht das dann aus?
 

anonymos

Junior Member
Kommt leider recht häufig vor. Liegt in den meisten Fällen and defekten Windowsinstallationen. Woran genau konnten wir bisher nicht nachvollziehen...



Wegen dem Speed.
Ist eine gute Frage. Kann immer an allem möglichen liegen. Vom verwendeten Router, bis hin zum ISP. Also bei einer 50iger Leitung sollten schon mit OpenVPN so 40 MBit übrigbleiben. Bei 100 MBit so um die 70 bis 75 MBit. Bei deiner Beschreibung scheint das an Vodafone zu liegen.
Versuch bei StealthVPN mal SSH und Port 22 zu nutzen. Wie sieht das dann aus?

Habe eine FRITZ!Box 6490 Cable, liegt es daran? Oder ist es Vodafone? Kann Kabel sonst von keinem anderen Anbieter bekommen und von maximal verfügbarem DSL 16.000 sehe ich hier nur 12k.
StealthVPN über SSH und Port 22 ist noch langsamer als ohne OBFSproxy3.
Habe noch mal mit und ohne OBFSproxy3 in verschiedenen Szenarien nachgemessen. Ohne sind es konstant etwa 20 Mbits, während es mit etwa 22 Mbits sind (stark schwankend).
Trotz einer 32er Leitung reicht mir das zwar natürlich auch im Alltag, allerdings kommt man selbst damit ja heutzutage auch schon an die Grenzen, wenn meine Freundin auf dem Laptop und ich am PC gerade mal zufällig zeitgleich ein hochauflösendes Video bei youtube ansehen.
Dass da teilweise 10 Mbits mehr drin sein könnten finde ich einfach super ärgerlich.
Kann ich noch etwas anderes tun, um den Speed anzukurbeln oder dem Problem auf den Grund zu gehen?
 

UPhmWgXe33g9

New Member
Ich würde es testweise über IKEv2 versuchen.
Da ich aber kein Windows nutze, weiß ich nicht wie das dort mit VPN-Manager ist. Ich denke man muss hier zunächst die Zertifikate per PP-Installer einbinden, lasse mich da aber auch gerne korrigieren.

Aber IKEv2 hat i.d.R. einen sehr guten Bumms.
 

anonymos

Junior Member
Bekommst du nach einer Weile irgendwelche Fehler im Verbindungslog? Ansonsten kann ich auch nur ins Blaue raten
Ich bekomme keinerlei Fehlermeldungen..
Tatsächlich wäre ich sehr dankbar dafür, wenn du ins Blaue für mich raten würdest, da ich sonst ratlos bin. Ist jetzt natürlich alles kein Weltuntergang, aber ich wollte auch nicht als irgendwie doofe Notlösung womöglich auch noch für umsonst bzw. gegen Aufpreis meinen Tarif monatelang upgraden.

Ich würde es testweise über IKEv2 versuchen.
Da ich aber kein Windows nutze, weiß ich nicht wie das dort mit VPN-Manager ist. Ich denke man muss hier zunächst die Zertifikate per PP-Installer einbinden, lasse mich da aber auch gerne korrigieren.

Aber IKEv2 hat i.d.R. einen sehr guten Bumms.
Danke für den Hinweis, aber ich würde schon ganz gerne den Manager oder etwas ähnlich komfortables nutzen.
 

PP Frank

Staff member
Lass die Verbindung mal einen Tag durchlaufen.... Einfach gucken ob irgendwas kommt.
Ansonsten: Router mal neu starten, Firewall auf dem Ding prüfen, testweise abschalten(nur zum Testen).....


Andere Server versuchen.....
 

UPhmWgXe33g9

New Member
Andere Idee: PP unterstützt Cipher neogitation. D.h. einfach ausgedrückt, man kann die Verschlüsselung beim sogenannten Cipher anpassen. Das gibt der Manager soweit ich das gesehen habe in den "Programm-Einstellungen" ja her.
Standard ist AES-256-CBC, das könnte man auf AES-128CBC setzen und gilt immer noch als sicher. Zeitgleich ggf. auch prüfen, das in den Einstellungen TCP nicht aktiviert ist.

Bzgl. Cipher hatte ich in einem anderen Thread angemerkt, dass beim Connect eine Inkonsistenz auftaucht (in den Logs), aber gem. Rückmeldung würde trotzdem der selbst gewählte Cipher genutzt.
 

anonymos

Junior Member
Lass die Verbindung mal einen Tag durchlaufen.... Einfach gucken ob irgendwas kommt.
Ansonsten: Router mal neu starten, Firewall auf dem Ding prüfen, testweise abschalten(nur zum Testen).....


Andere Server versuchen.....
Router neugestartet, Firewall testweise abgeschaltet. Macht keinen Unterschied.
Server habe ich schon in Hülle und Fülle getestet. Bislang gab es keinen, der über 24 Mbits hinausging.

Andere Idee: PP unterstützt Cipher neogitation. D.h. einfach ausgedrückt, man kann die Verschlüsselung beim sogenannten Cipher anpassen. Das gibt der Manager soweit ich das gesehen habe in den "Programm-Einstellungen" ja her.
Standard ist AES-256-CBC, das könnte man auf AES-128CBC setzen und gilt immer noch als sicher. Zeitgleich ggf. auch prüfen, das in den Einstellungen TCP nicht aktiviert ist.

Bzgl. Cipher hatte ich in einem anderen Thread angemerkt, dass beim Connect eine Inkonsistenz auftaucht (in den Logs), aber gem. Rückmeldung würde trotzdem der selbst gewählte Cipher genutzt.
Danke für den Ratschlag! Hatte ich schon seit einiger Zeit probiert und nur so erreiche ich die 24 Mbits überhaupt (hätte ich vielleicht erwähnen können). Bei 256 sind es etwa 20 Mbits.
TCP ist natürlich nicht aktiviert.

Früher (bis vor einigen Wochen oder noch vor Monaten) hatte ich mit TCP jedoch tatsächlich mehr Speed (so bis zu 26 Mbits etwa) und UDP war langsamer. Das ist inzwischen nicht mehr so.
Im Übrigen habe ich vorhin festgestellt, dass IPSEC auch keinen Geschwindigkeitsvorteil mehr bietet (das hatte ich aufgrund einers früheren Tests einfach mal gemutmaßt).

IKEv2 habe ich aus Spaß an der Freude nun auch mal getestet, es bringt ebenfalls keinen Geschwindigkeitsvorteil gegenüber sonstigen VPN-Setups.
o_O
 

alter-falter

Junior Member
Meine Erfahrung zur Geschwindigkeit. Mittlerweile habe ich VDSL mit 100mbit Down und 30mbit up.. Ohne VPN.
Mit Open VPN habe ich meist um die 80-85Mbit im Download und 20mbit im Upload.Mit Ipsec 95 mbit im Down und 25 im Upload,

Also Geschwindigkeitseibußen sind normal. bei Open VPN etwas höher.

Wenn ich über 2 Server laufen lasse sind es meist noch 60mbit im Download. Bei der Geschwindigkeitsmessung hier sogar mehr,über Calais und Steinsel.

Nicht schlecht
 

Attachments

  • Unbenannt.PNG
    Unbenannt.PNG
    77.3 KB · Views: 5
Last edited:

anonymos

Junior Member
Das klingt aber schon komisch. Spätestens mit IKEV2 muss die Leitung volles Rohr bringen..... Ich baller damit hier mit 110 von 128 Mbit durch....
Habe IKEv2 noch mal mit anderen Servern getestet. Tatsächlich ist es damit etwas schneller als mit OpenVPN oder IPsec, komme auf etwa 26-27 Mbits.

Meine Erfahrung zur Geschwindigkeit. Mittlerweile habe ich VDSL mit 100mbit Down und 30mbit up.. Ohne VPN.
Mit Open VPN habe ich meist um die 80-85Mbit im Download und 20mbit im Upload.Mit Ipsec 95 mbit im Down und 25 im Upload,

Also Geschwindigkeitseibußen sind normal. bei Open VPN etwas höher.

Wenn ich über 2 Server laufen lasse sind es meist noch 60mbit im Download. Bei der Geschwindigkeitsmessung hier sogar mehr,über Calais und Steinsel.

Nicht schlecht
Danke für deinen Erfahrungsbericht.
Meine einzige Erklärung für die höheren Einbußen bei meinem Kumpel und mir ist eigentlich nur noch Vodafone oder die FRITZ!Box 6490 Cable..
 

alter-falter

Junior Member
Fritz Box 7490 habe ich. Und die läuft eigentlich super. Das Teil hängt sich nicht auf und die Verbidungen sind immer stabil.

Bezüglich Vodafone Probleme habe ich schon gehört. Aber es ist auch teilweise so wie Frank es formuliert. Es gibt regional Ecken, wo manche Server beim einen besser laufen und bei anderen weniger.
Also Amsterdam-Rotterdam-Steinsel-Calais-Zürich sowie Nürnberg laufen eigentlich immer super bei mir. Nur Nürnberg ist halt gern mal überlastet......

Seit dem Umstieg auf VDSL wegen des Ausbaus läuft alles generell besser. Telekom ausnahmsweise mal nicht der böse Bube,-)
 

alter-falter

Junior Member
Kann das sein!!!!???? Habe eben gerade nen DSL Speedtest gemacht. Über den Server Frankfurt mit Open VPN habe ich 133mbit Download!

Ich habe aber nur eine 100mbit Anbindung über VDSL .... ist das nicht gedrosselt??? Ab 100 mbit Schluss??

Siehe Anhangspeedtest.PNG
 

Gerhard

Junior Member
ich habe eine 400 Mbit Leitung mit 20 Mbit Upload.

Ohne PP Manager komme ich auf sogar 430 Mbit.

Schalte ich PP ein, 2-Fach Hoop komme ich gerade mal auf 58 Mbit.
 
Top