Dns wird immer geleakt

Discussion in 'Linux' started by masto33, Nov 7, 2017.

  1. m

    masto33 New Member

    Hallo,

    Ich benutze Ubuntu und habe den Perfect Privacy Client installiert.
    Leider wird ständig meine dns geleakt.
    Was kann ich da tun?

    Außerdem ist mir aufgefallen das ich im linux client nur wenig einstellungen treffen kann. Im vergleich zum windows client.

    Deshalb habe ich eine Win VM laufen in dem ich den client nochmal installiert habe. Dabei wurde meine DNS adresse nicht geleakt. Also muss es ja am Linux PP manger liegen

    Ich bitte dringend um Hilfe!
     
  2. M

    Morbis55 Active Member

    Ubuntu hat seit längerem standardmäßig einen DNS Leak.
    Bis vor kurzem konnte man im network manager in den Optionen des verwendeten Netzwerks unter "ipv4"
    bei der Methode "Automatisch (DHCP), nur Adressen" einstellen. Danach gibt es keinen Leak mehr.
    Allerdings gab es vor kurzem ein Update und dann konnte man gar keine Verbindung mehr aufbauen. Das klappt also nicht mehr.

    Die einzige Lösung die ich bisher gefunden habe ist manuell die DNS zu setzen, also einfach zB von OpenDNS.
    (Oder du stellst im Router direkt eine feste DNS ein)
    Beim DNS Leak Test wird dann sowohl die DNS von PP als auch von OpenDNS erkannt. Nichts was Schlüsse über deine Identität zulässt.
    Nicht 100% perfekt, hier sollte PP endlich selbst tätig werden und einen DNS Leak schutz integrieren, aber man kann damit leben.
     
  3. m

    masto33 New Member

    Danke für die antwort. Aber ich kann unter dem Linux client auch keinen dns auswählen. aber unter den win client schon.

    Ist das normal das der PP linux client so gut wie keine einstellungs möglichkeiten hat?
     
  4. p

    paranoia New Member

    Du kannst openvpn in der Komandozeile starten. Dann hast du kein DNS Leak.

    Der PP Manager hat keine Priorität weil die Masse der Kunden Windows und Mac nutzt.
     
  5. r

    rockweapon New Member

    @Morbis55
    Wo setzt du die OpenDNS bei dir manuell bzw. warum werden dir diese neben den PP-DNS noch angezeigt?

    Habe die openvpn-Verbindung über Konsole aufgebaut aber ist eig. bei mir egal ob über Konsole oder über NetworkManager, das gleiche kommt raus.
    Bei mir werden nach Verbindungsaufbau über whoer.net, ipleak.net oder Perfect Privacy DNS Leak Test nur der DNS-Server von PP angezeigt. Das ist auch gut so, aber ursprünglich wollte ichs so wie bei dir haben, sprich dass neben den PP-Servern auch die Google-DNS angezeigt werden.

    Ich benutze Arch und pushe mithilfe der updaete-resolv-conf die Google-DNS-Server nach den 2 Perfect Privacy DNS-Servern.

    Siehe etc/openvpn/update-resolv-conf
    Code:
    foreign_option_3='dhcp-option DNS 8.8.8.8'
     foreign_option_4='dhcp-option DNS 8.8.4.4'
     foreign_option_5='dhcp-option DNS 2001:4860:4860::8888'
     foreign_option_6='dhcp-option DNS 2001:4860:4860::8844'
    
    In der etc/resolv.conf steht dann nach Verbindungsaufbau:
    Code:
    # Generated by resolvconf
    nameserver 92.43.104.78
    nameserver 217.114.218.30
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    nameserver 2001:4860:4860::8888
    nameserver 2001:4860:4860::8844
    
    Würde ich die google-dns mit der foreign_option in der /etc/openvpn/update-resolv-conf an 1,2,3 und 4. Stelle setzen, sieht es in der /etc/resolv.conf so aus:
    Code:
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    nameserver 2001:4860:4860::8888
    nameserver 2001:4860:4860::8844
    
    Über nslookup zeigt er mir dann auch die 8.8.8.8 als Rückgabe an, aber über Whoer.net, ipleak.net und PP wird mir trotzdem nur der PP-DNS angezeigt.
    Also eigentlich egal wo ich welchen DNS setze, er leakt nicht und zeigt nur den PP-DNS an.

    Unter Windows gibt es die openvpn-Option block-outside-dns, die verhindert, dass DNS außerhalb des VPNs genommen wird.
    Sprich wenn man in den WLAN-Adapter und TAPv9 Adapter primär und sekundär google-dns server setzt, dann werden diese durch diese Option über whoer.net, ipleak.net und PP ausgeblendet bzw. nicht erkannt und nur der PP-DNS angezeigt. Über nslookup unter Windows wird mir der IPv6 Google-DNS dann angezeigt, wenn ich diesen in die Adapter-Einstellungen setzte. Kann mir dieses Verhalten nicht erklären, warum Seiten wie whoer.net, ipleak.net und PP diese DNS-Server ausblenden, aber über nslookup dann ein anderer Server in der Konsole angezeigt wird. Nehme ich diese Option block-outside-dns aus der Windows-Config raus, dann zeigt er mir auch die Google-DNS-Server an, also immer noch kein Leak.

    Habe hierzu schon folgenden Beitrag geschrieben, leider hat noch keiner geantwortet:
    https://board.perfect-privacy.com/t...penvpn-auf-der-linux-konsole.1534/#post-19987
     
  6. M

    Morbis55 Active Member

    Aktuell habe ich im Router die OpenDNS IPs eingetragen, aber es geht auch im (grafischen) Network Manager.
    Dort gibt es "zusätzliche DNS-Server", das hat den gleichen Effekt , also OpenDNS + PP (wenn man per VPN verbunden ist)

    Vorher habe ich unter "ipv4" einfach "automatisch DHCP, nur adressen" ingestellt und das hatte den gleichen Effekt,
    wie bei dir, sodass NUR die DNS von PP angezeigt wurde
     
  7. r

    rockweapon New Member

    Das klappt bei mir irgendwie nicht. Wie sieht denn deine /etc/resolv.conf aus?
    Benutzt du die update-resolv-conf in /etc/openvpn?
    Sind in deiner client.conf die up, down zur update-resolv.conf und script-security 2 Zeile vorhanden?
    Hast du in deiner /etc/NetworkManager/NetworkManager.conf die Zeile:
    Code:
    [main]
    dns=none
    
    gesetzt?
    Dies verhindert, dass der NetzworkManager die /etc/resolv.conf überschreibt.
    Wenn ich die zusätzlichen DNS in meiner normalen Netzwerkverbindung setze (ohne vpn), zeigt er mir diese neben meiner vom ISP gegebenen DNS auch an. Wenn ich das überschreiben durch NetworkManager mit dns=none verhindere und in der /etc/resolv.conf
    Code:
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    nameserver 2001:4860:4860::8888
    nameserver 2001:4860:4860::8844
    
    setze, dann werden auch nur diese genommen.
    Nur bei der VPN-Verbindung, sei es durch Konsole oder durch die NetworkManager Gui mit zusätzlichen DNS-Servern von Google, klappt einfach nicht.

    Also bevor ich hier weiter alles aufzähle was ich probiert habe (alle erdenklichen Szenarien). Wie siehts bei dir aus?

    Es klappt nur, wenn ich an meinem Router die google dns als globale DNS nehme, dann VPN-Verbindung über Konsole oder NetworkManager aufbaue (dns=none Zeile in /etc/NetworkManager/NetworkManager.conf entferne). Dann wird mir neben PP DNS auch google dns angezeigt, ist ja klar, weil er dann über den lokalen DNS vom Router auf die globalen verweist.

    Danke

    Gruß

    rockweapon
     
    Last edited: Nov 8, 2017
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice