Certificate verification failed

krischperl

New Member
Hallo zusammen,

1)
Mein Debian 10 Debian ist aktuell, PerfectPrivacy hat bereits die Config-Version: 1590491490 und die Softwareversion 1.3.15.
Beim heutigen apt update bekomme zu PerfectPrivacy die Meldung:

Certificate verification failed: The certificate is NOT trusted.
The certificate chain uses expired certificate.
Could not handshake: Error in the certificate verification. [IP: 31.204.150.121 443]
Paketlisten werden gelesen... Fertig
E: Das Depot »https://www.perfect-privacy.com/repos/linux/debian perfect-privacy-vpn Release« enthält keine Release-Datei mehr.

2)
Daraufhin habe ich perfect-privacy-vpn.deb nochmal heruntergeladen und mit sha256sum geprüft. (Ich wollte das Programm neu installieren)
Ergebnis: Die sha256-Prüfsumme passt nicht

ich bin ratlos
 

khubenbecker

New Member
Beim MacOS Client gibt es auch Probleme mit dem Zertifikat beim Config & Update Checker...

[2020-05-31 23:35:12] DEBUG: central_requester: requesting (GET): https://www.perfect-privacy.com/downloads_public/VPNManager_Mac_configbundle2.zip.version, headers: {}, direct access enabled: True
[2020-05-31 23:35:12] DEBUG: urllib3.connectionpool: Starting new HTTPS connection (2): www.perfect-privacy.com
[2020-05-31 23:35:12] DEBUG: ConfigUpdater: checking for updates failed
[2020-05-31 23:35:12] DEBUG: UpdaterState: update state changed to: 'Config update failed (Connection error: HTTPSConnectionPool(host='www.perfect-privacy.com', port=443): Max retries exceeded with url: /downloads_public/VPNManager_Mac_configbundle2.zip.version (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:720)'),)))'
[2020-05-31 23:35:12] INFO: ConfigUpdater: Config update failed (Connection error: HTTPSConnectionPool(host='www.perfect-privacy.com', port=443): Max retries exceeded with url: /downloads_public/VPNManager_Mac_configbundle2.zip.version (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:720)'),)))
[2020-05-31 23:35:12] DEBUG: ConfigUpdater: removing temporary download directory at: /tmp/tmp4suvfzee
[2020-05-31 23:35:12] DEBUG: ConfigUpdater: error while checking for updates, retry in 300 seconds
 
hmmm,also gestern mittag hatte ich genau das gleiche am laptop und da gings dann in dem ich hergegangen bin und mir die file von der hp hier gezogen hab. einfach per hand drübergerumpelt und es ging. danach dann noch ebend upgrade übers terminal und alles war geritzt. Hier am rechner gehts jetz auch nicht mehr, habs grad nebenbei hier versucht. Werdn wir warten müssen bis unsre Jungs das hingebogen ham.
 

Zero

Junior Member
unter Linux Mint das gleiche Problem:


Code:
Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Fehler bei der Verifizierung des Zertifikats.
E: Das Depot »https://www.perfect-privacy.com/repos/linux/debian perfect-privacy-ssh Release« enthält keine Release-Datei mehr.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).
 
Top